Previous 1 2 3 4 Next 45 Replies Latest reply: Jul 24, 2015 12:44 PM by SRKfromfremont Go to original post
  • dogschool Level 1 Level 1 (0 points)

    Same here...on my 3rd new MBA and even with bluetooth turned off it stil lags and drops wi-fi. Put a call into the higher level support yesterday and had to leave a message...no call back yet...probably busy..

  • jamesmcd03 Level 1 Level 1 (0 points)

    Having the same problems with BT connected. Tried different channels 1-15 no luck. If I turn BT off it works but I use the apple BT keyboard and mouse.

     

    Any solutions?

  • gkubisak Level 1 Level 1 (0 points)

    I have had the same issue with the 2007 Apple Wireless Keyboard and 2009 Apple Magic Trackpad connected.  With Wireless Diagnostics Utilities running, I notice that the wireless signal degrades when the bluetooth device is actually transmitting to the computer.  I can stand right next to the router and not experience disconnection, but can see a significant drop in signal.  Besides, it is impractical to stand next to the router with a wireless keyboard and trackpad.  Without bluetooth devices connected, Wireless Diagnostics Utilities indicates wifi quality is Excellent in my office.  With devices connected, it hovers around Good, then degrades to Poor when the devices are transmitting to the MBA.  I have also tried all channels in the 2.4 GHz range, PRAM and SMC resets, and cursing - all with no success.

     

    This is my second new MBA.  I returned the first after experiencing issues with wifi/bluetooth and inability to connect to iPad via USB.  I retested with a fresh system, after performing upgrades, and after restoring with a Time Machine backup.  The issues remain.  Apple support is trying to say that it is an issue with my network since this has happened with two MBAs.  It is my contention that there is something flawed in the design of the MBA because I do not experience this issue with my 2008 Macbook on the same network, and this has happened with two different routers (ASUS RT-N10+ and D-Link AC750) as well as with a range extender.  I will be testing this on my work network later today.

     

    I am entering my third week of dealing with Apple Support, and am getting a little frustrated.  I am currently in contact with Tier 2 support and have submitted logs, which I am told will be given to engineering to analyze.  I should hear back sometime in the middle of the week. 

  • rjcollins Level 1 Level 1 (0 points)

    Thanks mate, this fixed my issue too! :-)

  • cwebber1 Level 1 Level 1 (30 points)
  • gkubisak Level 1 Level 1 (0 points)

    OK.  I have worked my way through tier 2 support.  Engineering is convinced that it is environmental (i.e. my router signal is not strong enough). I took the MBA to an authorized repair center, and they ran diagnostics.  I was told the hardware is working "as designed."  They could not duplicate the issue in the store, but the technician acknowledged that he was standing next to the router.  It works fine standing next to my router also; however, this is obviously not practical.

     

    I have yet to call support back.  I'm sure that since the hardware is working "as designed," Apple will not acknowledge a design flaw.  I am certainly frustrated that a device that is supposed to be entirely wireless cannot be used with wireless peripherals except under the most unrealistic conditions.

     

    I have upgraded to Mavericks and hoped this would somehow solve the issue, but it has not.  I'm still hoping for a resolution that does not end up with me buying yet another router.

  • sbaker@osd Level 1 Level 1 (0 points)

    For our MBAs, upgrading to 10.8.4 or 10.8.5 seems to have resolved the issue.  They operate more reliably on the 5ghz band, which has a shorter range than 2.4.  We did have to up the number of wireless APs in our highschools (we now have 50 for ~600 concurrent connections), so signal strength definitely makes a difference.  It is possible those of you still having the issue may need to get a more powerful wireless router (ours are $500 each).  It definitely is not ideal for home users who don't have tech budgets!

  • famora1979 Level 1 Level 1 (0 points)

    alguem tentou usar bluetooth com o magsafe conectado?

     

     

    bluetooth fica com o sinal mais fraco...

     

     

    se ativar o wifi fica mais devagar ainda...

     

     

    será que é por causa que esta tudo no lado esquerdo do macbook air?

     

     

    alguem pode confirmar isso?

     

     

    MBA 2013+magicmouse

  • ChemicalElectric Level 1 Level 1 (0 points)

    *HERE YOU GO LADIES & GENTS!!!!* AFTER trying unsuccessfully ALMOST every method in regards to resetting the router, changing channels and anything to do with reconfiguring the IP or network due to bluetooth interfering with wifi, the solution was much easier..... 

     

    This bluetooth interfering with wifi occurred shortly after I upgraded to the latest IOS

     

    Go to SETTINGS icon

    1) Go to Bluetooth settings (make sure keyboard, speaker or any bluetooth apparatus that you are trying to connect to is off) click on the the (i) icon to the right of the keyboard, speaker that is listed on your Mac or IPad, select " Forget this Device".

     

    2) Go to General settings scroll down to the bottom, click on RESET and select "Reset all Settings".

     

    3) Rebooting will begin- no data will be lost.

     

    4) Go to Bluetooth settings enable bluetooth and pair with your BT apparatus *PRESTO* that will do the trick.

     

    This should save you some time searching through all the forums for the solution, this page seems to have a higher ranking than the other where the solution was listed.

     

    Credits to stoopskc & DrBennett68 for the original posting.

  • bacid90210 Level 1 Level 1 (0 points)

    SIMPLE SOLUTION:

     

    i just changed my Routers Settings from 802.11gn to 802.11g and from Channel 11 to 5.

     

    Now everything works fine.

  • cwebber1 Level 1 Level 1 (30 points)

    I wouldn't go so far as to call this a "solution".

    Turning off the router will make the problem go away too, but that's no solution.

  • Anonymous61073 Level 1 Level 1 (0 points)

    How would I get to my WiFi configuration page to change a channel?  This Magic Mouse / MacBook Air conflict is ridiculous.  I can't even surf the web with it.  I have to use my cheap Logitech mouse -- that works 1,000 x better than this expensive thing!

  • alitaliano Level 1 Level 1 (0 points)

    Hi,

    did you try this workaround  ?

     

    ow that a couple folks have verified the workaround, here it is:

     

    sudo defaults write /Library/Preferences/com.apple.airport.bt.plist bluetoothCoexMgmt Hybrid

    Then you need to reboot. I've tried and thus far failed to find a way to make this take effect without a reboot.

     

    Background: after a lot of snooping and head scratching, here's what I found: the issue here seems to be that the system isn't using the same Bluetooth/Airport coexistance mode for BLE as it uses for BT Classic. One tell tale sign: if you have any BT Classic devices connected and active, the bug won't repro (neither for the Classic device nor any connected BLE device). The moment the Classic device disconnects, the bug repros (ie all the BLE connections are also dropped).

    Further, I was able to find reference in the symbol table of an airport configd agent to an override setting for the coexistance mode. If you set the mode manually as above to 'hybrid' (the same mode that is usually invoked when a classic device is connected), the bug no longer repros.

     

     

     

    I'm not sure if it works as I didn't try… But I do have the same problems with Wifi and Bluetooth on my MBA.

     

    Seen here :

    http://lists.apple.com/archives/bluetooth-dev/2013/Aug/msg00023.html

  • alitaliano Level 1 Level 1 (0 points)

    Hi,

    I tried this workaround and it worked !

    I have no more problems with bluetooth et WiFi on my MBA 2013.

    Just try !

  • NoxDiurna Level 1 Level 1 (0 points)

    This really works for the Wifi/BT interference but since I did the little maneuver, my Magic Mouse seems to lag, especially when Safari is loading a page.