12 Replies Latest reply: Nov 21, 2013 9:14 AM by sbuchan55
atenati Level 1 (0 points)
So this is my second time posting the following, as it got deleted and completely disappeared (even from my own posts in my profile).

I own a 13" white 2007 MacBook:

Model Name: MacBook
Model Identifier: MacBook2,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 4 GB
Bus Speed: 667 MHz
Boot ROM Version: MB21.00A5.B07
SMC Version (system): 1.17f0

My girlfriend has a brand new MacBook Pro from this summer.
Both our computers suddenly started behaving weirdly about a week ago. I'm writing now on 5% batter power so I'll make it short. We have tried everything but our chargers just don't work properly. We have about 3 chargers and 5 heads/cords and all combinations have failed to yield result more than once. I have restarted my computer, taken the battery out, restarted PR-things and SMC and I have cleaned the heads and I have even tried to install an update from Apple but it told me my mac didn't need this update.
So what the * is wrong with the magsafes? It's a real pain because we can have them working for many hours as long as we don't touch them - then if we move or want to unplug the charger for even just 1 second, they might not work again for 2 days.

So please help us. We're both writing our BA theses and need our computers working. Thanks!

PS: I received a message telling me this was a duplicate but it is not the same issue addressed by most people here because we are using both L and T shaped magsafes and it makes absolutely no difference. Both behave stupidly.

macbook, Mac OS X (10.6.4)