Skip navigation

Cannot delete phantom files which just appeared on desktop - no extensions

81660 Views 82 Replies Latest reply: Mar 26, 2014 7:40 PM by quits RSS
1 2 3 ... 6 Previous Next
MA2011 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 23, 2011 6:43 PM
Two files have appeared on my desktop. 16E7C000 and 24FD5200. The icons look like a little excel or keynote file with a green top bar. I cannot move them anywhere else on the desktop, Finder cannot find them and when trying to delete or move them to trash - a message comes up saying "The item "24FD5200" can't be moved to the Trash because it can't be deleted.

Does anyone know what they are and what I can do to get rid of them? Thank you!
Macbook, Mac OS X (10.6.4)
  • oldscribe Level 1 Level 1 (50 points)
    Hi,

    A few questions,

    1.Did you download them or were they downloaded.
    2.If you highlight then click then file and get info what is the result re file type.
    3.Have you tried terminal commands.
    Macbook, Mac OS X (10.6.6), iPod - iPhone
  • EdVG Level 1 Level 1 (0 points)
    Same thing has happened to me, a file that is named by numbers appeared on my desktop and it cannot be deleted. It is an xlsx file - Open Office sort excel, as the file in this message seems to refer as well. I don't think I have downloaded it and I have no idea of what it is, I just want to delete it!

    As for oldscribe's question 3, I don't understand what a terminal command is - my bad! I know when I try to drag the file to the trash it says it "cannot be deleted". I have found a few threads with this problem, but no answer as yet. Hope someone can help!

    Cheers
    MacBook6,1
  • EdVG Level 1 Level 1 (0 points)
    Same thing (or a very similar thing) has happened to me. Numbered files that look like excel ones - but are xlsx and, apparently, open office ones - turned up on my desktop and I cannot delete them. Have you got a solution for that?
    Best wishes
    MacBook6,1
  • mberardinelli Level 1 Level 1 (30 points)
    Sounds like these files may have permissions that are preventing you from deleting them.

    You can try using Terminal to delete them as follows:

    1. Open Terminal
    2. Type "sudo rm -f " (without the quotes and with a space after the f) and then click and drag the file into the terminal window (that will automatically "type" the path of the file for you).
    3. Hit enter. It will prompt you for your password. Type it in and hit enter again.

    If that does not work, right-click on the file and choose Get Info. At the bottom of the Get Info window you will see a section called "Sharing and Permissions." If you expand that section (click the little black triangle), can you tell me what the permissions say?
    MacBook Pro, Mac OS X (10.6.7)
  • yaleforce Level 1 Level 1 (0 points)

    I have four files on my desktop.  They are increasing in number.

     

    They appear as .xlsx files.

     

    I can't click on them. 

    I can't "Get Info".

    I can't move the to the trash.

    I can't move the icons at all.

    I can't rename them.

     

    They have names like: 993F0000 or 2E85A700 or A2E2A000.

     

    I tried sudo terminal deletion but when I drag and drop, no link appears in the terminal.

     

    They don't show up in the Finder ... just on the desktop.

     

    I have Norton.  Nothing shows up on a scan.

     

    Any thoughts? 

  • mberardinelli Level 1 Level 1 (30 points)

    Sounds like maybe they are the hidden temporary files that Excel (or any office program for that matter) creates while you are working on a document (and sometimes leaves them behind).

     

    In other words, your Desktop folder might have the "hidden" flag removed somehow and you are seeing these "phantom" files which normally are behind the scenes.

     

    You can try this to see if those files are in fact supposed to be hidden:

     

    1. Open Terminal

    2. Type "cd Desktop" (without the quotes) and hit Enter

    3. Type "ls -la" (without the quotes) and hit Enter

     

    This will show you a list of all the files on your desktop. Look closely at the file names. All the "hidden" files will have a dot (.) in front of them. Do these weird files show a dot in front of the name (for example: .DS_Store is a file you will see in there).

     

    If so, you can try the following command to reset the "hidden" flag on those files:

     

    sudo chflags hidden <filename> (without the < >)

     

    If this is not the case, you can try a couple of other things:

     

    Try going into System Preferences > Accounts and creating a new user profile. Log into that profile and try opening Excel and making a "dummy" document. Do the same weird files appear on the desktop?

     

    Have you tried running a Permission Repair and Disk Verify from Disk Utility? If not, do so. There is also  another type of permission repair you could run (which might be more effective since it repairs Home folder permissions):

     

    1. Insert your Mac OS X Installation disc

    2. Reboot your machine and hold down the "C" key to boot to the disc

    3. Once the install disc loads up, choose English. Go up to the Utilities menu and choose "Reset Password"

    4. Highlight your username and click "Reset Home directory permissions and ACLs" (you don't need to actually reset your password).

     

    Let me know if any of this helps!

     

    - Matt

  • doe09 Level 1 Level 1 (0 points)

    I tried to go in through the terminal to delete these files but they are not there. All I have instead are filles named, ". and .." which cannot be changed through the terminal.

    Next I tried verifying disk permissions and I repaired permissions but the files are still on my desktop.

    Then I created a dummy account and the files did not appear.

     

    I will try the Mac OS X Installation disc and let you know how it does.

     

    Thanks and will keep you posted,

     

    Doe

  • doe09 Level 1 Level 1 (0 points)

    It turns out after I verified disk permissions and repaired them, I rebooted my computer and the images were gone. They did not reappear today when I opened up some applications or any else.

     

    If anyone knows why or how this happens I would be very interested to hear the answer.

     

    Thanks!

  • mberardinelli Level 1 Level 1 (30 points)

    Permissions get funky after multiple installs/uninstalls, moving files, and so on. The permission repair that you find within Disk Utility repairs the permissions on system files.

     

    Incorrect permissions can cause all kinds of issues, and most likely the kind that caused this were some type of permissions that controlled the "hidden" attribute flag on those "phantom files."

  • swholland Level 1 Level 1 (0 points)

    this suggestion worked like a charm.  I used spotlight to find "disk utility" and then ran "repair permissions" option and then rebooted.  Ta Da, the offending XLSX file on desktop disappeared.

  • marc32 Level 1 Level 1 (0 points)

    Screen Shot 2011-08-19 at 7.53.21 PM.png

    Just read this thread - I have been having this exact problem for several weeks, since installing Lion.  The phantom files look like Excel files and appear spontaneously on my desktop (see attached image).  When I shut down and restart my computer, the file or files are always gone.  But similar files invariably continue to appear as I work on and re-save Excel files.  The filescannot be copied or moved.  Also, if I click and drag several files on my desktop at the same time in order to move them to a folder, and happen to drag over this file when selecting the files to move, the result is that all of the "real" files are copied into the folder rather than moved.  The originals remain on the desktop and copies appear in the folder.  The phantom file itself is not copied.  I have tried the following:

     

    1. Reinstalled Lion

    2. Repaired disk permissions based on this thread

    3. Checked for hidden files using Terminal based on this thread

     

    The file is still on my desktop.  Any other input would be appreciated!

  • chrisfromames Level 1 Level 1 (0 points)

    Force quitting and restarting the finder worked for me. 

  • DocBaldie Level 1 Level 1 (0 points)

    I believe this is a problem with Excel 2011. I have the same problem. It appears that in some cases the temporary files Excel creates don't get properly deleted. They are not "hidden" files and they don't show up using "ls -la" in the terminal.

     

    In my case, I removed the .DS_Store file that is in the same directory and then rebooted. That removed the files but didn't prevent them from coming back the next time I used Excel 2011.

  • bood Level 1 Level 1 (0 points)

    And for me. Thank you.

1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.