Previous 1 2 3 4 5 6 Next 85 Replies Latest reply: Jun 2, 2015 11:49 AM by joshgastin Go to original post
  • rollerjedi Level 1 Level 1 (0 points)

    I just upgraded to Lion yesterday and now when I'm annotating pdf files in Preview I always have a phantom pdf file left on the desktop.  Same issue here.  Can't delete it can't move it etc.  It does go away when I reboot but it seems like a OS issue.  There are so many things about Lion that I like that I can't fault Apple for a minor thing like this but I'd love to see it resolved.

  • mberardinelli Level 1 Level 1 (45 points)

    This is not a Lion issue, it happens across OSes. It is typically a permissions problem - that weird file that you are seeing that cannot be deleted is actually a temporary file that gets created in the background by whatever application (Excel, Word, Preview, etc. etc. etc.) and it goes away once the file has been saved and the machine is rebooted.


    Normally you are not supposed to see the file during this process (i.e. it is supposed to be hidden).


    Have you tried running a Permission Repair and rebooting?

  • mberardinelli Level 1 Level 1 (45 points)

    This is not so much an issue with Lion as it is a permission problem that seems to be occuring during an in-place upgrade to Lion.


    Have you tried running a full Permission Repair and rebooting?

  • mberardinelli Level 1 Level 1 (45 points)

    Have you tried running a Permission Repair and rebooting yet? From what I can tell, this problem is happening after an in-place upgrade to Lion which seems to be causing some permission errors.

  • Stephen Lentz Level 1 Level 1 (5 points)

    I'm having same problem on a brand new iMac with 10.7.2 and a clean install of MS Office 2011 with all updates applied.  So I believe Apple changed something in Lion regarding how hidden files are handled which Microsoft haven't caught up with yet. 


    Quitting Excel then relaunching the finder seems to be the best way to clear them.  Logging out and back in also works. 


    Excel creates these files in the directory of the file you are working on, so one way to make them less of a nuisance is to move the files off the desktop into another folder before opening them.


    Word has a File Locations preference that allows it to put all the temp files somewhere they are less visible, but Excel doesn't seem to have this feature.  Haven't used PowerPoint recently, so I don't know how it behaves. 


    Anyway, I think all we can do is keep checking for updates.

  • JJW-Evanston Level 1 Level 1 (0 points)

    I didn't originally understand chrisfromames recommendation, but it works.  If I force quit Finder, it makes the phantom excel files go away from my desktop without having to reboot.


    When in finder press command + option + esc . This will launch the Force Quit Applications box.  In this box select 'finder' then press the button 'relaunch'.  This will get rid of the temporary excel documents for the moment.


    This works well with minimal effort.

  • rollerjedi Level 1 Level 1 (0 points)

    Seems reated to LION in my case.  I never had the problem before I upgraded from Snow Leapord two days ago.  Rebooting removes the phantom but I ran the permissions utility as you suggested.  Haven't seen the phantom but now on two occasions when I boot up, the system hangs and I have to shut it down and try again.  I read on another post that when you upgrade to Lion, the permissions utility is run during the install.  If true, running it again shouldn't make any difference.  Seems to my non-qualified senses that it may be related to the new "Versions" feature in Lion.  I like feature so I hope they get it worked out.

  • mberardinelli Level 1 Level 1 (45 points)

    It could be related to the Versions feature, or as Stephen Lentz suggested it may be that Lion handles the hidden files auto-created by MS Office apps differently and Microsoft has not issued an update for this yet.


    As far as Permission Repair goes, running it again can make a world of difference. It may run during an upgrade to Lion, sure, but every time to add/remove/edit a file, install or uninstall an app, move things around from folder to folder, etc. etc. etc., it causes permission changes to occur in the background.


    Running a Permission Repair will repair the permissions for all system folders and the Applications folder, which is why some people recommend doing a sort of "ritual" permission repair after doing updates, installing lots of apps, etc.

  • rollerjedi Level 1 Level 1 (0 points)

    I'm using a MacBook Pro, early 2008 model & I've upgraded to every new OS since then.  Maybe 4 times now?  I don't remember.  I didn't even know about the Permission utility until I read about it in this thread.  Never used it until now.  I'm sorry to say I don't completely understand it.  Is that like the registry on a pc?  What I have always loved about Apple is, I don't have to know what it is...  So far, it hasn't been necessary (for me) to know anything about the OS because as they say, "it just works".  When I started computing on pc's you had to learn everything about how the system works because it was so screwed up most of the time.  Illegal operations, blue screen of death, system hangs etc. etc.  Never had that with a Mac.  I remember hearing Steve Wozniak comment about the need to defrag on a Mac & he basically said "what for?".  That was one of the things that sold me.  In all the years since I've switched, the only serious complaint that I've had with Apple was the last upgrade to iPhoto.  I thought it was a disaster.  Love most everything else though.

  • mberardinelli Level 1 Level 1 (45 points)

    The permissions are not like the registry of a PC, no.


    PCs have permissions too, they are just accessed differently and do not work quite the same.


    Basically, permissions dictate who can do what to a file (read it, execute it, write to it, delete it, etc). For example, when you go to install an application, it will ask you for an administrator's password. That is because of permissions. Standard users do not have permission to install applciations because they access things at the system level.


    After numerous installations/removals/so on and so forth, the permissions on files sometimes get a bit whacky. That's where Permission Repair from Disk Utility comes in.


    Basically what it does it look what the permissions should be on all system files, Applications folder, etc. and compares them to what they currently are. When it finds some that do not match, it repairs them so that they are once again what they should be.


    Normally this does not cause a huge visible difference, but I have in fact seen Permission Repair fix quite a few issues. It's not necessary to perform a permission repair often, but I like to do them every now and then (I work in IT so it's kind of a habit at this point).

  • secondnature Level 1 Level 1 (0 points)

    Finder force quit & relaunch worked perfectly fo me - thanks - this has been bugging me for weeks!

  • sarasam Level 1 Level 1 (0 points)

    it is the weirdest thing. happened to my husband and i both. i quit all my programs and did a re-start on the computer and its now gone for now.

  • nwr1991 Level 1 Level 1 (0 points)

    This worked surprisingly quickly and so easy to do!

    Thanks for the tip

  • bombtech13 Level 1 Level 1 (0 points)

    Restart did the trick, though when opening certain excel files, the "phantom" files returned.  However, restart and they're gone again. 

  • DollyGal Level 1 Level 1 (0 points)

    To add another wrench into solving this problem, I have the same issue.  HOWEVER, it just started for me since the latest MS Office 2011 update.  I've been using MS O 2011 on Lion since August and haven't come across this issue before.  Restarting the computer, or at least the Finder does remove these temporary files for a while.  But like others have said, they return.  I did just run the Permissions Repair, so hopefully that will be a permenant fix.