Previous 1 12 13 14 15 16 Next 371 Replies Latest reply: Apr 26, 2016 7:45 PM by OliDel Go to original post Branched to a new discussion.
  • da136203 Level 1 Level 1



    Confused at work today and forgot I had set it to integrated only.


    Dynamic switching enabled again and the external popped on.


    Thank you.

  • McFlyFarm Level 1 Level 1

    Okay, here is MY deal: I have a MacBook Pro (here are all the specs because I know someone is going to ask for them):


    Model Name:          MacBook Pro

      Model Identifier:          MacBookPro7,1

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2.66 GHz

      Number Of Processors:          1

      Total Number Of Cores:          2

      L2 Cache:          3 MB

      Memory:          4 GB

      Bus Speed:          1.07 GHz

      Boot ROM Version:          MBP71.0039.B0B

      SMC Version (system):          1.62f6

      Serial Number (system):          73108040ATN

      Hardware UUID:          025B639B-BAE5-5653-B256-78416A82D4AC

      Sudden Motion Sensor:

      State:          Enabled


    So anyway, I have it hooked up to 2 Acer V193W monitors. I have had them hooked up for almost two years with no problem. One through miniDisplay and the other through a USB adapter. I went to plug my MBP back into the monitors tonight and the USB monitor works fine but the minidisplay does not, no matter what I do, no matter what solution I try it simply will not detect it. The weird things are, if I hook up my MBP to my TV, works fine. Detects it perfectly. So it's not the adapter or the monitor chord. HOWEVER, when I try to hook it up to my OTHER Acer monitor, that one doesn't work either.


    So to recap, two Acer monitors. One on USB, one on mindisplay. One works with USB, other with mindisplay does not. Minidisplay to VGA adapter works on TV. So that rules out adapter. Monitor with USB works but does not work with VGA adapter. has to be some speific configuration problem betweem the adapter and the type of monitor. Not even that one specific monitor, just the brand/model etc.


    What to do??

  • Vic-zx Level 1 Level 1

    have you tried the usual problem solving steps yet? (like pram reset, gfx, etc)

  • McFlyFarm Level 1 Level 1

    I do not have 10.8, only 10.6 so I couldn't download gfx and I have not tried a new VGA adapter because...there's nothing wrong with the one I have. But everything else I have tried for 3 hours last night. I suppose I will try and install 10.8 and then gfx before anything else. It's just so weird. Both the adapter and the monitor work separately, it's when you put them together that all of a sudden, after all of this time, they stop working.

  • Vic-zx Level 1 Level 1

    Were there any recent updates to ML that you installed which might coincide with when the output to the acer stopped?

  • McFlyFarm Level 1 Level 1

    I edited my post to be more clear. Yea I don't have ML and I didn't upate my MB in the few hours it was unplugged. It just mysteriously stopped working. It's the strangest thing. Like I said, I am going to try and install 10.8 today and maybe that will fix the problem. Hopefully.

  • Vic-zx Level 1 Level 1

    if i were you i would reinstall the current SL system, if you upgrade you will probably experience lower battery life and performance reduction. and anyway SL is very good. it is not guaranteed to solve your problem. your adapter may work on the tv, but that doesnt rule out that it is damaged/ and or have a software problem on the mac. I had a similar problem with two hdmi adapters which worked on some displays and not on others. If you have the opportunity to go to an apple store, then i suggest you take your mac and the adapter and ask them to have a look and try the adapter. you might want to try the fix that solved my endless display problems, and that was to get a NEET hdmi (or vga in your case) to minidisplay cable (as i keep saying   )  because since ive been using it ive had no problems at all with any of the displays.


    whatever you decide to do keep us updated please.

  • McFlyFarm Level 1 Level 1

    I installed 10.8 before I read your reply. But regardless, it did not help and I am unable to install gfx. Whenever I try I get the message "You are using a system that gfxCardStatus does not support. Please ensure that you are using a MacBook Pro with dual GPUs." So, unless anyone has any other suggestions I am going to have to just purchase a new adaptor and see if that works. I don't see any other options.

  • Vic-zx Level 1 Level 1

    gfx doesnt help many people. did you do the pram and nvram resets?

  • McFlyFarm Level 1 Level 1

    I've tried pram many many times with nothing. I was unsure how to reset the nvram. option + command + O + F? If so, it did not do anything.

  • Vic-zx Level 1 Level 1

    yeh im not surprised, nothin worked for me except the cable. Probably getting a new adapter will work for you. Either way pls put a post here once you got it and tried.

  • McFlyFarm Level 1 Level 1

    Okay, we have another interesting update. In an effort to rule out every possibility, I switched the VGA cables between the two monitors. The first time I plugged in the other cable to the unresponsive monitor, it recognized it! For like...2 seconds. And then went black again stating "no signal". I unplugged it and plugged it back in again, this time it stayed on for like maybe 5 seconds and went black again stating "no signal". But now it won't do it at all. Both VGA chords work fine on the other monitor but I am going to try new chords tonight hopefully. Maybe that will solve the problem before I invest in a brand new adapter.


    Also, I hate Mountain Lion.

  • McFlyFarm Level 1 Level 1

    I just got home with a completely "new" VGA cable from a thrift store. 4 bucks. Perfect condition. I plug it in. It recognizes monitor. It then proceeds to blink to black several times. As in recognizes, doesn't, recognizes etc. That lasts several moments and signal again.

  • carltonfrommeridian Level 1 Level 1

    OK, this has been going on for years and everyone has tried all the black magic to get non-Apple monitors to work at startup. I have had my MacBook Pro since early 2011. It works fine with an Apple Display, of course. But at my second home, it fails to work on startup everytime with my HP 23" Monitor. So I am going to repeat what I have done now for 2 years to get the monitor up and running. It works so take it for what is worth, I am convinced it is a software glich with Apple OS v. non-Apple Monitors. It isn't cord or connector related, too many situations where people tried to solve with new ones and no joy.


    So, here is what I do if the monitor doesn't go live at startup:


    1) Monitor scans and then goes to sleep and is inactive at startup,

    2) Unplug DC power cord to Monitor,

    3) Open up laptop so you can see the screen,

    4) Unplug Monitor to laptop at laptop,

    5) Watch for blue flash on laptop screen,

    6) QUICKLY as possible, replug in the DC power plug to monitor. (Monitor will scan for signal) And replug in the connector to the laptop.

    7) If you are successful, the monitor will detect the signal from the laptop and go live, jump for joy,

    8) Close the laptop and let the pix resize to the monitor's best fit, and go to work,

    9) If it doesn't work, repeat steps 2>>6.


    SOMETIMES, the monitor goes live at boot. Sometimes it does not. I thinkk it has to do with timing of the scan phase and the stability of the laptop output signal. (Just a guess).


    Since this problem existed with previous OS and Lion, I have to think it is software related.


    Best of Luck.

  • McFlyFarm Level 1 Level 1

    I tried this many many times.'s not NOT working. It "recognizes" the monitor in the system preferences but the monitor itself still states "no signal" but it looks to be going in and out though when it comes to having a signal. The indicator light will go from blue (working) to orange/amber (not working) and "no signal" will flash periodically on the screen. So...we're getting somewhere. I am going to try restarting the computer and also reinstalling Snow Leopard and see if that doesn't do anything.

Previous 1 12 13 14 15 16 Next