5 Replies Latest reply: Mar 24, 2011 2:32 PM by bilant
bshomb Level 1 Level 1 (0 points)
We received a site license for iWork 09. But if a user has had the trial of iWork 09 on their computer, iWork asks for a serial number when installed (even though Apple doesn't give these out with iWork anymore).

I've tried deleting

~/Library/Preferences/com.apple.iWork.Keynote.plist
+/Applications/iWork\ \'09+
+/Library/Application\ Support/iWork\ \'09+
/Library/Preferences/com.apple.iWork09.Installer.plist

Still doesn't work. What am I missing?
  • DNosky Level 1 Level 1 (0 points)
    Same problem here only I'm going from the Free Trial to the Box Set Family which I have succcessfully installed on other programs in our home. I've deleted the trial Application and the folders referenced above, I've cleared the Library Cache related to iworks, emptied trash, restarted, re-installed and did application updates... SAME PROBLEM.
  • bshomb Level 1 Level 1 (0 points)
    What's ridiculous is I paid for a 20-user site license, and Apple can't just put a serial number with it. It's the same as the retail box, and a simple trial software can screw it up.

    I even tried installing it and capturing it with Absolute Manage InstallEase to see where everything was going, but I'm at a loss to what I've missed here.

    Anyone?
  • bshomb Level 1 Level 1 (0 points)
    I remembered I had written a shell script a couple years ago to revert Java in OS X, and it involved "forgetting" old packages. I found the script and rewrote it for iWork '09. Removes and installs the same stuff, but for some reason it works.

    In this case, I was doing it over SSH to a network machine, so I copied the package from the installer disc and then the latest iWork update package to a common location "/Users/Shared".

    ----

    #!/bin/sh


    rm -rf $HOME/Library/Preferences/com.apple.iWork.Keynote.plist "/Applications/iWork\ \'09" "/Library/Application\ Support/iWork\ \'09" "/Library/Preferences/com.apple.iWork09.Installer.plist"

    pkgutil --forget com.apple.pkg.iWork09Trial
    pkgutil --forget com.apple.pkg.iWork904Update
    pkgutil --forget com.apple.pkg.iWork905Update
    pkgutil --forget com.apple.pkg.iWorkTrial

    installer -target / -verbose -pkg "/Users/Shared/iWork09.mpkg"
    installer -target / -verbose -pkg "/Users/Shared/iWork9.0.5Update.pkg"
  • bshomb Level 1 Level 1 (0 points)
    Use of shell script to remove and install worked, where GUI method failed.
  • bilant Level 1 Level 1 (0 points)
    Hallo,

    i had the same problem and have delated the files you wrote plus as follows:

    ~/Library/Preferences/com.apple.iWork .../iWork\ \'09
    /Library/Preferences/com.apple.iWork09.Installer.plist

    after the procedure do not forget to empty the trash.
    reinstall iworks 09 from dvd......

    finally it worked out!!

    good luck