Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Turning off built in mic

This is crazy-how do I turn off the built in microphone on my computer. I can't use Garageband with it on and I can't find how to turn it off. I turned the volume all the way off but it still works. Very Very frustrated!!!!!!!!!!!!!!!!!!!! User uploaded file

macBook Pro, Mac OS X (10.6.1)

Posted on

Reply
Question marked as Solved
Answer:
Answer:
Why do you want "turn it off"?

Posted on

Page content loaded

Jan 25, 2011 2:19 AM in response to AnaMusic In response to AnaMusic

Thanks for your help-I tried what you suggested and could not find any line in to click on. I reduced the volume slider to 0 but the sound still gets picked up. I have a MacBook Pro and I am using a audio-midi interface to plug my electric guitar into. I am getting ambient sound and feedback from the built in microphone on my computer. I just can't find any way to shut it off. Thanks again. Still stumped.

Jan 25, 2011 2:19 AM

Reply Helpful

Jan 25, 2011 2:29 AM in response to dubdroid 1 In response to dubdroid 1

You can either record through your interface or the built-in mic - no way that you are picking up sound through the mic while you're recording your guitar. So there's two possibilities:

1. You're not really recording through the interface - have you picked it in GB's (not the System's) audio preferences?

2. Your guitar is picking up the noise - is it an electric guitar or an acoustic one with a pickup or what?

Jan 25, 2011 2:29 AM

Reply Helpful

Jan 25, 2012 10:34 PM in response to dubdroid 1 In response to dubdroid 1

Same problem here. Trying to record with a keyboard. I can hear the ambient room sounds, so those sounds are not obviously coming throuhg the keyboard. On my Macbook air, there is no option through System pref to select 'Line-in' - there is only one line in that window - 'built-in mic'. And yes, I did select the 'real instrument' through GB audio pref......

Any ideas?

Jan 25, 2012 10:34 PM

Reply Helpful

Jun 17, 2016 8:22 PM in response to dubdroid 1 In response to dubdroid 1

I was having the same issue when I wanted to listen to and edit projects after I'd unplugged my digital interface, but didn't want to hear myself typing/breathing as I did so!


What worked for me was to turn ambient noise reduction on and max out its sensitivity.


Here's what to do:

In Garageband:

1) Garageband menu → Preferences

2) Choose Audio/MIDI

3) In "Input Device" dropdown, choose "Built-In Microphone"

(If it won't let you do this, then try it again after doing the below and it should work; worked for me.)


In System Preferences

1) Go into Apple menu → System Preferences

2) Choose Sound (Second row, furthest to the right)

3) Choose "Input" heading

4) Select "Internal Microphone_Built-in" as the device for sound input

5) Make sure box is checked next to "use ambient noise reduction"

6) Drag the "Input volume" slider all the way to the left (This makes the internal mic so sensitive to external noise that it basically just stays shut off/silent while you work on your project).

User uploaded file

This may not work if the issue you're having has to do with multiple conflicting inputs, but it resolved my issue perfectly. I hope this helps

Jun 17, 2016 8:22 PM

Reply Helpful

Jan 23, 2017 10:24 PM in response to Lizzy-beff In response to Lizzy-beff

I'm not sure if this is the answer you're looking for, but if you are picking up noises from your computer mic (or any mic for that matter) and you want to turn them off, you can click on the "Input Monitoring" button on the individual tracks to turn the monitor on or off. It is the orange button to the right of the mute and solo buttons in the track controls.

Jan 23, 2017 10:24 PM

Reply Helpful
User profile for user: dubdroid 1

Question: Turning off built in mic