Previous 1 2 Next 21 Replies Latest reply: Dec 24, 2015 11:13 AM by Tomas Savėnas
verzunof Level 1 Level 1
expertise.itunes
iTunes
Hello,

I use two keyboard character sets for keyboard. The switch between them is Command-Space.
I also have password requirement for waking up or going from screen saver.
Now if screensaver starts with non-English layout selected, I'm not able to login:
password is not accepted because keyboard layout is not English and switching
to English layout does not work in unlocking window.
Is there any way to change layout while in the unlock window?
Thanks

iMac 24 (Mid 2007), Mac OS X (10.6.6)
Solved by igepard on Jun 17, 2011 5:21 AM Solved

I think, it is a bug in the OS.

 

Anyway, to prevent this from happening go to Settings=>Accounts=>Login Options and check Show Input menu in login window box. Now at the login window you will see all your keyboard layouts, so you can change to any of them before typing a password.

 

Thanks!

Reply by noondaywitch on Feb 22, 2012 4:51 AM Helpful

System Preferences > Accounts > Login Options -

 

Accts login input.png

Check the box.

All replies

  • peter0909 Level 1 Level 1
    hi! i've just encountered the same problem...
    my screen locked itself while being in non-english layout.
    since you posted your question weeks ago, i'm wondering, have you solved this problem yet?
  • verzunof Level 1 Level 1
    expertise.itunes
    iTunes
    No,
    I have not solved the actual problem.
    My immediate solution was, unfortunately, hard reboot using power button.
    After reboot it comes back to the locked screen, but this time in the English mode.
    Also, I'm not sure, but I have observation, that if "The same setting for all documents" or something (don't remember exact name) in the language pane is unchecked then the problem, seems to have gone. You can try this.
    Otherwise before leaving the computer unattended, so that it can go into locked screen, make sure it it in English mode.
    Thanks
  • Tom Gewecke Level 9 Level 9
    Are you sure you cannot make the required characters with the non-English layout? If you give the name of the layout and the problem characters, someone might be able to help.
  • zaph0d Level 1 Level 1

    Write the password while holding the Option key(ALT). If you have digits in the pass release the opt key while typing them since Alt-Number key results in other symbols.

     

    regards

  • igepard Level 1 Level 1

    I think, it is a bug in the OS.

     

    Anyway, to prevent this from happening go to Settings=>Accounts=>Login Options and check Show Input menu in login window box. Now at the login window you will see all your keyboard layouts, so you can change to any of them before typing a password.

     

    Thanks!

  • noondaywitch Level 6 Level 6

    zaPhod; holding down Opt while typing will give symbols and diacritical marks, not letters, and they vary between keyboard layouts.

  • zaph0d Level 1 Level 1

    Holding 'Opt' with Bulgarian keyboard layout gives me latin letters , you can try it yourself if you dont believe me

     

    regards

  • noondaywitch Level 6 Level 6

    Indeed it does, but the OP never said what keyboard he/she was using...

  • zaph0d Level 1 Level 1

    This is really annoying bug, it makes me hate osx when I unlock the screen...

  • noondaywitch Level 6 Level 6

      Hardly a bug: if you set the password in English, it's perfectly reasonable that it will only respond to the English characters.

  • verzunof Level 1 Level 1
    expertise.itunes
    iTunes

    Holding Opt does not produce readable characters with russian layout.

     

    Thanks

  • olisman Level 1 Level 1

    Yes you are right, this is not a bug, it's just bad user interface. Just imagine the following scenario...
    Writing a paper, switching to Greek to enter a couple of characters and leaving the mac idle for 5 mins.

    The lock screen comes up asking for a password, unfortunately the user didn't change the language

    before the mac was left idle and there is no option to change the language in the lock screen.

    User has to hard reset to access the mac and let's hope that the user was saving his paper frequenlty.

     

    So from a coding point of view this is not a bug, but from a user interface design it is a huge flaw

  • noondaywitch Level 6 Level 6

    System Preferences > Accounts > Login Options -

     

    Accts login input.png

    Check the box.

  • zaph0d Level 1 Level 1

    Haha, noondaywitch, thanks!!!! This is it!!!

     

    I wanter why this is not the default?

     

    regards,

    arizal.

Previous 1 2 Next