12 Replies Latest reply: Jun 25, 2013 11:32 AM by James Kachan
stream41 Level 1 Level 1 (0 points)
Hey guys, I'm using the newest Apple bluetooth keyboard (A1314) with an iPad running 4.2.1. The keyboard works great if I'm using it constantly - I can sit for hours and type away with no problems. However, if the keyboard sits for a few moments and goes to sleep, then often when I wake it back up, the keys will "stick". Not physically - just in software. Any key on the keyboard will do it, so I know it's not a particular key causing the problem. If I power cycle the keyboard, it works fine after pairing back up. Batteries are fine.

Any ideas? Thanks!
  • stream41 Level 1 Level 1 (0 points)
    Also, I tried replicating the problem on my iPhone 4 running 4.0.1, and it doesn't seem to have the same problem. I would think that narrows down the problem to the iPad?
  • Michael Morgan1 Level 7 Level 7 (23,825 points)
    That's interesting. I don't have one yet but it just never occurred to me that wireless keyboards would go to sleep.

    Assuming that by sticking you mean a key repeating, as though held down, then I'd be curious about two things right off the bat:

    A. Does that iPad do the same thing with a different keyboard?

    B. Despite the belief that they're fine, does that keyboard do the same things with fresh batteries?
  • stream41 Level 1 Level 1 (0 points)
    Good questions.

    1) I don't have another keyboard to try, but the keyboard acts fine when paired to my iPhone 4. I assume that means it's the iPad at fault.

    2) I use Powerex rechargeables which were fully charged a few weeks ago when I received the keyboard, but I've only been using the keyboard for the last couple of days. I suppose it's possible that they could have drained in those few weeks, so I'll charge them up tonight and see if that helps.

    I think it's also worth pointing out that the keyboard just "stuck" again right in the middle of using it - no sleep this time.

    Thanks!
  • stream41 Level 1 Level 1 (0 points)
    Just fully charged up the batteries, and the problem still persists. Any other ideas?

    Thanks!
  • stream41 Level 1 Level 1 (0 points)
    Well, never mind. I just hooked the keyboard up to my iPhone 4 again to test it one more time, and it's doing the same thing on that device. Looks like I bought myself a bad keyboard

    I bought it used, but do I have any kind of warranty recourse? I'd suspect not, but it never hurts to ask.
  • Michael Morgan1 Level 7 Level 7 (23,825 points)
    If your sales co tract doesn't mention a warranty, or if where you bought it doesn't have a policy publicly posted, then I'd expect not.
  • aybow1 Level 1 Level 1 (0 points)

    My Apple wireless keyboard is doing the same thing. The keys are sticking so when I press one it is as if I'm holding the key down. Using it with an Ipad 2. Fresh batteries. No clue what to do.

  • Ashapalan Level 1 Level 1 (0 points)

    I also have this problem.

     

    I have had the previous generation wireless keyboard for almost 3 years and only started getting this waking from sleep sticky keys issue upon the purchase of a new macbook pro this year. This would suggest that the problem lies in a recent software update? Perhaps something to do with bluetooth?

     

    Regardless i hope there is a fix because it is driving me up the wall...

  • cskingle Level 1 Level 1 (0 points)

    I have been having problems with repeating keys on my iPad 2.  I purchased a Zaggmate keyboard case which I love, but the last two weeks, it started repeating keys - not just one key - any key.  The last letter I type before pausing gets repeated and will fill an entire page with that letter.

     

    I tried hooking up my Apple Bluetooth keyboard and the same thing happened.  This leads me to believe that the issue lies with the iPad and not the keyboards.  I've rebooted my iPad and it seems to be accepting the Apple bluetooth keyboard now without repeating keys. In one second, I'm going to fire up the Zaggmate keyboard and see what happens - stay tuned....

     

    Well, I've fired up the Zaggmate and it appears the reboot of the iPad has solved the issue. 

     

    Very strange and MORE THAN A LITTLE IRRITATING!

  • muggles5 Level 1 Level 1 (0 points)

    Have had same issue with a ZAGG keyboard case. Rebooting iPad and reconnecting keyboard on bluetooth settings fixed it. Had keyboard for months with no problem, and have had iOS6 for a month or so as well. Hard to identify any trigger, but then these things are way quirkier than any manufacturer or software developer ever wants to admit. I would assume that if it is widespread and/or gets worse, the issue will be addressed, as it would be a huge headache for 3rd party accessory manufacturers and dealers. In any case, try rebooting, that's fixed it (for good?) for me.

  • SiPodder Level 1 Level 1 (0 points)

    I have the same problem with my older white Apple Wireless Extended Keyboard, which had been working fine with my 2009 iMac. But I experience the issue sporadically with my new Mac Mini. I've read reports of people resolving some BT issues by turning off "Allow Bluetooth devices to wake this computer" in the Advanced pane of the Bluetooth System Preferenes Pane.

     

    Not that that'll help you guys with the iPad issues, but interesting to note that it's happening across various devices, keyboard models, and OSs.

  • James Kachan Level 1 Level 1 (25 points)

    I have this bluetooth key sticking issue from time to time as well.

     

    From what I can figure out, it has to do with interferance with bluetooth either from my iPhone in close proximity to the computer and (more so) when my macbookpro is in clamshell mode, connected to external monitors. This has a major effect of typing. if i open the macbook it stocks the sticking of the keyboard.

     

    To sorta "hack" the situation, I have placed a small magnet physically on top of my keyboard near the bottom right side where the magnetic trigger for sleep is, this fools the laptop into thinking the screen is closed and it turns off, entering clamshell mode while leaving the screen open. This allows for better bluetooth reception.

     

    Hope this helps someone, I've been dealing with this issue for a logn time.