Previous 1 2 Next 28 Replies Latest reply: Apr 24, 2015 1:45 PM by StacyNT Go to original post
  • mooperful Level 1 (0 points)
    I'm having the same exact problem and would really like to know what is going on.
  • dineenie09 Level 1 (0 points)
    I'm having this exact problem- has anyone found any success? I've spoken with both Netflix and Apple at length and inconclusively about it. I can occasionally get a movie or page to load but it's very rare. Suggestions?
  • TeenTitan Level 4 (2,410 points)
    have you tried un-installing silver light; reboot, then re-installing it?
    have you tried another browser such as google crome and or firefox?
    You could also try cross posting your question on MS SilverLight forums. There seems to be a thread about a similar issue on their forums. One of the things listed as being helpful by other users in the thread is to re-install "Flip4Mac" if you have it already installed on your computer.

    Message was edited by: TeenTitan

    Message was edited by: TeenTitan
  • the_guy_from_that_movie Level 1 (0 points)

    My PS3 and my iPhone (while on WiFi) wouldn't load Netflix.  Reverting the firmware on my Airport Express fixed the problem.  I have two young children and no cable, so I was kinda freaking out.  Thanks so much. 

  • lastlegs Level 1 (0 points)

    I WAS having a similar problem where i couldn't view netflix, apple, new york times and a few others, only the text of the webpages would come up, nothing else. I recently updated my router, now the websites load pretty well, minus a few images here and there.


    Any help with that!?

  • Dfromc'bad Level 1 (0 points)

    Well, let me make it even stranger:  running a MacMini w/ Snow Leopard.  When logged in as administrator = no problem reaching Netflix.  I can log in.  I can search.  I can watch instantly.  But if logged in as a non-admin user = no images load on the page, and the browser (Firefox AND Safari) fails to connect to Netflix server when I try to sign in.

  • truedat Level 1 (0 points)

    What's happening here is that netflix is shutting you out for using too much of their bandwidth. This problem started for me when my two roommates started using "Watch Instantly". Before that it was never a problem, but the increased traffic caused netflix to shut out my entire network, and one day no device connected to my wireless router could load netflix, not even my cellphone. I tried clearing my DNS cache as someone suggested, and that didn't work. Then I tried getting a new IP address from my dhcp, but that didn't work either of course because my whole network was blacklisted. The solution I came upon was to connect by proxy.


    In firefox, go to:

    Firefox > Preferences... > Advanced (tab)

    Under "Connection", click Settings...

    Check Manual Proxy Configuration

    Under HTTP, write in the address of any proxy (list of free proxies is here). I used "" You can leave all other fields how they are.


    I'm sure the set up for safari is similar.

  • racso39 Level 1 (0 points)

    I'm having this issue, it is strange, I have a MacBook Pro early 2011 running the latest Lion version and while inside OS X, netflix homepage won't load correctly or load at all, however, If I turn on my Personal Hotspot (iPhone) it will work, but here is where it gets more confusing: I have Boot Camp with Windows 7, when I load up there, Netflix will load correctly on the same router it doesn't load while I am on Lion.


    Any idea of what could be wrong?

  • shamarkharris Level 1 (0 points)

    just go into your netflix , play a movie then right click on the movie while its playing and select silverlight preferences and leave it open and click on fullscreen and it should work.....hope it work fo you because it worked for me....

  • mikeumr Level 1 (0 points)

    All - I have had this issue for months and after reading your discussion, I took a look at my Safari settings.  Under the "Advanced" button, click on "Change Settings" next to Proxies.  Check the box "Auto Proxy Discovery".  Worked immediately for me.  Netflix browser finally loads the pictures of the movies in Safari!!


    Is there an security risks I should be concerned about with this setting?

  • tequilaready Level 1 (0 points)

    Thank you! I was having this problem until I did what you suggested. Before that I tried several things, reinstalled FF, checked file permissions, tried other browsers, other machines, other OSses, changed router, changed internal ips, tried with only one machine on network, tried tcpdump, wireshark, etc, etc, etc. Thanks!

  • Meqc31 Level 1 (0 points)

    If you can adjust your router settings, you should change your MTU to 1450.

    This worked for my Netflix app as well as other streaming video apps.

    Good Luck!

  • Rockonnyc Level 1 (0 points)

    Awesome!  Thanks!  Worked for me right away on MacBook Air in 2015….wow….such a simple fix….

  • StacyNT Level 1 (0 points)

    Perfect, fixed it . . . thank you!

Previous 1 2 Next