12 Replies Latest reply: Jun 11, 2011 9:36 AM by PhilMac!
The Joolster Level 1 Level 1 (45 points)
I've read various posts about scanner functions not working after upgrading to 10.6.x. I too have this problem now with my Epson Stylus CX6600. This machine has been a real workhorse for me for 6 years and up until this week it has been trouble-free. It prints absolutely fine as usual but the new OS can't 'find' its scan function.

So far I've :

1 Deleted the driver and reinstalled via Software Update
2 System Prefs : Printer/Fax : when I select 'Scan' the queue window opens and reads "No Scanner Selected"
3 Image Capture : "No Scanner or camera selected"
4 Preview : "Epson Stylus CX6600 was disconnected"

No matter what I try my iMac will not recognise the fact that I have a scan option.

I know others have had this problem in the past but the posts remain "unanswered". My assumption is they either fixed it or gave up.

If anyone has the answer, I'd be most appreciative to hear it!

TIA
Joolster

PS : Our MacBook is connected to an Epson Stylus SX215 multifunction - print & scan working perfectly fine on that.

Message was edited by: The Joolster

Intel iMac + MacBook, Mac OS X (10.6.6)
  • DaddyPaycheck Level 6 Level 6 (16,035 points)
    Try deleting the driver and download the one you need from Epson and see if that does it.
  • Alex_miksa Level 1 Level 1 (30 points)
    Exactly what Daddy said, uninstall everything to do with your Epson, printer, scanner, image capture drivers. So delete it through system pref >print and fax

    After that open a finder window:
    -go to home folder/library/printers -> if there is anything in there delete it

    Now we are going to trash a few plist files: ~ tilde is being used for home folder
    ~/library/preferences/com.apple.print.add.plist
    ~/library/preferences/com.apple.print.custompresets.(variable for printer here).plist
    ~/library/preferences/com.apple.print.PrinterProxy.plist
    ~/library/preferences/com.apple.print.PrintingPrefs.plist
    ~/library/preferences/com.apple.systempreferences.plist
    (You may not have all these files but what we are doing is if you see anything com.apple.print trash it)

    Next go to:
    http://www.epson.com/cgi-bin/Store/support/supDetail.jsp?BV_UseBVCookie=yes&oid= 41664&prodoid=46253282&infoType=Downloads&platform=Macintosh

    Download the first 3 drivers:
    Printer Driver
    Scanner Driver
    ICA Scanner Driver v5.3.0 for Image Capture driver
    And maybe Epson EasyPrint 3.1

    AFter downloaded install those files.

    If the issue persists after that, do an archive OS reinstall:
    Insert DVD, follow the onscreen installation instructions. It will keep your data and programs just replace the system files and you start off with a fresh with printers.
  • The Joolster Level 1 Level 1 (45 points)
    Your help is much appreciated.

    I'll throw all that stuff out and start again then report back.

    Thanks!
    Jools

    null
  • The Joolster Level 1 Level 1 (45 points)
    Latest...

    That process didn't work unfortunately. I have a feeling that despite my model being listed as able to print and scan with SnowLeopard (http://support.apple.com/kb/HT3669#epson) I believe the printer is too old to marry up its scanning capability with the latest drivers and system update.

    I haven't done an archive install as you suggested. Can you clarify what that is exactly? Does it mean reinstalling original Snow Leopard without installing the Software Updates?

    Thanks
    joolster
  • pantbrown Level 1 Level 1 (0 points)
    I recently downloaded the 10.6.6 update and my HP F2280 printer/scanner has had problems since. I can print fine but the scanner comes up with an unknown error every time I attempt to scan!! Just found out a work around that works for me though,
    If you go to the "apple" menu and into system preferences, click on the "print & fax" option, choose "scan" rather than "print" in the window that comes up and you can hopefully scan through this! It has worked for my problem, still can't use the official HP software though to scan.
    Hope Apple can address this because looking on the discussions it's not a problem for just that make of multifunction device.
  • The Joolster Level 1 Level 1 (45 points)
    Thanks for the suggestion pantbrown. Much appreciated but unfortunately the route via "Scan" in system prefs doesn't work for me...I just get a message that reads "No Scanner Selected" or "Epson CX6600 disconnected".

    I'm still hoping to get an answer about what exactly an 'archive install' so I can give it a go.

    joolster
  • sibelius33 Level 1 Level 1 (0 points)
    I got the same problem and I found a way to use my old CX6600 scanner with 10.6.
    I've just replaced the file /Library/Image Capture/Devices/Epson Scanner with the old 4.1.0 version I found in one of my others macs running 10.5 and able to drive the scanner.

    HTH
    sibelius33
  • syheeee Level 1 Level 1 (0 points)
    Same here. I have an iMac running 10.6.6. and an elderly Epson Stylus CX6600. I have installed, deinstalled, reinstalled, updated, tried the Epson website, gutenprint and even installed SANE ... nothing worked. I've been at it for two days now. My CX6600 is printing all right but it doesn't scan. The scanner sometimes appears in System Prefs but anytime I try to open it it just says that the scanner was disconnected. The scanner showed up in Image Capture occasionally but disappeared after a couple of seconds.
    I've looked into my old G4, that had no problem scanning and found out that there is a file in library/Image Capture/TWAIN Data Sources called "Epson Stylus CX6600.ds". My new imac does not have this file. Does anyone know, if this could be the problem?
  • EAF61862 Level 1 Level 1 (0 points)
    Thats the solution! I replaced the scanner driver with the old version 4.1.0 and It worked like a charm.
    Thanks for the solution
  • Dr. Fuzzy Level 1 Level 1 (0 points)
    So after 6 hours of tech support with Apple and Epson, they couldn't help me. So, how do I get the 4.1.0 driver that some of you say works? It is not on my old computer.
  • nhd91 Level 1 Level 1 (0 points)

    I'm having the same problem.

     

    Is there a way to find old drivers archived on the internet somewhere?

    Or maybe one of you could upload the old driver?

     

    That would be unbelievably helpful!

  • PhilMac! Level 1 Level 1 (0 points)

    (1) Happily, you can get the 4.1.0 file from the 10.5.8 Combo Update. (I don't know which of the previous updates introduced it — to save time, I looked only in this combo update, the last for Leopard.) Download the standalone installer from the Apple site.

     

    (2) You must also have a file called "EPSON Stylus CX6600.ds", which belongs in "/Library/Image Capture/TWAIN Data Sources/". If it's not there, you can get it from Epson:

     

    (a) Download the file for the CX6600 identified as "TWAIN Driver and EPSON Scan Utility v2.77A", with the filename "epson11802.dmg". It's described at the model's downloads page, and the direct link is "ftp://ftp.epson.com/drivers/epson11802.dmg".

     

    (b) Epson seems to have messed up the content type of the file, or made some other error, because Safari at first tries to open it in the browser as though it's a movie. Give it a minute or two to sort itself out. If it never starts downloading, use an FTP program to get the file.

     

    (c) Once you have it, mount it and run Epson Scan Installer.

     

    (3) Next, go into "/Library/Image Capture/Devices/" and trash the file "Epson Scanner". (Well, you might want to just stash it somewhere else, in case you ever need to use an up-to-date Epson scanner.)

     

    (4) Download a program called Pacifist, if you don't already have it. You will use it to extract from the 10.5.8 Combo Updater only the file that you need.

     

    (5) Open the combo updater in Pacifist, and look for a file called "EPSON Scanner.app". Its location in the combo updater package is "/Library/Image Capture/Devices". Select this file and click the "Install" button in the toolbar.

     

    (6) "EPSON Scanner.app" should now be in your Devices folder. Double-click on it to launch it. (It runs in the background, so you won't see an icon in the dock, but you .)

     

    (7) At this point, you should be able to power up and connect your CX6600, launch Image Capture, and scan as usual. (The EPSON Scan application, which will have been installed in your Applications folder during step 2, if it was not already there, should also function.)