Previous 1 2 Next 17 Replies Latest reply: Jul 9, 2013 10:51 AM by lachelvi
paladin3 Level 1 Level 1
So I sometimes use the screen recording feature of QuickTime Player and occasionally have the following experience:

1. After I click the stop recording button, the recording appears to cease but the new video never appears.
2. The black Screen Recording window reappears but the record button is grayed out as is the red close button.
3. The File menu's New Screen Recording is likewise grayed out.
4. The application will not quick and must be force quit.
5. There is a Screen file in my Movies folder but it typically is zero KB. Sometimes it shows an actual value but cannot be opened because "The File is Not a Movie File"
6. Other kinds of recordings (Movie Recordings) can be done.

This feels like there is some sort of error during save but I was wondering if a) anyone had experienced this or b) knew of a fix.

mac book pro, Mac OS X (10.6.6), 2.2ghz, 4gb ram, 750gb hd
  • Eduard1729 Level 1 Level 1
    I had exactly the same problem today, I was recording screen for a couple of hours, then clicked end button, but the file is still of size 0 and the same items as described in the 1st post are disabled. The video did not start as it normally does.
  • Jon Walker Level 6 Level 6
    This feels like there is some sort of error during save but I was wondering if a) anyone had experienced this or b) knew of a fix.

    1) Have used the screen capture option in the past to, more or less, test how it worked. Unfortunately, my Snow Leopard system is currently tied up batch processing files so I can't re-check things at the moment.

    2) How long are captures and how much time are you allowing between terminating the recording and forcing the application to quit? If I remember correctly, this is a 2-step process. In the first phase the screen is simply captured to your hard drive. In the second phase, the data is converted to H.264 compressed video and written to the target file container. If you force the app to quit prematurely, the target file is never properly updated/closed leaving it empty and/or unable to be opened. As to the controls, they remain deactivated until all of the data has been converted/written to the target file or you force the app to quit. The amount of time required to create the target output file is, of course, directly related to the duration of the screen capture.

    Suggest you try making a very short screen capture and see if the test file is successfully created. If it is, allow more time for the process to complete on its own with longer captures. If the process is not successful, try a similar test using a different user account to see if the problem is local to the user account or system wide.

  • Eduard1729 Level 1 Level 1
    I made about 30 screen capture videos during last a few days. This size was between 1 minute (19MB) and 1 hour (1.4GB). I didn't find any correlation between video size and the problem occurrence. After I stopped recording of the biggest (1.4G) video it only took about 2 seconds before is started playing indicating it was saved successfully.
    It looks like the recording saving randomly fails in about 10% cases.
    I didn't try another account since I doubt it would make a difference.
  • Saul888 Level 1 Level 1

    I found my lost video data in folder



    after opening Activity Monitor, selecting QuickTime process, clicking Inspect and checking Open Files and Ports.

  • Eduard1729 Level 1 Level 1

    deleted post

  • Eduard1729 Level 1 Level 1

    Saul888, were you able to play the files found in this folder?

  • Saul888 Level 1 Level 1


  • Saul888 Level 1 Level 1

    Try to switch Finder to show hidden files and folders. The path to temp files may be different on each computer. Always check the real path in Activity Monitor. Find QuickTime process, click on Inspect button and check OpenFiles and Ports.

  • Eduard1729 Level 1 Level 1

    I found a workaround. I have an external monitor connected to my notebook. I do record the external monitor. When I click the end recording button and it happens to be unlucky case when it can't stop, I simply disconnect my external monitor. As a result, after a few seconds, applications move to the notebook's monitor. The QuickTime shows an error message. I don't remember what it says exactly, but I think it complains that recording has failed because screen resolution has changed. I click Ok. As a result, QuickTime finishes recording successfully.


    In case you don't have an external monitor, you could try changing resolution of you monitor for a minute to archive the same result. I haven't tried it. This is just my guess.


    As for Saul888 workaround, unfortunalely, it never forked for me. I was able to find files related to failed recording, but I could never play a single one of them. Players complained about incorrect video format. I did follow Saul888's instructions.


    Also, I hope Apple fix this. I reported this to them, but no indication they even received my report. Communication from Apple regarding bugs is terrible. Perhaps, this is not as profitable as releasing next iPhone model with even more memory. Please report the issue to them as well.

  • Eduard1729 Level 1 Level 1

    I can confirm that, as I suspected, changing screen resolution without having to disconnect the 2nd monitor does the trick and makes QuickTime screen recording stop successfully after it hang at first. The exact error message that QuickTime shows in this case is "Recording stopped because the format oh the source media changed. Media of different formats cannot be recorded to the same file."

  • slojo404 Level 1 Level 1

    This works for me as well.  Just wanted to give a quick thank you for such a simple work-a-round to a problem that has cost me a fair bit of time.

  • David Das Level 1 Level 1
    Apple TV

    I'm having a parallel problem but can't solve it. Last night I used QT Player X to do a screen capture of a webcast. It was supposed to run for 60 minutes, but I accidentally let it run about 5 hours. Fortunately I had plenty of hard drive space free (120GB+ free on the boot drive).


    I stopped the recording after 5 hours, and QTPX showed me "Finishing Recording" -- so I left it -- and 12 hours later, it's STILL showing me "Finishing Recording" so I'm concerned that it's hung. And worse, I'm concerned I may have lost the 60 minutes of content I actually needed to capture.


    I took the advice listed above and looked at QTPX's Open Files and Ports. I found only one file similar to what was mentioned above:


    /private/var/folders/q8/g091bc7d76x3mhj_3x9vmmdm0000gp/C/ s-034502.csstore


    and looked at it (and all around it) but there is no movie file (or any other very large file) here or near here.


    Looking through Open Files and Ports I don't see anything else that could really be a movie file.


    Any other hints or ideas on where to look for the temporary file that I'm desperately hoping still exists?


    (The movie definitely doesn't exist in the target directory, which is Users/myusername/Movies).

  • nappyp Level 1 Level 1

    You guys are way more advanced at this than I am. I'm having the same problem. I've tried what Saul888 suggested, and I think I located the files when I go to Open Ports and Files, but once I locate the files, I'm not sure what to do next. I don't see any buttons or commands I can do next. Do I copy and search for it somewhere else through the Finder?

  • Saul888 Level 1 Level 1

    if you've found the place where your QuickTime writes tempraraty movie files, go to that folder with Finder, rename to *.mov and put them to your custom place.

Previous 1 2 Next