1 Reply Latest reply: Jan 27, 2011 10:12 PM by Limnos
nhcaller Level 1 Level 1 (0 points)
I have an iMac, Intel Core 2 Duo, OS 10.4.11. Five months ago, I purchased an external CD/DVD burner (Pioneer DVR-218L) in a multiple interface case from OtherWorldComputing. Everything worked flawlessly... I could burn iTunes CDs on that drive, using Toast I could copy DVDs from my internal drive to the external... life was good.

No longer. The computer simply doesn't recognize that there is an external burner attached.

I'm running it through with Firewire 400 cables, but I also tried Firewire 800 and USB2, with no luck. I've tried resetting the PRAM, and for one brief moment, thought I had licked the problem. I had a blank disk in the external drive and got a message saying that there was an unreadable disk, so I ejected it. Hooray! I put in a CD, which was recognized, momentarily. But when I went to copy those files to the computer, it was no longer recognized. And now I'm back where I was.

Very frustrating, because it had worked so smoothly and now it's not. I've spent much of today reading various message boards seeking an answer. Any suggestions?


iMac, Mac OS X (10.4.11)
  • Limnos Level 8 Level 8 (45,420 points)
    Something sporadic like that sounds more like a problem with the drive than with the computer or interface. You've tried several interfaces (FW, USB) which means it isn't just a bad port on the computer. If it was a bad bit of software I wouldn't expect the drive to briefly reappear like that.

    When the drive is plugged in, what does Apple System Profiler say about Firewire or USB devices? It could be the enclosure is working but the drive itself is bad.

    Have you phoned OWC about this? They have pretty good technical support and one reason for going with them is their reputation for standing behind their goods.