Previous 1 2 Next 21 Replies Latest reply: Feb 18, 2011 4:39 PM by Robert Enders
Stu531156 Level 1 Level 1 (0 points)
My iphone receives email ok but when I try to send it displays an message: username or password incorrect
I have deleted my account and reinut the details (which are correct) and were authenticated ok but the problem still persists!
I have used the phone for more than a year and never had a problem this error just seemed to pop up for no apparent reason!!

Iphone 3GS, iPhone OS 3.1.3
  • doctored Level 1 Level 1 (0 points)
    This seems to be affecting UK users over the last 24 hours.
    I have NO idea.
    It will probably disappear as mysteriously as it arrived...
  • 4kidsat147 Level 2 Level 2 (295 points)
    Mine is fine, what email provider is it and what network are you on?
  • wegras Level 6 Level 6 (14,070 points)
    3 for instance has specific smtp addresses you have to use but O2 seems to accept any smtp
    I use both so have had the foibles of "3"

    Neither are causing me a problem at this time fwiw

    Message was edited by: Peter Gillespie
  • 4kidsat147 Level 2 Level 2 (295 points)
    Ah but with NTLWorld, O2 needs it's own SMTP to be used as the virgin one won't work. LOL

    NTLWorld I can help with - the rest I'm a lost cause. LOL
  • doctored Level 1 Level 1 (0 points)
    The problem is affecting Yahoo (BT) mail on iPhone 3G running IOS 3.1.3.

    My 3GS (jailbroken) 4.1 seems OK.

    Gmail accounts working fine on both phones.

    Phone recognises and verifies the Yahoo account OK, but throws back error whenever you try and send mail.
  • cakesunlimited Level 1 Level 1 (0 points)
    My iphone is doing exactly the same thing since yesterday. Receives mail ok
    but gives the same error message when trying to send mail.
    The username or password is incorrect.
    Driving me nuts
    Have switched it off. Taken out email account and put back again
    Tried changing password.
    Tried syncing
    Its going out the window

    Yahoo (BT) mail on iPhone 3G running IOS 3.1.3.
    I am in the UK.

    Someone please help. What is the point if you can't send emails on the move.

    Message was edited by: cakesunlimited
  • jeannie777 Level 1 Level 1 (0 points)
    I solved my email issue my going to settings, mail, touch your account,under the incoming mail section you should see a place for your password (so you can receive mail) touch your outgoing mail server, on the next screen it displays SMTP, under Primary Server touch smtp.....com (mine is stmp.live.com cause I use hotmail) the next screen under Outgoing Mail Server, make sure that your password is inserted there as well (mine said optional). After I inserted my password, everything worked just fine. I didn't know that I needed it there too! Hope this helps!!
  • doctored Level 1 Level 1 (0 points)
    It was still happening as described after 24 hours, so, reluctantly, I updated the phone to IOS 4.2. All seems OK so far. It does slow things down a tad, but you get a few nice features, and sending Yahoo mail seems to get fixed.
  • HRDC Level 1 Level 1 (0 points)
    Did this get fixed for anyone? It started happening for me about four days ago. Like others I've deleted accounts and put them back in, I've tried setting them up under the "other" tab (like others I'm on bt internet which is a yahoo account), I've sworn and screamed (didn't make me feel better either), but nothing's working.

    I'm on t-mobile if that's relevant and have an Iphone 3G running OS 3.1.3 but I'm a bit of a techno-idiot so not much of that really means anything to me.

    I've tried adding my password under the SMTP server bit but I can't because it's greyed out. Any ideas? I'd upgrade to OS 4 if I knew how - so if that's what it takes can someone tell me how to do it?!
  • lifeisabeach Level 1 Level 1 (0 points)
    Same here. Can receive but cannot send email from my yahoo account. My google account works fine! Also PUSH isnt working. And theres more.....when syncing my address book itll go from my phone to yahoo but not in the other direction??
  • quiltingchristine Level 1 Level 1 (0 points)
    I too am with Yahoo and have been having this problem for 3 days now. I tried the password thing but i could not access the password in the last page because it was greyed out. I could have set a password in an additional server page but my courage failed me at that stage. Was considering downloading the new OSi4.2 but there appear to be problems with that apart from the e mail thing. Really not sure what to do now.
    I dont understand why it clearly recognises the password etc as it downloads the e mails to the phone, but then wont send anything out.
    Is this just a matter of patience? Will it really disappear as quickly as it appeared as someone suggested?
  • quiltingchristine Level 1 Level 1 (0 points)
    To HRDC - I tried to find the way to update to OSi4.2 when I was still running OS10.4 (Tiger) on my Mac - I found that this was impossible until I updated to Snow Leopard and now I am constantly getting asked if I want to upgrade my phone automatically when I go into iTunes. So unless you are running Snow Leopard...
  • HRDC Level 1 Level 1 (0 points)
    Thanks! But I have no idea what that means! My computer is a PC as well so I suspect that adds an extra layer of complication. Am going to attempt to find a way of contacting Apple about this without having to pay...
  • jojotigerlily Level 1 Level 1 (0 points)
    I am having the same problem since yesterday morning, I have done EVERYTHING above and nothing works, I can not send any emails and get the error. I might call AT&T today. Not sure if they can help me.
Previous 1 2 Next