9 Replies Latest reply: Apr 30, 2012 2:52 PM by Tim Robb
pwwwayne Level 1 Level 1 (35 points)
For a couple of weeks I have been having repeated problems with freezing while using Preview.

I have been through extensive troubleshooting the hardware: Increasing new HD to 500GB (from 120GB), installed total of 4 GB RAM (from 2GB), re-installed Snow Leopard OSX and upgrade to 10.6.6, repaired permissions, run Disk Utility with no problems found. I ran SMART and found no errors. Disk Warrior found 28% fragmentation and repaired directory. I trashed Preference Preview plist.

Many glitches went away but I am still left with freeze problems in Preview.

Today I re-started in Safe Mode and immediately encountered problems in Preview:
1. When I tried to open a few jpg files from desktop I got blank windows in Preview;
2. When I tried to open a folder of jpg files, the Preview window remained blank but the Sidebar strip displayed the jpg pics.

What do I need to do next to get Preview working properly?

MBP 2.2GHz Intel Core 2 Duo, Mac OS X (10.6.6), 4GB SDRAM; 500GB HD
  • baltwo Level 9 Level 9 (62,205 points)
    Create a new admin user account, log into it, and see if the problem persists.
  • pwwwayne Level 1 Level 1 (35 points)
    In a new account I had no problems of freezing in Preview.

    I have no idea what that indicates or means about freezing in Preview in my regular User account?
  • baltwo Level 9 Level 9 (62,205 points)
    Since the issue is specific to your original user account, you can proceed in two ways. One is to log into your new account, make a list of the preference files (plists) located in /username/Library/Preferences/, including any in the ByHost subfolder, log back into the original account, move everything on that other account's list from the original account's Preferences folder into a newly created folder on the Desktop, log out and back in, and see if the problem goes away. If so, you can copy the ones in the Desktop folder (one at time) back into /Preferences/, restart, and see if the problem returns. If so, you've identified the corrupt/conflicting one. Continue with all of them until isolating the bad ones. That'll save you the trouble of resetting preferences.

    The second way is much more detailed and I'll not burden you with the steps unless the above doesn't fix the issue.
  • pwwwayne Level 1 Level 1 (35 points)
    Thank you for reply.

    So I identify plists in my new account and then return to my original (1st admin acct) and remove these and add back in one at a time, restart and watch for freeze.

    I presume I can start with plist files associated with Preview (there must be hundreds of Preference files!) (Oh for the days of ConflictCatcher!).
  • baltwo Level 9 Level 9 (62,205 points)
    That's the procedure. You don't have to do it one at a time, do one half then the other half, then half of what's causing the issue, etc.
  • pwwwayne Level 1 Level 1 (35 points)
    (ah, that's the old automatic ConflictCatcher process.)

    There are 4 plists associated with Preview.

    I do NOT find a "ByHost folder" - at least Spotlight doesn't either ??
  • baltwo Level 9 Level 9 (62,205 points)
    /Users/username/Library/Preferences/ByHost/.
  • pwwwayne Level 1 Level 1 (35 points)
    Thank you, I found it

    -- dreading the "work" to be done . . . . .
  • Tim Robb Level 1 Level 1 (0 points)

    Following the instructions provided by Baltwo, after having some similar problems, I was able to fix this issue.

    I went into the "ByHosts" folder, deleted anything relating to imagery (these are basically just caches), and I deleted all the preview preferences files (including the .lock files) excluding the main com.apple.Preview.plist and it's lockfile.

     

    This seemed to solve the problem for now, for anyone looking for an answer.