Previous 1 2 Next 24 Replies Latest reply: May 21, 2012 11:33 PM by csgzs
akickintheteeth Level 1 (0 points)
I've got the same problem I've read about in other forums... Directory Services is hogging my cpu. Not doing anything, it's usually between 40% and 90% cpu... This has only begun happening since a format/reinstall of the OS (and everything else) about two weeks ago. I found some articles saying it was because of a long hosts file, and I have a huge ad-blocking hosts file, but I had that before and never had this problem until reinstalling... I'm also sharing the ethernet network via wifi, but again I was doing that before I reinstalled and never had any problems. Any clues?

Macbook Pro, Mac OS X (10.6.6), big hosts file, no other significant tweaks to network settings
  • baltwo Level 9 (62,215 points)
    Create a new admin user account, log into it, and see if the problem persists. My hosts file is 614 KB, but I don't do any wifi or wireless stuff.
  • akickintheteeth Level 1 (0 points)
    Didn't really help.

    I wonder if it's Safari? Before I reformatted I was using Chrome as my main browser. I've since switched to the native Safari... ?
  • baltwo Level 9 (62,215 points)
    Since the problem continues in the new account, the issue's system-wide. Download and install the 10.6.6 COMBO update. If still no good, reinstall the OS, and see if that fixes things. FWIW, I've only used Safari.
  • akickintheteeth Level 1 (0 points)
    Reformatting and reinstalling won't solve the issue, I think. As I said, this install is only two weeks old and this problem started occurring after the reinstall. :/

    I tried installing the combo update again (I installed it when reinstalled the os two weeks ago) and it looked like it was helpful for awhile but looking at istat on my dashboard, DirectoryServices is still consistently at the top of the processes list.

    Is there a way to copy user configuration from my current admin user to the other account you asked me to create? I'd like to try using the other account for a day or so and see how performance is, but I'd really rather not go through the hassle of re-customizing everything if the issue is going to persist. a side note to anyone at Apple reading this, I'm really surprised with this issue. I expect these sorts of strange problems in Windows but not from my mac, especially as I don't have any special or fancy configurations other than a 600k hosts file, which most would argue is not that special, or fancy.
  • baltwo Level 9 (62,215 points)
    Now, you're confusing me. Are you saying that the new user account does't exhibit the problem? The easiest way to do that is to use the new user's drop box:

    *To give a file to another user on your computer:*
    +Open the user’s Public folder (in their home folder in the Users folder on your hard disk).+
    +Hold down the Option key and drag the file to the Drop Box in the user’s Public folder.+

    BTW, no one from Apple routinely reads these posts. These are user-to-user forums.

    If you want to report this issue to Apple's engineering, send a bug report or an enhancement request via its Bug Reporter system. To do this, join the Mac Developer Program—it's free and available for all Mac users and gets you a look at some development software. Since you already have an Apple username/ID, use that. Once a member, go to Apple BugReporter and file your bug report or enhancement request. The nice thing with this procedure is that you get a response and a follow-up number; thus, starting a dialog with engineering.
  • akickintheteeth Level 1 (0 points)
    Well as I'm getting a little desperate to fix this I tried using a new admin account again and the problem seemed "less intense"... i.e. DirectoryServices wasn't going off at 100%+ cpu cycles... but I wasn't using the computer in the same way I do on my normal admin account because I didn't have bookmarks, user configurations, etc. etc. So what I would like to do is use the computer as I normally use it with a new admin account, and then see if DirectoryServices is still acting up.

    The trick is that I need (want) all my user configurations to migrate to the new account with me. It's not just the files I want copied between accounts... I don't suppose it's as simple as renaming my current admin user account to something else?

    Thanks for the tip on the dev program, I'll check it out.
  • baltwo Level 9 (62,215 points)
    Use the drop box method for the original user's preferences, such as finder, dock, mail, and safari, then repeat within that user's Library folder for the mail and safari stuff. Alternatively, you could delete the original account, saving its data (put into a disk image in /Users/Deleted Users), recreate the account, using the same username & password combo, log into that account, mount the disk image, and selectively move stuff back. Mainly mail, safari, and network settings. Do it slowly and that should rectify your issues.
  • akickintheteeth Level 1 (0 points)
    I went ahead and removed the ad blocking entries from the hosts file which completely resolved the issue. For now... I'd really love to see this properly fixed as I like my ad blocking hosts file; and simply not having a hosts file seems like a pretty lame workaround.. I submitted a bug to Apple, here's hoping they take a look at it.
  • baltwo Level 9 (62,215 points)
    As I already noted, my hosts file doesn't cause any of your issues.
  • akickintheteeth Level 1 (0 points)
    Whether or not you experience problems with a big hosts file is unrelated. Three weeks ago I also had a big hosts file on this same laptop, running the same software, and it was problem free.

    However now when I reduce the size of the hosts file, the problem I am experiencing stops. It means there is a major performance issue (DirectoryServices hogging cpu cycles) that is being triggered by a large hosts file.

    To be perfectly clear: I really doubt the hosts file is the root cause of the issue, but I've proven that it's a catalyst.
  • akickintheteeth Level 1 (0 points)
    Anyway, thanks for your helpful suggestions. As I said, hopefully Apple will take a look at the bug I submitted. I want my ad blocking hosts file back. haha
  • akickintheteeth Level 1 (0 points)
    Working with dev on this, they just confirmed that the hosts file is causing the issue. Hope to see this fixed soon~
  • Targon Level 1 (45 points)
    What is the bug tracker ID for the rest of us to follow its progress to resolve?
  • akickintheteeth Level 1 (0 points)
    Glad to hear I'm not the only one having the issue.

Previous 1 2 Next