11 Replies Latest reply: Mar 5, 2013 12:53 PM by AJDUF
codhoppers Level 1 Level 1
So I used the Kindle App from the App store for a few days, and now it will no longer open. Ive deleted the app and reinstalled as well as restarting my computer. When I try to open the app I get this error message.

Process: Kindle [377]
Path: /Applications/Kindle.app/Contents/MacOS/Kindle
Identifier: com.amazon.Kindle
Version: 1.2.3 (1.2.31370)
App Item ID: 405399194
App External ID: 3175812
Code Type: X86 (Native)
Parent Process: launchd [166]

Date/Time: 2011-01-29 12:12:35.048 -0600
OS Version: Mac OS X 10.6.6 (10J567)
Report Version: 6

Interval Since Last Report: 126469 sec
Crashes Since Last Report: 19
Per-App Interval Since Last Report: 40756 sec
Per-App Crashes Since Last Report: 14
Anonymous UUID: 6B5F4CFB-597B-4BA7-8A24-29F0B731CE0D

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread: 3

Application Specific Information:
abort() called

macbook pro, Mac OS X (10.6.5)
  • Carolyn Samit Level 10 Level 10

    . Ive deleted the app and reinstalled

    if you didn't use the combo udpate....

    Install the v10.6.6 combo update available here.


    Then repair permissions.

    Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. As long as you see, "Permissions Repair Complete" when it's finished... you're done.

    If you see any warnings re: SUID messages, they can be safely ignored, information here: http://support.apple.com/kb/TS1448?viewlocale=en_US

    Restart your Mac. See if that makes a difference.

  • codhoppers Level 1 Level 1
    I tried what you said, and unfortunately it didn't work.
  • Malcolm McGrath Level 1 Level 1
    I had the same issue with the copy from the App Store, but the copy downloaded direct from Amazon (v1.2.2) worked after about 15 minutes using an entire core on my MBP, although is rather jerky in selecting a book.
  • jdewald Level 1 Level 1
    Same issue and fix for me. Replacing my App Store Kindle with a directly downloaded Amazon Kindle solved inability to open Kindle. Interestingly, the Amazon downloaded one is supposedly "older" than the App Store one.

    An additional piece of information is that I have a large (I think) number of highlights in the current book I'm reading, and perhaps there was some bug in one of the versions of the Kindle software. 99% of the time when I open my iPhone Kindle software it crashes (and then will work when I re-open). Latest update supposedly fixes that.
  • lostbronte Level 1 Level 1

    I believe it is in fact a permissions problem. I tested it by downloading and launching the app directly from the Kindle disk img without moving it, and it opened without a problem. It's when it's moved or aliased that it won't launch.


    Someone at Amazon doesn't understand the Lion permissions structure (I don't either, I guess).


    What I ended up doing was accessing ~/Library/Application Support/Kindle/My Kindle Content (which is a system/hidden file). Then I right-clicked and selected Get Info on the folder. Click the padlock at the lower right of the window that opens, then type your administrator password. Adjust permissions as you like for other users of the computer, but leave the padlock unlocked. Then you shouldn't have any problems launching the Kindle app, even from aliases.


    I don't really know UNIX, so outside of Terminal you can access this hidden folder by choosing Finder>Go>Go To Folder and typing the path, then right clicking on the folder when it appears.


    I use free Tinker Tool software that lets system and hidden files be visible when I want them to be.


    I think the problem originates with the programmers' or publishers' concern about DRM and copying files. They need to fix this pronto.

  • Lancer Kind Level 1 Level 1

    Reading through this thread, I was able to discover the root cause, at least for my install of the Kindle.  Since Lion and probably even on Snow Leopard, my Kindle app wouldn't work when installed from Amazon or via the App Store.  It wouldn't work despite uninstalling.  An old version of Kindle did work but I let it "get away" from me and so I just didn't use it on the Mac for 8 months.  Today I got it working again for Kindle V1.9.2 (38421).


    Today I had some time to play and with the above information, this is what I discovered the problem to be:

    • The symptom: Using the Console I got the following error message for Kindle:

    7/10/12 12:01:07.495 AM [0x0-0x4bc4bc].com.amazon.Kindle: dyld: Library not loaded: @executable_path/../Frameworks/libWEbCoreKRF.dylib

    7/10/12 12:01:07.495 AM [0x0-0x4bc4bc].com.amazon.Kindle:   Referenced from: /Applications/Kindle.app/Contents/MacOS/../Frameworks/libWebCoreViewer.dylib

    7/10/12 12:01:07.495 AM [0x0-0x4bc4bc].com.amazon.Kindle:   Reason: image not found

    7/10/12 12:01:13.806 AM com.apple.launchd.peruser.501: ([0x0-0x4bc4bc].com.amazon.Kindle[22600]) Job appears to have crashed: Trace/BPT trap: 5

    Note with interest the suspicious spelling of "@executable_path/../Frameworks/libWEbCoreKRF.dylib" is spelled WEbCore  (the capital "E" is not to conventional coding standards and should be a lower case "e".

    • Doing a
      $ls /Applications/Kindle.app/Contents/Frameworks

              reveals that it's spelled libWebCoreKRF.dylib  (NO capital E, per conventional coding standards.)

    • Best solution: Amazon correct how it's linking libWebCoreViewer.dylib to libWebCoreKRF.  And tell them to test their releases on a "clean machine" so they catch these problems in the future. But we don't have time to wait for Amazon, we've got books to read, so read on.
    • Workaround you only have to do once: make a "file alias" using the ln command:
      $ln -s libWebCoreKRF.dylib libWEbCoreKRF.dylib

                   Make sure you DON'T put the arguments in the wrong order or you'll overwrite your existing libWebCoreKRF.dylib (a common mistake even among seasoned professionals), so make sure the argument with the captial "E" is at the end.

    • Other solutions: probably could use dyld to re-assign what library libWebCoreViewer.dylib is using and tell it to use the one with the lower-case "e".  I haven't tried this.



    If you're not getting the exact same symptom as I am, then this solution will not help you.  I imagine many people have the same problem as I am.  And does someone know how to report the problem to Amazon?




  • kloom Level 1 Level 1

    Thanks - that worked for me.

  • drdstny Level 1 Level 1

    Nailed it: the "ln -s" fix worked perfectly for me too.  10 points, half an Internet, three cats, two bottles of Pico-Pica--Whatever you need, Cure-All Brother of Happiness!

  • araym Level 1 Level 1

    Lancer Kind - That was absolutely great and solved my problems too, but I did have to make a slight tweak.  Allow me to explain for the benefit of others.


    When I tried it (OS Mountain Lion) the ln -s command failed due to no file permissions.  I run my Mac with multiple generic users for security reasons.  Even when running as the Admin account it still failed.  So I had to employ the sudo command in addition to what you typed above.


    Detailed instructions for others to follow:


    Sign in as your Adminstrator account.  Bring up a Finder window and go to Applications -> Utilities -> Terminal and launch that application.


    Once Terminal is up and running type the following two commands exactly.  If you have this window up in a browser you should be able to copy from the browser window and paste into the Terminal window:


    cd /Applications/Kindle.app/Contents/Frameworks

    sudo ln -s libWebCoreKRF.dylib libWEbCoreKRF.dylib


    At that point it will ask for your password.  This is your Admin account password, not root (I did not enable the root account).  Type that password in on the next line when it prompts you and after the sudo warning messages about knowing what you're doing.  It will then launch Lancer Kind's command fix above, but with the right permissions to actually make the change.


    Works great for me.  I couldn't be happier. Thanks much to Lancer!

  • rrelph Level 1 Level 1

    The problem only occurs on machines that have the partition that /Applications is on formatted "case-sensitive". This is not the way Macs usually ship. If the partition is not case-sensitive (the normal case) this problem is not visible because the two file names - libWebCoreKRF.dylib and libWEbCoreKRF.dylib - are "the same"..


    I hope Amazon fixes this. And I sure wouldn't mind if the people doing AppStore approval would try running on a machine that uses a case-sensitive partition.


    Thanks for the fix, araym, Lancer.

  • AJDUF Level 1 Level 1

    I have tried everything - and I tried this but when I open my terminal window there is some weird script in there (mentions my husband's iphone?!!?) and cannot be deleted.  When I copied your script in there and the password prompt came up it wouldn't let me type the password in there?


    Any clues much appreciated.  Kindle runs fine on my main Mac.  This is my new MacBook Air which was working fine until last week when it wouldn't sync.  So I uninstalled, reinstalled - have tried from app store and from Kindle site.  Nothing appears to work?  Crashes when asked for registration details?



    Any help much appreciated!