7 Replies Latest reply: Feb 14, 2011 9:25 AM by BigUncleJohn
BigUncleJohn Level 1 Level 1 (0 points)
Keep getting the message, "We could not complete your iTunes store request. The iTunes Store is temporarily unavailable."

Running iTunes 8.0.2.20 -- which is a supported version as it works every once in a blue moon. Antivirus passes the application, did the "Hosts" file delete as suggested in the troubleshooting, and did all of the other tests and still no connection.

I can log in, it tells me that all of my downloads are complete, I can authorize/deauthorize my computer, I pass all of the connectivity tests, yet I cannot connect to the store.

Digging deeper, I wanted to find out what the real error was. Turned on Wireshark and saw what was happening.

Checked my account on-line, and saw it hit

17.152.19.93
17.250.237.40
63.84.59.10
63.84.59.49
63.84.59.49
63.84.59.73
63.84.95.9
63.84.95.48
66.235.132.152

Great. Able to hit a large number of servers; not blocking the iTunes app. Must be an apple problem.

Selected the iTunes store, there was some preliminary handshaking on part of the iTunes app and 63.84.95.48 up until my client sends "GET /WebObjects/MZStore.woa/wa/viewGrouping?id=38 HTTP/1.1 /r/n"; couple of ACKs and then:

HTTP/1.1 500 Internal Server Error

This is a 'catch-all' error generated by the Web server. Basically something has gone wrong, but the server can not be more specific about the error condition in its response to the client.

Try it again -- 63.84.59.10; 500 error

Ah, so the servers are unable or unwilling to respond to the GET command. So what's the deal Apple?

Vaio, Windows Vista
  • BigUncleJohn Level 1 Level 1 (0 points)
    Some more information for you.

    Did a search through google and found a website with a description of an iPhone application. Clicked on "open in iTunes" and voila! iTunes opens on the PC and goes to the application web page.

    I can search using the search function, typed in "Al Green" and received his entire discography.

    Hit the "Home" button and, doh! "We could not complete your iTunes Store request. The iTunes Store is temporarily unavailable. Please try again later."

    Okay, did a search on "talking heads" and voila, "Accessing iTunes Store"; and here is all of their music and video.

    Hunh, and the home button sends server 63.84.59.24
    "GET /WebObjects/MZStore.woa/wa/viewGrouping?id=38 HTTP /1.1 \r\n"
    while the search sends server 63.84.59.40
    "GET /WebObjects/MZSearch.woa/wa/search?submit=edit&term=talking%20heads HTTP /1.1 \r\n"
    and it works.

    So. Still the same problem -- the server is refusing the home page HTTP-GET.
  • BigUncleJohn Level 1 Level 1 (0 points)
    This error is very, very consistent. I have had exactly the same issue for ten days now. Absolutely no success going to the home page in iTunes, yet the store is accessible if I do a search.

    Anyone at Apple willing to help? Hello?
  • tsprung Level 1 Level 1 (0 points)
    If you are having problems accessing the itunes store, it's because the old version no longer works with the itunes store. You need to upgrade to the 10.2.1 version of itunes. I hope this is what your question meant, since 10 other posts were about people having problems.
    -Therine
  • BigUncleJohn Level 1 Level 1 (0 points)
    There is only one thing on my iTunes that does not work, and that is the home page. I can sync my iPod, buy music, search for music, and manage my account.

    I have not found any notice anywhere on the apple.com site that says that iTunes 8.0.2.20 is no longer supported.

    If the software were unsupported, then wouldn't there be more than one function that does not work? And if it were true, why wouldn't there be an appropriate message other than "try again later". Isn't that rather misleading?
  • atpcliff Level 1 Level 1 (15 points)
    Hi!

    "If you are having problems accessing the itunes store, it's because the old version no longer works with the itunes store. You need to upgrade to the 10.2.1 version of itunes."

    When I upgraded to iTunes 10.0.1 I can no longer access the store, and I can no longer upgrade my iTunes software, so I am stuck with the old software, and no store, so no more spending money on apple products.

    cliff
    GRB
  • alfparks Level 1 Level 1 (0 points)
    I'm having trouble connecting to iTunes. I created the account last night without any problems and signed in. I signed back out because I didn't need it anymore at that time. I went to sign back in later that night and this morning and it won't let me. When the screen comes up to sign in, I can put it my user name just fine but the "Sign In" button isn't clickable. I don't know what to do. Can someone please help?
  • BigUncleJohn Level 1 Level 1 (0 points)
    After way too many emails from Apple support, it is clear that Apple does not want to support any other version of iTunes than the current version. If you are running anything other than the newest one, you may not be able to connect to the home page.

    All other functions should work fine, as long as the diagnostics pass. Try entering something into the search box, and see if you get a response. If so, you can continue to use the product, but you will only be able to buy those items compatible with your version of iTunes.

    The message you receive, I believe, is because Apple is intentionally blocking your access to their servers by what, in my opinion, is lazy programming and reprehensible treatment of customers. Its lazy because they know which version you are using, and can tell you that the application is no longer supported, but instead of doing so, they block access and provide a misleading message. It is reprehensible, because it is a trick -- everything works except for the home page -- the application is not really "not supported".

    @tsprung -- all of your comments on this board are recommendations to upgrade to the latest version. Thanks, but no thanks. I don't want to end up like @aptcliff or @alfparks or the legion of others who post on this board who have had trouble with the latest release and not be able to use my music library at all.

    And, @aptcliff and @alfparks, i recommend that you start your own threads, and provide a little more detail about what works and doesn't work, and perhaps someone who has experience will similar issues will help you.