4 Replies Latest reply: Apr 6, 2011 8:45 PM by russellben
JonFleming Level 1 Level 1 (0 points)
iTunes 10.1.2.17 84 bit on Windows 7 Ultimate x64.

I( have a set of MP3 files which make up an audiobook. They are all in their own folder. In iTunes I import the folder, find the individual tracks under Music, highlight them all, right-click and on the Options tab set media kind Audiobook, part of a compilation Yes, remember position Yes, Skip when shuffling Yes, part of a gapless album Yes, and click OK.

When I click on Books in the left-hand pane I see the book cover. If I right-click on the book cover and pick Get Info, Options tab I see that the media kind is Music. If I change it to Audiobook and click OK and check the setting, it remains set as Music.

If I look at Books in list view the individual files are media kind Audiobook.

When I click on my Touch in the left-hand pane and select Books I am informed that there are no books. Of course it doesn't get synced to my Touch.

Running Itunes as administrator makes no difference.

How can I convince iTunes that my audiobook is an audiobook?

Windows 7
  • rockmyplimsoul Level 5 Level 5 (6,215 points)
    What ID3 tag version are these mp3's? If 2.4 try converting to 2.3 to see if that helps.
  • turingtest2 Level 9 Level 9 (55,125 points)
    As far as I'm aware the media kind setting for audiobook isn't embedded anywhere in the tag, but if iTunes "knows" it can't update the tag (perhaps because it is marked as read-only or being accessed via an account without write access) then it may not change the media kind either. What happens if you try to change a single track? Are the options greyed out? If so, check your permissions. Both your account (or EVERYONE) and SYSTEM should have full access.

    tt2
  • syd3n Level 1 Level 1 (0 points)
    i'm having the same exact problem with iTunes 10.1.1.4 on Windows XP SP3.

    i can change the media kind of the individual mp3s, but when i go into the Books section, and do a Get Info on the compilation, it just says "Music". the first time i set this to "Audiobook" and sync my iphone, the books will sync and show up in the Audiobooks section of my iPhone's iPod app, but the next time i sync, the audiobooks are gone. In order to have them sync again, I have to once again set the compilation to "Audiobook" by doing a Get Info on the compilation in the Books section of iTunes.

    i am experiencing the exact same issue as JonFleming. i want to be able to have the media kind stay as "Audiobook". how do i do this? i tried looking at the log files for iTunes, but found nothing.
  • russellben Level 1 Level 1 (0 points)
    I'm having a similar problem. When I go to "Get Info/Options" the "Media Kind" is locked, and I can't change it. Any suggestions?