7 Replies Latest reply: Mar 9, 2011 7:52 PM by yanlinwood
yanlinwood Level 1 (0 points)
I'm using itunes 10, the latest version

Diagnostic looks fine, just cannot connect to the itunes store.
Here is the logs from the connectivity test:

Microsoft Windows 7 x64 Home Premium Edition (Build 7600)
ASUSTeK Computer Inc. N61Jq
QuickTime 7.6.9
FairPlay 1.10.24
Apple Application Support 1.4.1
iPod Updater Library 10.0d2
CD Driver
CD Driver DLL
Apple Mobile Device
Apple Mobile Device Driver
Bonjour (214.3)
Gracenote SDK
Gracenote MusicID
Gracenote Submit
Gracenote DSP

iTunes Serial Number 0E36B88AB9674317

Current user is an administrator.
The current local date and time is 2011-02-01 01:09:22.
iTunes is not running in safe mode.
WebKit accelerated compositing is enabled.
HDCP is supported.
Core Media is supported.

Video Display Information

ATI Technologies Inc., ATI Mobility Radeon HD 5730

** External Plug-ins Information **

No external plug-ins installed.

Genius ID: 470e1beeb9a518a233ba30508e219601

iPodService (x64) is currently running.
iTunesHelper is currently running.
Apple Mobile Device service is currently running.

** Network Connectivity Tests **

Network Adapter Information

Adapter Name: {54E0D7DF-BC44-46F3-A402-F22A8426AC8B}
Description: Microsoft Virtual WiFi Miniport Adapter
IP Address:
Subnet Mask:
Default Gateway:
DHCP Enabled: Yes
DHCP Server:
Lease Obtained: Wed Dec 31 19:00:00 1969

Lease Expires: Wed Dec 31 19:00:00 1969

DNS Servers:

Adapter Name: {3C7EECCB-F597-423D-960D-6D41E90D71A8}
Description: Atheros AR9285 Wireless Network Adapter
IP Address:
Subnet Mask:
Default Gateway:
DHCP Enabled: Yes
DHCP Server:
Lease Obtained: Wed Dec 31 19:00:00 1969

Lease Expires: Wed Dec 31 19:00:00 1969

DNS Servers:

Adapter Name: {4EFC042A-BA7A-4105-A7C0-283C94FCDE77}
Description: Atheros AR8131 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
IP Address:
Subnet Mask:
Default Gateway:
DHCP Enabled: Yes
DHCP Server:
Lease Obtained: Tue Feb 01 00:52:35 2011

Lease Expires: Wed Feb 02 00:52:35 2011

DNS Servers:

Active Connection: LAN Connection
Connected: Yes
Online: Yes
Using Modem: No
Using LAN: Yes
Using Proxy: No
SSL 3.0 Support: Enabled
TLS 1.0 Support: Enabled

Firewall Information

Windows Firewall is on.
iTunes is enabled in Windows Firewall.

Connection attempt to Apple web site was successful.
Connection attempt to browsing iTunes Store was successful.
Connection attempt to purchasing from iTunes Store was successful.
Connection attempt to iPhone activation server was unsuccessful.
The network connection was reset.
Connection attempt to firmware update server was successful.
Connection attempt to Gracenote server was successful.
Last successful iTunes Store access was 2011-02-01 00:59:38.

I've already tried all sort of ways.
-Disable firewall/antivirus
-No Im not using mcafee or norton
-Tried the uncheck proxy box
-Tried the delete the xml files from User folders
-Tried flushing ipconfig, by running cmd
-Tried restarting the computer/rebooting
-Tried reinstalling itunes

Weird stuffs that I figured out:
-I could still sign in to my account through itunes, but it just wouldn't show the itunes store. I keep getting the same message over and over again.
"We could not complete your iTunes Store request. The requested resource was not found"
-I could connect to itunes store if I'm in college. FYI, I'm using LAN connection at home, so there should not be a problem.
-I could still access ping and geniuses in itunes.
-JUST CANNOT ACCESS ITUNES STORE and cannot update my ipod to the latest 4.0 OS

What do I do now?

Windows 7
  • tsteele93 Level 1 (0 points)
    I'm in a similar boat, except I have an XP machine. I have been chasing this ALL DAY and finally tried something that was interesting.

    I went upstairs and fired up my wife's iTunes on her computer and it immediately prompted me to download the new version. She already has 10.1.2 but it wanted to update to

    It suddenly dawned on me... hmmm.

    So I declined the update and loaded the "old version" of iTunes and sure enough, it came up as normal, showed that she had 4 apps that needed to be updated. It allowed me to download them as usual.

    That means I've ruled out ANY connection problems as she is hard wired to the same router as my computer is, and she is working just fine.

    I'm going to try to re-install 10.1.2 and see if that works for me - if so I'll come back and post.

    -Tom Steele
  • tsteele93 Level 1 (0 points)
    Ok, I de-authorized my computer and followed the procedure on the apple support page to completely remove my itunes and apple software:


    Then I re-installed and re-authorized the computer.

    Oddly, this did not wipe out my music library, or my playlists. So regardless of how thorough it was supposed to be, it didn't remove all traces.

    At first I did not think it worked, but then I connected my iPhone to the computer and a new App Store screen came up showing the 129 apps that needed to be updated. And this time there was a "Download All" button on the top right hand of the screen.

    I clicked it and they are downloading as I type this. I still got a couple of timeout errors while these were downloading, but I just clicked ok and it resumed downloading again.

    I spent a whole day on this because I have an iPhone 4 that I want to restore from my 3gs backup and I wanted to make doubly sure that I had a clean backup and a clean copy of iTunes running when I make the switch.

    -Tom Steele
  • bigb93036 Level 1 (0 points)
    I hook up my new i touch to itunes and it says it cant connect to the i store but when i hook up my i phone it is fine. whats up? this is a brand new i touch and i am trying to set it up. what do i do?
  • yanlinwood Level 1 (0 points)
    I will try that and write another post if it works. Thanks anyway! (:
  • yanlinwood Level 1 (0 points)
    Dude, I have totally no idea. We need someone expert to help. I have the same problem, except I dont have iphone 4. I have ipod touch 3GS, which right now I have a problem with connecting to the store.
  • yanlinwood Level 1 (0 points)
    I tried your method, but it still doesn't work. I still can't connect to the itunes store. I can't update my ipod.

    This has been happening for almost 8 months now. Since the last updated itunes until now.

    Could someone please help?
  • yanlinwood Level 1 (0 points)