3 Replies Latest reply: Feb 13, 2014 12:48 PM by alfredolira
NojjerUK Level 1 Level 1 (0 points)
Hi, folks need some help.

I have read through a lot of the posts but cannot find the same symptoms to my problem.

Basically the whole of iWork doesn't seem to be working. In pages I cannot open any templates or existing documents from new or the template chooser. On the template chooser I select blank and the timer wheel comes up and that is it. When I select new I get nothing.

In numbers I can open existing documents and by setting what template I want through New i can open a blank template, however I cannot save, the options are greyed out.

Had this set up from 2009 and never had an issue but 2 weeks ago when I try and start a new template it all starts acting funny.

Please help I can't find my discs so hoping I won't have to re-install, but at moment can't see any other option (assuming that would even help).

Cheers

Jon

Mac Book Pro
  • DominikF77 Level 1 Level 1 (0 points)
    I actually had the same problem. Now iWork '09 completely stopped working on my Macbook Pro...
    Everytime I start any of the iWork Applications I get the following error code (in this case with Pages):

    Process: Pages [413]
    Path: /Applications/iWork '09/Pages.app/Contents/MacOS/Pages
    Identifier: com.apple.iWork.Pages
    Version: ??? (???)
    Build Info: Pages-7660000~4
    Code Type: X86 (Native)
    Parent Process: launchd [103]

    Date/Time: 2011-02-05 19:11:14.773 +0100
    OS Version: Mac OS X 10.6.6 (10J567)
    Report Version: 6

    Interval Since Last Report: 711362 sec
    Crashes Since Last Report: 18
    Per-App Crashes Since Last Report: 11
    Anonymous UUID: 855CBD3F-4E20-49EF-92B7-A4D161231332

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: @rpath/Inventor.framework/Versions/C/Inventor
    Referenced from: /Library/Application Support/iWork '09/Frameworks/SFCompatibility.framework/Versions/A/SFCompatibility
    Reason: image not found

    Binary Images:
    0x8fe00000 - 0x8fe4162b dyld 132.1 (???) <A4F6ADCC-6448-37B4-ED6C-ABB2CD06F448> /usr/lib/dyld
  • gbdoc Level 2 Level 2 (345 points)
    Re-installing the app is usually the first step in such a problem. It often works, and often nothing else works, because the app has become corrupted. So, unless you have your disks, or at least proof of purchase (which may move Apple to give it to you again), you may be up a creek.

    Other than that, you have a number of other things you could try: maintenance apps (OnyX, applejack, among others), real fixit apps (DiskWarrior, Drive Genius, TechTool Pro). If those didn't work, remove all prefs associated with iWork and its apps. Finally, re-apply the most recent OS combo updater.

    If you had a backup of your system from a time when everything worked, that would, of course, be easiest, but I suspect you don't, or you wouldn't be here.

    I wish you luck, but don't hold your breath.
  • alfredolira Level 1 Level 1 (0 points)

    In my case, Keynote or Numbers would not open after a clean Mavericks install. The App Store showed Intalled and just could not figure out how to download again. The problem was that my external drive connected to the mac did contain very old keynote and numbers application files, hence making the app store I already had these, though they did not show in my home applications folder... I deleted those from the external usb drive, re-opened the App Store, et voilá! installed and worked right away, like a charm, like everything Apple! Thanks!