Previous 1 2 Next 27 Replies Latest reply: Apr 24, 2014 10:34 AM by genesiafromva
_carpediem Level 1 Level 1 (0 points)
I got the iPod Touch 3rd Generation and when I first got it I was able to connect it to my internet perfectly without any trouble. But suddenly one day it just won't connect no matter what I do. I try reseting the Network Connection thingy and still nothing. I also unplugged and plugged in my router and still my iPod just won't connect to the internet. Whenever I tried to connect it this thing just popped up and said 'Incorrect Password' but I double checked and I did put in the correct password but for some reason it still won't connect. Please help.

Thank You

Windows 7
  • luvlabs Level 4 Level 4 (3,610 points)
    You need to take this one step at a time.

    First, reboot the router again.
    Second, reset the touch network settings - tap Settings > General > Reset > Reset Network Settings
    Third, tap Settings > WiFi > Other and manually log back onto your network.

    Other things to consider - a) does your router have updated firmware available? Download and install it.; b) stop using WEP or, if you have to use it, use the WEP hex key as the password - in place of any you have created yourself. Use WPA2 for encryption and use a good 8-12 character password.
  • Flyguy2 Level 1 Level 1 (0 points)
    Fixed it!! Hi Carpediem, I was having the same problem as you and bazmom and it would appear many others who have a 3rd and 4th generation ipod touch. My laptop situated alongside it would instantly pick up my router as would my desktop i.mac. The ipod would always see my router but rejected the password time after time. Very frustrating. Because of this I did not believe that it could be a router problem. However having read several posts from Luvlabs (don't we all?), I de powered my router and reset the settings in the ipod. None of this worked. Because of Luvlabs advice that it most likely was a router problem I phoned my ISP ( Sky.com) who supplied the router, to see if there was an upgrade. They said that there was not an upgrade for this router. When I explained my problem to the technical guy, he said that I should change my router channel from "auto" as supplied to channel 11 which was a stronger signal. As soon as I did this the ipod picked up the router and has worked perfectly ever since. The signal strength is also better on all the computers. I suspect that the problem may have been compounded by signals from other wi fi devices or equipment in the neighborhood debasing the router's signal. So a big thank you to Luvlabs, especially as the ipod touch concerned was for my wife's birthday!
  • _carpediem Level 1 Level 1 (0 points)
    OMG!!!!! THANK YOU SO MUCH luvlabs I just tried what you have said it did work....THANK YOU THANK YOU...
  • luvlabs Level 4 Level 4 (3,610 points)
    Happy to be able to help you. Come back if you have any other issues.
  • Flyguy2 Level 1 Level 1 (0 points)
    Hi Carpediem, just to avoid confusion and to help any one else, did changing your router channel fix the problem as I suggested? Or was it another solution that LuvLabs suggested? Glad that you are up and running fine.
  • Bethygnome Level 1 Level 1 (0 points)
    Hi,

    I have had similar problems with my iPod touch connecting to the wifi but not the internet. The conclusion seems to be that it's my router (and I dread calling verizon), but my dad has an iPad and he had no problems connecting to the internet when he was at my house. Is it possible it's still the router? I have reset the iPod and the router like 100 times and it's still not working. Thank you for the help!
  • Bruce Thomson Level 6 Level 6 (10,410 points)
    You haven't supplied much information about your situation. Here is a WiFi Troubleshooting guide for iPod, iPad devices: http://support.apple.com/kb/TS1398

    Please supply your iPod Touch generation, IOS version, inspect the IP address you get in:

    Settings > WiFi > tap your network name > tap the blue ">"

    Did you recently upgrade your iPod to IOS 4.x ?

    What kind of router, model#
  • luvlabs Level 4 Level 4 (3,610 points)
    Welcome to Apple Discussions. In the future, please post this as a new discussion. This is especially important that WiFi problems get posted as new as there are no universal fixes out there. Those of us who participate here have multiple approaches that all depend on what is going on with your individual problem.

    I'm not overly fond of Verizon routers (actually 2-Wire routers). Just because your Dad can connect, doesn't mean much - unless he updated his firmware as well to 4.2.1 and is not having problems.

    The easiest fix for to try is simply rebooting the router. Just unplug the A/C power cube, wait 20-30 seconds, and plug it back in. When it is done rebooting, try logging on again.
  • vivling Level 1 Level 1 (0 points)
    Hi Luvlabs, I was wondering if you could help me I have ipod touch 4 but I cannot seem to connect to free wifi hotspots.
    I can see the signal strength bar, and can see the wifi name and ticked, but when go into safari it says no internet connection.
  • jasper vincent Level 1 Level 1 (0 points)
    hi,

    i have read your advice below about hte router but can you tell me why my ipod touch won't connect to my bt home hub but my sons works fine and my husbands iphone works fine aswell. My ipod touch was working then i charged it on a docking station and since then its never worked!! Please can you help me???

    Regards
    Michelle
  • mattchesterunited Level 1 Level 1 (0 points)

    Saved my bacon, this was really annoying me. Thanks for the fix.

  • tiffanyfromnewburgh Level 1 Level 1 (0 points)

    i need hlep with ipod

  • nerd023 Level 1 Level 1 (0 points)

    I am going to try this. Mine is not connecting either!

  • raghavdone Level 1 Level 1 (0 points)

    hi,

    I have ipod touch 3g. i was trying to set a wifi network using my laptop (not imac) by wpa2 network using password but ipod was unable to connect the network even though the password typed was correct. so i tried another option using without password setting and it got connected ie. tick the network, show the signal strength. But when i opened safari, it showed that cannot connect to the internet...help me ....Also what r the setting for ip address (DHCP, BootP, Static)....and vpn ......

Previous 1 2 Next