8 Replies Latest reply: Dec 16, 2011 11:47 AM by tonefox
ekin Level 1 Level 1 (0 points)
Here's a new one I discovered just this morning - my camera app is missing. I thought you're not able to delete system apps (or in my case, accidentally delete because i have it set not to allow you to delete apps)? It thinks my iphone is an ipod now and I can't get the app back unless I do a system restore.

iphone 4, iOS 4, Mac OS X 10.6.6, iTunes 10.1.2
  • JimHdk Level 7 Level 7 (26,010 points)
    You haven't enabled restrictions for your camera by any chance? (Settings > General > Restrictions)

    See here: iOS: Restoring a missing Camera or Safari application
  • KiltedTim Level 8 Level 8 (42,250 points)
    If you set up an Exchange account for e-mail (for example, from your employer), Exchange is capable of enforcing restrictions on phones, including banning the use of things like the camera or web browser. This will cause them to disappear from the home screen until and unless you remove the Exchange account.

    If the administrators aren't careful, they can set these restrictions without realizing they've done so. They may have done so with the intent of controlling company owned devices without taking into consideration what the effect would be on individuals using their own handsets. They can also force the use of a passcode to access the device.

    I have seen some reports of this happening to people using Google hosted accounts or g-mail as well, when no restrictions were set up by the administrators. In that case, try removing and re-adding the Exchange account. If it still happens, you would have to contact Google for assistance as the problem originates on the server side.

    If you have NOT set up an exchange account of any kind, then I'd say you or someone else set up restrictions (as the post above posits). If neither of these are true, then I'd say it's there, you're just not seeing it. (Maybe you moved it into a folder by accident?
  • MacZA Level 1 Level 1 (0 points)
    I had the same problem that my camera apps were missing on my IPad2 after setting up my Google Apps for Business Mail account using Exchange.

    As per the above post it had to do with restrictions set on the Google Apps server not the device itself.

    As the administrator for the Google Apps account you need to go to your domain settings and then to service settings and select mobile from the list. Under the restrictions section you need to check the 'Allow Camera' box and then save changes.

    On the ipad you can try refreshing your mail or turning the account off and the on again and everything should work.
  • My Last Confession Level 1 Level 1 (60 points)

    The settings path you described does not exist (or I am not seeing it).   After clicking "domain settings," I do not see a "service settings.". I did, however, find under "Organization and Users" a "Services" tab but there is nothing here that I can find having anything to do with mobile or allowing camera.

     

    Can you please ckarify where the cam restriction is located? Thanks in advance.

  • KiltedTim Level 8 Level 8 (42,250 points)

    Are you the administrator of the Google or Exchange system? (this should not apply to 'personal' google mail accounts, only corporate accounts).

     

    If not, you will need to talk to your system administrator.

  • My Last Confession Level 1 Level 1 (60 points)

    Of course I am. Its my domain and I created all of the email addresses. I am logged in with the email address that I first create when activating google apps which is the administrator account.

  • felislibyca Level 1 Level 1 (0 points)

    My app was still there but when pushed, it just went black. I looked in settings and it wasn't there. I then did what most IT people tell you to do. First, turn the device off and then back on. When I did this, the camera app worked. Don't know the why's but it worked. When I looked in settings, the app still wasn't there, but was it there to begin with?

  • tonefox Level 6 Level 6 (8,775 points)

    No. Not all apps have entries under Settings.

     

    You just latched onto a thread which has been dead for nearly six months. You should really have started one of your own.   ;-)