Previous 1 2 3 4 Next 53 Replies Latest reply: Mar 20, 2014 12:42 PM by Michele Stapleton Go to original post
  • Richard Day Level 1 Level 1 (55 points)

    Did you delete the preferences plist for Mail? I haven't tried that. I think.

  • Tim - it just works Level 1 Level 1 (0 points)

    Hi. Tried removing the account and adding again and it seems better. Not used it enough to be sure but maybe worth a try for everyone. Will reply again when I have tried it for longer.

  • Tim - it just works Level 1 Level 1 (0 points)

    Everything I do, either deleting account and setting up again or quiting mail and restarting seems to fix it only temporarily.  When i restart mail it sends immediately.

     

    Also problem with mail ruless refusing to work - in another thread.  Maybe I will try reinstalling mail as I can't work like this any longer. 

     

    Just switched to MAC and rather ironic I may be forced to use outlook running in parallels for reliable mail!  Need parallels for some other software anyway.

  • olganyc Level 1 Level 1 (0 points)

    My wife had this same problem on her MacBook, running OS X 10.7.1 and Mail 5.0. Just doing the repair disk permissions trick seems to have fixed the problem (no reinstall of Mail). At least I could immediatly send an e-mail afterwards.

     

    Thanks a lot!


    Svein

  • olganyc Level 1 Level 1 (0 points)

    I was too fast on that one. It worked for a few hours, then it stopped sending. I had to install Thunderbird for her to send her e-mails, and she is very frustrated about it. Anyone knows how to fix this problem?

     

    Svein

  • olganyc Level 1 Level 1 (0 points)

    An update: After living with a very frustrated wife for some time, and taking quite a bit of heat for not being able to fix it, I tried creating a new user profile to see if the problem would still be there. And lo and behold, Mail worked fine in the new user profile.

     

    I am not a Mac expert (sorry, I am a PC...), so I don't know much about how the configurations are stored for the user profiles, and I wasn't able to find out what was wrong with her profile. I tried to copy over some preference settings to /users/PROFILE/library/preferences from the new working profile to the non working one, but it didn't make any difference.

     

    So, the solution was to move over all documents, music, movies and so on from the old user profile to the new one, which required changing the permission settings on the user directory. And now, using the new user profile, everything seems to finally work.

     

    I hope this helps for others having the same problem.

     

    Svein

  • Carroll Morgan Level 1 Level 1 (55 points)

    I've been having problems recently (October 2011) with hanging sends and drafts not being saved. This is in Lion, not Leopard; but perhaps the same solution applies.

     

    Checking the console log on the Mac, I found complaints about a file being locked. Didn't say which one; but I guessed it was the Drafts folder on the mail server (Debian Unix I think). So I logged into my account there with terminal, deleted the file Drafts.lock which indeed was there, copied (not moved) Drafts to a new file, deleted the original, then moved (not copied) the new file back to Drafts. That probably was enough. But for good measure I deleted the .imap/Drafts directory, since if missing it will be regenerated anyway.

     

    All fixed.

     

    Probably something died while holding a lock on Drafts.

     

    Carroll

  • windsurfertx Level 1 Level 1 (0 points)

    Mac mail is working just fine.

    Howerver there is one email that is hung up and locked up.

    I can not delete it, click on it or anything.

     

    This email is to multiple recipients, around a hundred, I've got the message "can not send mesage using the server"  That server works fine with other emails.

     

    I copied the email recipients and the body of the email (from where I pasted it from) loaded it all into outlook on my windows pc and it went fine.

     

    How do I delete this email.  I dont want it to go out again.

     

    Thanks

  • zappullae Level 1 Level 1 (0 points)

    same problem.  deleting the outgoing server and creating it again sometimes worked.  I found that I had multiple smtp servers defined.  duplicated the primary account server.  check that.  When all is said and done I needed to add my user name and password to the primary account.  it's optional.  my server requires a user name and password to send email from a domain that is not the hosting companie's.  And the user name has to be a full email address like name@domain.com.

     

    Hope this helps....ed

  • r56 Level 1 Level 1 (0 points)

    Mine is doing this today.  The outgoing mails are not going anywhere.  *****... I had to type it all out again and send it on my iPhone.  ***??

  • zappullae Level 1 Level 1 (0 points)

    I finaly fixed it.  I had 2 servers defined for the same POP account.  The default server is not just a selection but an actual server instance.  I also had one for the pop account.  However, under iOS 5.0.1 it appears mail settings have changed.

  • edfromagoura hills Level 1 Level 1 (0 points)

    I HAVE THE ANSWER!... I have been dealing with this same issue for over 2 years on my MacBook Pro.

    It confused me (and every tech genoius I could find) because it only happened while using the MacBook Pro at my office, and was fine at home and at other areas.

     

    But what you need to do is use GENERIC DNS... The 2 from google are

     

    8.8.8.8

    8.8.4.4

     

    In OS X Snow Leopard 10.6.8. Go to System Preferences, then click on Network, then click on "Advanced" button at bottom right) CLick on the DNS tab. Under the DNS servers column you will probably see 192.168.1.254 (this is your routers default DNS) The problem is outgoing mail tries to go, it's getting slowed down here, so to bypass it you add using the + sign the 2 new DNS servers.. 8.8.8.8; 8.8.4.4. These will replace the router's default DNS of 192.168.1.254 (this was told to me by Apple Tech Support after over 4 different attempts to find some one to help me) Click "OK" and then click "Apply". Restart your copmputer... Go to your MacMail and try sending a "test email" (no attachment) to yourself. It should leave the OUTBOX immediately (unless there's an attachment) and almost instantaneously, you will get your test email in your INBOX... Voila!  NOw, the only thign I haven't been able to figure is how to keep these two generic DNS server addresses in my system preferences..Because when I go to a new router (like my home wi-fi router, or even a wi-fi hotspot) the DNS will default back to 192.168.1.254... Just do this procedue whenever you see it revert back.. Maybe there's a way to keep the 8.8.8.8'; 8.8.4.4 in there permantley? I dunno. But I'm so friggin happy thatr I figured it out (or should I say the Apple Tech guy did) and my email life is no longer agony... I used to have to wait almost 35-60 seconds for a sinple email to leave MacMail!  All web based email clients worked fine.. I was losing my mind!  But now I'm good, try it folks! It works.  Why this hasn't been posted elsewhere, I have no idea, but Apple needs to tell everyone this workaround  ~ So pleased  ~EP

  • deblq Level 1 Level 1 (0 points)

    I had this problem with my MacBook Pro running Leopard after sending a file with very large attachments. I tried closing Mail and opening, rebooting, shutting down overnight. Just kept spinning in the Sent and while Mail would receive mail, all outgoing messages were put into the Outbox and not sent.

     

    After reading all the info below, I plugged in an ethernet cable, and almost immediately go a popup that Mail could not send the message with the server selected. It allowed me to edit the message, so I deleted the attachments and changed the message to go to me, and it sent immediately. Also, the spinning wheel by Sent disappeared, and email is now going both ways.

     

    Thanks everyone for your ideas! Hope this helps someone who is stuck in this spinning wheel of doom.

     

    Deb

  • neilcan Level 1 Level 1 (0 points)

    Just discovered this wonderful feature too and when I check the Mail Connection Doctor I get two seperate instances of each of my accounts, see below. Does this happen for anyone else?

     

    I'll keep checking back in the forlorne hope that a proper, solid fix is identified. Until then, I'm going to use Thunderbird - downloading as I type....

     

    Screen Shot 2012-02-03 at 16.39.15.png