Previous 1 2 3 Next 142 Replies Latest reply: Mar 14, 2012 8:34 PM by restorationgirl
D_LAW12 Level 1 Level 1 (0 points)
When I open the iTunes Store, it will begin to open properly. Then, it begins to slow down, and right before it is entirely loaded the entire store will turn white! It doesn't say "unable to connect" or anything of that nature. it's just a white screen. This has never happened before, I don't know what to do. A resolution to this problem is of course greatly appreciated.

Windows XP
  • Jynrah Level 1 Level 1 (0 points)
    I am having this exact same problem! The screen begins to load and then the loading bar slows down, and right before it finishes loading the screen goes blank. I just noticed it yesterday, and it has never happened before. I had no problems connecting to the iTunes store a few days ago either.
  • fu_itunes123 Level 1 Level 1 (0 points)
    This is happening when I open the iTunes Store, it will begin to open properly. Then, it begins to slow down, and right before it is entirely loaded the entire store will turn white! It doesn't say "unable to connect" or anything of that nature. it's just a white screen.
  • Jynrah Level 1 Level 1 (0 points)
    Oddly enough, I can access the iTunes U tab, but none of the other ones. Also, I ran a diagnostic on my network connectivity, and it claims that I can access the store.
  • Supra1979 Level 1 Level 1 (0 points)
    I'm having the same problem. I bought a song this morning and after I confirmed the purchase, the Itunes Store screen went white. I searched the artist again and now the standard theme is to load a page 90% of the way and just as it finishes loading, it goes to a white screen. If I click the Home button it "sometimes" tries to load and if it does, it loads 90% of the page and finishes with a white screen. If I type in the search box it will do the auto complete function and finish the rest of the artist's name. It's as if this problem lies solely within the Itunes Store because everything else is working fine. I've tried restarting Itunes, my computer and all that stuff. It's very irritating to say the least. I also haven't installed anything new on my computer that would somehow be linked to the problem.
  • HolySweetDamnThisMakesMeMad Level 1 Level 1 (0 points)
    Same problem here. The store loads, a little slowly, then just as it seems to finish it all disappears and goes white. No new installs of any kind have been made to this machine in weeks.
  • RomanMoreno Level 1 Level 1 (0 points)
    Absolutely so frustrated here. Same problem as others reported. I-Tunes Store screen appears for a brief moment and just before it gets to 100%, the screen goes blank. Headers identifying my account and available monies still appear. Any ideas?
  • PattersonWM12 Level 1 Level 1 (0 points)
    I'm also having this problem. The store starts loading, begins displaying images form the homepage, and then immediately goes blank. There is no error message or anything, it just goes all white. I tried closing and reopening iTunes, but it didn't work. I waited several hours then tried again. Still nothing. Does anyone know what may be happening?
  • iiiooopppqwerty Level 1 Level 1 (0 points)
    I'm having the same problem here.
    Apples' conceived perfection is going down the toilet with this screw up.
    They'd better fix it soon
  • Abbeygirl Level 1 Level 1 (0 points)
    I am also having the exact same problem as all of you are. Have spent the last hour trying to hook up to the i tunes store. Sent them an e mail, hope they respond, but I'm glad to see others are having the same white screen. Was afraid it was my fault!! Hope they resolve this
  • Supra1979 Level 1 Level 1 (0 points)
    Another interesting thing that happens to me with this problem is that as the page is ALMOST done loading, I can "sometimes" click on a link/button such as a song title and it will start to load the page associated with that click. Then as that page is loading the same thing... it finishes with a blank white page. I have been lucky a couple times (if you want to consider it luck) and was able to select a link/button from the currently loading page which allowed me to load an additional page just long enough to quickly click on something else to keep it loading pages. But no matter what, it will always finish with a blank white page if I allow it to load completely. I also ran it past a few people on Facebook tonight and the only 2 people I communicated with about it were also having some troubles. I'm wondering if this is a widespread problem.
  • Abbeygirl Level 1 Level 1 (0 points)
    I believe it is!! I did some of the same things everyone else has done and have had the same results!!
  • Abbeygirl Level 1 Level 1 (0 points)
    I also was able to connect to the itunes U tab, but none of the others.
  • NSDQ Level 1 Level 1 (0 points)
    Same issue. I've tried to access ITunes U at least 5 times within the last 15 minutes and while everything initially appeared normal...poof...the screen turned whiter than a ghost on Halloween. At one point I did get a chance to click on a download button but when the screen blanked, the DL stopped. Glad it wasn't just my machine.
  • kgbohio Level 1 Level 1 (0 points)
    I'm having the same problem here. Given that so many folks are popping up with this issue, I'm not inclined to uninstall iTunes and reinstall it, since obviously this error is occurring across many computers and various platforms.

    I'm running iTunes (or trying to run) version 9.0.3.15.

    Everytime I open iTunes I see the iTunes store for a brief second, and if I'm really quick, I can click on a link, but once the page is loaded, the iTunes screen goes 'white'.

    The iTunesU page STILL does work, which leads me to believe that something is basically screwed up with Apple rather than something wrong with this version of iTunes.
Previous 1 2 3 Next