3 Replies Latest reply: Feb 6, 2011 10:49 AM by KTransue
Scott Blackman Level 1 Level 1 (5 points)
I realize there are a few topics floating around about this issue, but I'm still not finding a solution. Not sure if my situation is different than the others but figured I'd take a shot a describing my scenario in a new thread and seeing if it generates any new ideas.

I have a 2TB Seagate external expansion drive connected to a MacMini on my home network. The drive is formatted as Mac OS Extended (Journaled) and is not partitioned.

I have mounted the drive on my MacBook Pro 2.66/i7 running 10.6.6. I then go to the TM Preference pane and select the drive, enter the username and password for my admin account on the Mini. It indicates that it's preparing and then comes back a minute later with a Time Machine error indicating that the backup drive is not available.

I have an older MacBook Pro, my sons MacBook, and my wife's Macbook also on the network. Each of these Macs can mount the backup drive, select it in the TM Preference pane and successfully begin and maintain the TM backup.

I have created a second "test" account on my MacBook Pro. I have followed the same steps and have had no problems with time machine preparing and successfully beginning the back up account.

So - with those facts - I have had to conclude that there is something amiss with my main account.

Other steps I have taken on my MBP with my main account include:

* Deleting the com.timemachine.plist file from /Library/Preferences - restarting and trying again. No luck.
* Restarting into applejack and performing an "applejack auto restart". No luck
* Removing all timemachine related entries in the Keychain, running Keychain FirstAid. No luck.
* Reformatting the external drive on the Mini, repairing permissions and running a disk repair and starting all over again. No luck.

In each case above a restart was done before attempting to reinitiate the TM process.

So - with out blabbering on with any more details, I think it's clear that I'm at a bit of a loss as to what else I should try. I'm WIDE open to suggestions.

MacBook Pro 2.66 / i&, Mac OS X (10.6.6), MacBook Pro 2.4/Mac Mini 1.66 / iMac 1.83 /
  • 1. Re: Time Machine: Backup Disk Not Available
    Linc Davis Level 10 Level 10 (118,525 points)
    You seem to have deleted the system-wide TM preference file, but not the ones in your home folder. They are:

    ~/Library/Preferences/com.apple.TimeMachine.plist ~/Library/Preferences/ByHost/com.apple.TimeMachine.*.plist

    where '~' stands for your home folder and '*' stands for a long string of numbers and letters.

    If that doesn't help, launch the Console application (in /Applications/Utilities) and select 'system.log' from the list on the left. Enter 'backupd' in the "String matching" field. Do whatever it takes to reproduce the problem, and look for any new messages that appear. Post them here.
  • 2. Re: Time Machine: Backup Disk Not Available
    Scott Blackman Level 1 Level 1 (5 points)
    Thanks for the reply Linc.

    None of the Macs I listed - including my primary MBP have these files:
    ~/Library/Preferences/com.apple.TimeMachine.plist ~/Library/Preferences/ByHost/com.apple.TimeMachine.*.plist

    I did open the console as you described. I then proceeded to follow the steps to select the backup drive on my networked MacMini. Received the following (I've replaced 'real' names with <text>:

    Feb 5 10:12:33 <MyMacName> com.apple.backupd[3783]: Starting standard backup
    Feb 5 10:12:33 <MyMacName> com.apple.backupd[3783]: Attempting to mount network destination using URL: afp://<username>@MacMini.afpovertcp.tcp.local/TimeMachine
    Feb 5 10:12:34 <MyMacName> com.apple.backupd[3783]: Mounted network destination using URL: afp://<username>@MacMini.afpovertcp.tcp.local/TimeMachine
    Feb 5 10:12:38 <MyMacName> com.apple.backupd[3783]: Creating disk image /Volumes/TimeMachine-1/<MyMacName>.sparsebundle

    So - as you can see - it worked! What worked? I have no idea. I honestly did NOTHING differently than I've described above. I had made no changes to my primary MBP, the MacMini or the drive itself. For whatever reason this time it worked.

    So I'm happy, but baffled. This has honestly gone on for days and I truly have been scratching my head to try and understand what was going on.

    I'll mark this thread as "yes, my question has been answered" but to be truthful, I'm puzzled as to how

    Unfortunately this probably helps no one, but I'm happy to try and describe additional details if anyone wants me to.

    Again, thank you Linc for taking the time to provide assistance.
  • 3. Re: Time Machine: Backup Disk Not Available
    KTransue Level 1 Level 1 (0 points)
    I resolved this issue just this morning (see below). This may not (or may) apply to your situation because yours magically corrected itself, but hopefully it will help somebody.

    Environment Architecture: We appear to have a very similar system architecture to the one you describe. In my case, we have 4 macs all relying on Time Machine and a networked 1TB Time Capsule for backups. Each of 3 workstation macs share data from the 4th, which we use as a primary server. I ran into my problem when the Time Capsule filled up and stopped backing up our primary server due to lack of available space. All recommended solutions for freeing up space appeared time consuming, and because we do daily off-site backups through MOZY (we use Time Machine for simplicity of recovery for hourly backups) I could take the "easier" path of just reformatting the Time Capsule's data drive and start again fresh.

    Problem identified: Per instructions, I used Airport Utility to erase my Time Capsule data drive, but thought I'd check my existing settings while I was there. Seeing the password prompt, and not remembering for sure what my password was, I thought I'd just reset it to what I wanted. Seemed benign at the time. When I started my 1st system's backup, I was prompted for the Time Capsule's password, and entered the new password. It accepted it as it should have, but then rejected the backup with a message indicating that I had provided the incorrect network account and password. The odd part was that it had originally accepted it, and even flashed the available space on the Time Machine preferences window. After much searching through these topics, I discovered that the password is stored multiple times -- some correctly and some not. Correcting the passwords fixed the problems.

    Where to look:
    http://support.apple.com/kb/TS2048
    Mac OS X 10.5.3 or later: Time Machine - "Backup volume could not be mounted" after changing network volume's password
    * Last Modified: October 14, 2008
    * Article: TS2048

    As it turns out, Apple stores that password in multiple places in your Keychain (don't ask me why!), even using the identical Keychain entry name. All I can presume is that one piece of the software looked in one Keychain entry, and another looked in a different Keychain entry. The passwords were different (one was my original password, and one was my new password). Once I changed them to the same thing on each of my satellite stations, they all worked again and Time Machine is happily chugging along on all workstations.