3 Replies Latest reply: Mar 27, 2011 12:47 PM by Terence Devlin
sterestherster Level 1 Level 1 (0 points)
Just got my MacBook Pro yesterday and already today there are problems. When trying to open iPhoto, I get the message that iPhoto is damaged or incomplete. I have reinstalled it using the cd that comes with the MBP, but it's still not working.

I downloaded iPhoto library manager as I read somewhere on this forum, but I get the message:

Unable to launch iPhoto: iPhoto could not be launched because an error occured (* -[NSCFDictionary setObject:forKey:]: attempt to insert nil value (key: _NSTaskExecutablePath))

Anyone got an solution for this?

Macbook Pro 13 inch, Mac OS X (10.6.6)
  • Terence Devlin Level 10 Level 10 (133,175 points)
    I have reinstalled it


    Did you delete the receipt before re-installing?

    To re-install iPhoto



    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)

    2a: On 10.5: Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

    2b: On 10.6: Those receipts may be found as follows: In the Finder use the Go menu and select Go To Folder. In the resulting window type

    /var/db/receipts/

    A Finder Window will open at that location and you can remove the iPhoto pkg files.

    3. Re-install.

    If you purchased an iLife Disk, then iPhoto is on it.

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

    Regards

    TD
  • Perrin32545 Level 1 Level 1 (0 points)
    What are options if iPhoto on your install disc is an older version that came with '07 MBP...I tried to reinstall ( disc 1 ) but kept rejecting the finish up disc ( disc 2 )...my updated versions of iPhoto were downloaded from internet...
  • Terence Devlin Level 10 Level 10 (133,175 points)
    my updated versions of iPhoto were downloaded from internet...


    From where?

    Regards

    TD