8 Replies Latest reply: Oct 17, 2012 9:16 AM by Ashley Drees
timaceuk Level 1 Level 1 (40 points)
Hi all,

i'm in a pickle, I cannot enable automounts for either NFS or AFP, when i click the checkbox and go in to properties for automount for an AFP or NFS Share it prompts for password and reports back to me 'incorrect user name or password' i have triend my local server admin, diradmin and i know the passwords and usernames are correct as they work for WGM

any clues at all

MacBook Pro 17", Mac OS X (10.6.3), iPhone OS 4
  • timaceuk Level 1 Level 1 (40 points)
    I have posted 3 screenshots here for you to view f it helps

    https://public.me.com/timace
  • timaceuk Level 1 Level 1 (40 points)
    Self Solved
  • nezyrin Level 1 Level 1 (0 points)
    mind to share the solution?
  • ChrisBastian Level 1 Level 1 (0 points)
    Would you mind sharing your solution here. I am having the same issue.
  • Niloc_415 Level 1 Level 1 (0 points)

    Likewise ...

  • DY-E Level 1 Level 1 (20 points)

    Hi folks. Maybe these pointers will help others:

     

    • Ensure you know your open directory admin account details. If you don't, work hard to remind yourself the details, or check in Workgroup manager.
    • Make sure you are connected to the local LDAP directory, i.e. LDAP/127.0.0.1
    • Make sure your 'users' or 'home' folder has sufficient read permissions for your users
    • Look at the individual home folder share paths. Are there any variations listed (in Workgroup Manager)? If so, try allocating test users each of the different home directory paths, and see which one is happier.
    • Use the terminal command 'sudo changeip -checkhostname' to check your hostnames / DNS setup
    • If ANY errors crop up here, you need to use the changeip command to either change your server IP address, or more likely, change your DNS setup for your server name.
    • DNS doesn't have to be running on this server (your AFP server), but you need to make sure the DNS entries resolve correctly for the server it's self, and for workstations accessing this server.
    • Final HINT: If you can mount the "users" or "home" folder, but not the individual user folder, then you either need to check the 'changeip' command, or check the 'path' for individual users. Or both of these.

     

    I'm sure these pointers will help someone out there... (My setup is working fine). If you think of any I've missed, feel free to add them!


    Cheers,

    D.

  • Ashley Drees Level 1 Level 1 (25 points)

    I too am having this, the systems all check out fine... changeip -checkhostname is good, the diradmin user is good as i can create and delete users and work in Workgroup manager just fine... my administrator account for Server admin is OK as i can create groups just fine... OD is up and so is Kerb and LDAP...

     

    I have a master OD and a replica, and i cannot create an automount share on either, though i can create a share on either... which log file might be useful to check into this... (i HAVE already been looking at logs) - i am seeing a lot of "Network Transition Occourred" in "directory services server log"... but are these anything to do with this issue?

     

    Has anyone else (still) go this issue?

     

    I was going to promote the backup to Master and see if that enables me to recover from this issue (perhaps in creating the config to promote the error will get cleared up), but as i use the Backup for day to day as well, i will try that OOO hours.

     

    (the ability to migrate users to another machine is holding up our migration to ML and google.apps, so would be very pleased to get a handle on this)

  • Ashley Drees Level 1 Level 1 (25 points)

    OK, i have not yet found a way to bring back apples neat GUI way of doing this, but i DID find a workaround...

     

    I downloaded the very wonderful "Apache Directory Studio" and copyied my existing Users automount to a new record with the correct data for my new share.. - it worked.. and i now have a working NetUsers share on another machine... not optimum as i would love to get the GUI working properly again, and to be honest, hacking around within LDAP is not my ideal high tea... but it worked and i am happy... as far as that goes..