8 Replies Latest reply: Sep 21, 2014 12:07 PM by BDAqua
arb70sok Level 1 Level 1
I have seen lots of posts on this issue before and NO clear solutions or resolutions.

Problem:

Admin account works absolutely fine and can access all https sites no problem.
Standard accounts can not access https sites at all from either Safari or Google Chrome.

Safari returns this error:

Safari can’t open the page “https://www.google.com/accounts/Login?hl=en&continue=http://www.google.co.uk/” because Safari can’t establish a secure connection to the server “www.google.com”.


Chrome returns this error (seems more informative):

SSL connection error
Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.
Error 107 (net::ERRSSL_PROTOCOLERROR): SSL protocol error.


My hunch is that it has something to do with Key Chain access but I do not know much about Macs so could be completely wrong in that. I am pretty annoyed as this should 'just work' out the box and really should not require any special set up. I am using parental control to restrict access to adult websites but no other restrictions on the standard accounts have be set what so ever.

If anyone can give me any clues on this or point me in the right direction would much appreciate it.

This is on a Mac Book Pro 15" and Mac OS X 10.5.8.

TIA,
Andy

MacBook Pro (15" 2.8G Intel Core 2 Duo), Mac OS X (10.5.8)
  • roam Level 6 Level 6
    Hi Andy,

    I am using parental control to restrict access to adult websites but no other restrictions on the standard accounts have be set what so ever.

    As I suspected from reading your topic, using parental controls is the cause.
    Parental controls is a bit of a joke as it disables the https protocol as you have found out. If you want to filter content at your end, you'll need to find other software.
  • arb70sok Level 1 Level 1
    How daft is that?

    Thanks a lot for the info. I will switch off parent controls to verify that is the issue and update this thread if it is.

    On Windows I used Cyber Sitter for this. When I got the Mac I thought "brilliant this is built in and it seems really simple to administer". Shame it does not work. Oh well. Glad I did not spend days fiddling with key chains, firewalls browser setting etc, etc.
  • stanfromnull Level 1 Level 1

    if you still want to use Parental Controls, you can bypass this problem

     

    Parental Controls --> Web --> Customize

     

    then add all the https: URL you want to use in the Always allow these websites section

     

    a bit troublesome but it works

  • umbasa Level 1 Level 1

    Even easier: enable parental controls like you wanted to, then "allow unrestricted access to web sites", then use DNS IP addresses 208.67.222.222 (220.220 for 2nd) on the computer for DNS under network settings,  then pay $10/yr for an opendns.com account where you restrict access to unwanted sites from your house. that easy.

  • Aidan Quigley Level 1 Level 1

    I had this/ a similar problem - I was prevented from accessing https://www.google.co.uk  with the errors you mentioned on both safari and chrome. I fixed it by adding https://www.google.co.uk as a certificate to keychain access > 'my certificates' > right click > new identity preference > add the url

    strange I don't know why this happened?

  • BDAqua Level 10 Level 10

    What version of OSX are you running?

  • Aidan Quigley Level 1 Level 1

    OS X 10.9.4 (13E28)

  • BDAqua Level 10 Level 10

    Ah, thanks.

     

    I don't think that works in earlier versions of OSX though, especially 10.5.x