Previous 1 2 3 Next 34 Replies Latest reply: May 23, 2014 1:57 AM by amiv Go to original post
  • DWL-SDCA Level 1 Level 1 (0 points)

    when i try to enter my nickname the submit button goes grey. I don't remember ever entering a nicknane for my iTunes or app store account. If i did it is the same nickname I use almost everywhere. I can not find a place to check my app store nickname or to add a nickname if i don't have one.


    Any suggestions.

  • MamaLydia Level 1 Level 1 (0 points)

    When you type in the nickname, have you also typed in the title? As I understand it, you don't need a nickname or title to enter just a star rating, but if you enter a title, you have to enter a nickname and if you enter a nickname you have to enter a title, and if have to have both to enter comments.


    As far as it being the same nickname, the apple id is the same between Itunes and app store, so I'd assume the nickname is too (though you might be able to change it at whim, I don't know yet).

  • BTFoxxx Level 1 Level 1 (0 points)

    I am unable to post a review from my iPad2. The submit remains greyed out until a title is entered. Having worked that out I clicked submit and a pop up appears saying I have to have purchased or downloaded the app to write a review. Well I have purchased it so why can't I write a review! I tried another app that was free and when I submit the review the review disappears and nothing happens. Any ideas why I can't write a review?

  • Pagemakers2 Level 1 Level 1 (25 points)

    Same issue here on my iPad 2.  When i click to submit a review the page just refreshes.  Howwver if I change the option from Current Version to All Versions, the review window opens but just says loading....That may be due to the load on Apple's servers right now though.

  • marc289 Level 1 Level 1 (0 points)

    I am having the exact same issue on my iphone 4! App says "installed" yet I get the message "in order to write a customer review for this item you must have purchased or downloaded it first".  What's going on??  I purchased the app months ago.

  • downeaster59 Level 1 Level 1 (0 points)

    I bought an iPad 2 last week, and love it.  But I'm having the same issue.  I have tried to review two apps I have already purchased and downloaded.  But when I try, I get the message that I must own an app to review it.  Anyone???

  • liquidous Level 1 Level 1 (0 points)

    I have ipad 2, latest updates, version iOS 5.0.1


    I tried writing a review for a Free app, and the app store said i can not review without purchase, but this is a FREE app.  so i tried using Itunes on the Macbook Pro, tried to write a review, and still can not.


    no reviews on ipad, or macbook. 


    What kind of scam is this?


    Please fix this apple.

  • CheesedOffWithIT Level 1 Level 1 (0 points)

    Me too.  Iphone4 ios5 cannot add reviews implies I don't own app which isn't correct.  Been like this for about three weeks looks like this issue has been ongoing for months.

  • WelshWizz Level 1 Level 1 (0 points)

    I've been using the iPad 2 almost exclusively with App purchases but every App I purchase, it usually warns me first that some Apps were unable to be purchased and then proceeds to complete the transaction okay. Sadly, when I try to write the developer a review, like others had experienced, it says I don't own the App ( which I clearly do and have purchase invoice to prove it).


    I tried all the tricks like synching my iPad to my computer, logging out etc. but to no avail. Clearly this is an Apple internal accounts synch problem and I agree with the others that it just seems a matter of sitting back and waiting for Apple to pull their socks up and do something about this.


    I think it's a shame for the developers as I would quite like to leave some positive reviews but can't .

  • iMac39 Level 1 Level 1 (0 points)

    I was having the same problem for some time now.   It turns out that the reason was because I have multiple Apple IDs, and of course the one I bought the app with is not the same one I was trying to leave an app comment with. 


    The solution is to sign out with the failing ID, and sign back in using the other ID.  Unfortunately, this is not intuitively easy. What you need to do is open the App Store app, and do a search, or select the Top 25 or any option that gives you a list.  Then scroll to the bottom of the list, and you should see the apple ID you are signed in with.  Tap this ID, and select "sign out".  It will then change the button label to "sign in".  Tap "sign in" and sign in with your other ID.

  • mwatsonmusic Level 1 Level 1 (0 points)

    I am having the same problem on my iPod Touch.  I only have one Apple ID, and every time I try to post a review, I get the message "you must own this item to write a Customer Review."  This is with Apps that shows it is downloaded when I view it on the App Store.  I tried this with several of my favorite Apps and get this message every time.  I am surprised no one has found a solution around this, or that Apple has not fixed this bug yet.

  • haroldfromsaltsjöbaden Level 1 Level 1 (0 points)

    Same here.  Apple doesn't want to know what you think of their bad apps, and they want you to waste your time typing the review in and then they won't even accept it.  Even better, they say thank you for rating the app, and then they don't show the rating.  They say they have accepted the review, but it doesn't show up.


    The whole point of Apple's closed architecture is to avoid having things like this happen.  If I can't review apps on an iPad, exactly who is able to do it?

  • Angel101192 Level 1 Level 1 (0 points)

    I am currently having an issue review applications on my iPad, I get through typing the whole thing and hit submit and it goes away. I refresh the page and nothing shows up, as a matter of fact I can hit the 'Write a Review' button and it brings up my review... as if it didn't post at all. I'm trying to write this on the Simpsons Tapped Out application because I have lost sound on my iPad and can't get it back (but my iPod works just fine) and I don't enjoy the fact that I cant get the houses to face to the right or rotate 360 degrees. Apple can you help me fix my ability to write a review on my iPad for an application?

  • I'llhaveanother Level 1 Level 1 (0 points)

    Same as everyone else here. Simply wanted to review an outstanding app I found and couldn't do it.

  • roborobo Level 1 Level 1 (5 points)

    Actually this IS the point of the whole apple lpad walled garden concept...think again.