Previous 1 2 Next 21 Replies Latest reply: May 25, 2014 6:54 AM by Julian88888888 Go to original post
  • BCPfan Level 1 Level 1 (0 points)


    I know this issue and thread are a few months old, but I too was sick of the "search google" function/short cut searching with Safari instead of Chrome.  I searched google for a fix and this thread came up.  Bozo's solution worked perfectly.  I thought the fix seemed too easy, but it worked great.  Thx!

  • CodyHoll Level 1 Level 1 (0 points)

    I know this is old but I think I may have just solved it under the Safari>preferences>RSS tab and change default to Chrome.

  • WyoLarsens Level 1 Level 1 (0 points)

    Not a solution but (for me) an answer: I was having the same issue of right-clicking some text *in Chrome* and doing a Google search but it would launch Safari to do the search. It seems there's a contextual menu item that Chrome includes, "Search Google for 'whatever'" and there's also a contextual menu item that's included by the OS, "Search with Google." I never noticed the second one and have always just used the first, but the second one launches Safari... I must've hit it without looking. 3 times. Today. And wasted an hour trying to figure out why Safari's launching.


    I guess I still don't know why Safari's launching when it knows Chrome is the browser I want to use, but oh, well.

  • BerndNW Level 1 Level 1 (0 points)

    Great, it worked! Thanks silby102

  • CREAMASTER Level 1 Level 1 (75 points)

    This is amazing. It's 2013, almost 2014 as I write this and I see here it's been a bug since 2011… I thought - but no! This has been an issue since 2002! So I guess this is a feature not a bug?


    Search with Google still opens the wrong browser - even after 10 years of being a bug.

  • mmmond Level 1 Level 1 (0 points)


  • Julian88888888 Level 1 Level 1 (0 points)

    bozo_z_clown wrote:


    Resetting the default browser to Chrome in Safari (even though that is what it showed it was already set to) fixed the issue for me (the Pandora app was opening links in an old copy of Firefox).


    1. Open Safari
    2. Open "Preferences..."
    3. On the "General" tab set the "Default Web Browser" to "Safari"
    4. Close Safari
    5. Open Safari
    6. Open "Preferences..."
    7. On the "General" tab set the "Default Web Browser" to "Chrome" (or your choice)
    8. Close Safari
    9. Try your link again

    Worked for me, thank you.

Previous 1 2 Next