1 2 Previous Next 21 Replies Latest reply: May 25, 2014 6:54 AM by Julian88888888
jaileer Level 1 Level 1 (0 points)
I have my default browser set as Chrome. When I click links in mail, or right click and select "search with google," they open in Safari.

I went to Safari to ensure that Chrome was selected as the default browser and it is. Any other ideas?

Thanks!

MacBook Pro, Mac OS X (10.6.6)
  • 1. Re: links open in wrong browser
    Matthew Morgan Level 7 Level 7 (22,555 points)
    In Safari>Preferences>General do you have Chrome selected as the default browser.

    Matt
  • 2. Re: links open in wrong browser
    jaileer Level 1 Level 1 (0 points)
    Hi Matt ~

    Thanks for the reply! Yes, I do have Chrome selected as the default browser in that location.
  • 3. Re: links open in wrong browser
    Matthew Morgan Level 7 Level 7 (22,555 points)
    What happens if you switch it back to Safari quit then open a link.

    Change back to Chrome quit and try the link again.

    Matt
  • 4. Re: links open in wrong browser
    jaileer Level 1 Level 1 (0 points)
    Hmmm, This solved the links issue, but still if I right click on something and select "search in Google" it opens safari.

    Thanks for fixing the main issue, though! (i know better, i should have done that first...)
  • 5. Re: links open in wrong browser
    Matthew Morgan Level 7 Level 7 (22,555 points)
    Thanks for fixing the main issue, though! (i know better, i should have done that first...)


    You're welcome. I'm glad I could help.

    It seems that the prefererance you set in Safari can be overridden if you dismiss that dialogue warning when you first open something in Chrome.

    I'm not sure if there is any way around the Google thing.

    Matt
  • 6. Re: links open in wrong browser
    jaileer Level 1 Level 1 (0 points)
    Well, the links thing was the big issue, the google thing is a mere annoyance. Thanks again!
  • 7. Re: links open in wrong browser
    mjuarez Level 1 Level 1 (0 points)
    jaileer wrote:
    I have my default browser set as Chrome. When I click links in mail, or right click and select "search with google," they open in Safari.

    Thanks!


    I'm running into this same issue. Seems like Mac Mail's "Search with Google" option is somehow hard-wired to Safari. Any ideas on how to fix this?
  • 8. Re: links open in wrong browser
    Neal Bridgens Level 1 Level 1 (15 points)
    I'm having this problem too. And it transferred to my new laptop with migration assistant somehow.
    Not a problem on my promac, it opens with chrome just fine.
  • 9. Re: links open in wrong browser
    notetoself.net Level 1 Level 1 (0 points)
    I found this and several similar threads while looking for an answer to my issue. When selecting text and clicking "Search in Google" within Preview, Safari opens even though Chrome is my default browser.

    From the other threads, I see that several other Apple applications override the user's browser preference and force them to use Safari. This seems familiar. Didn't Microsoft get into trouble a few years back when they manipulated the OS to prefer Internet Explorer over other browsers?
  • 10. Re: links open in wrong browser
    Krag Level 2 Level 2 (215 points)
    It may be they coded Mail to use Safari rather than the Default Browser. My Safari issues stopped when I switched to "open in 32 bit mode".
  • 11. Re: links open in wrong browser
    andyBall_uk Level 7 Level 7 (20,320 points)
    The 'search with google' option is a 'service' offered by the Safari application, like 'look up in dictionary' or 'new textedit window'...

    I suppose that it should be named differently, since plenty of people expect it to use the default browser.

    see the macworld hint at http://hintsforums.macworld.com/showthread.php?t=111762 post #9
  • 12. Re: links open in wrong browser
    silby102 Level 1 Level 1 (10 points)

    Similar problem I've found but fixed. I have a broken arm and it's difficult to hold down cmd and click or do the shortcut (which doesn't work anymore), so I found a workaround based on http://rentzsch.tumblr.com/post/5794765921/search-with-google-using-chrome

     

    It will take less than a minute to implement.

     

    Open Automater -> Choose Service -> Find 'Run Shell Script' action and drag to workflow window -> Choose '/usr/bin/ruby' from Shell drop down menu -> type the following

    require 'cgi'

    `open 'http://www.google.com/search?q=#{CGI.escape(STDIN.read.chomp)}'`

     

    Then save it with a title like "Search With Google (New Window)" and you are done. Then rather than using the shortcut, just right click the highlighted text you want to search and you can use this new service. It should work with whatever you have your default browser to be set to in Safari preferences. Just make sure you choose the new service and not the original.

  • 13. Re: links open in wrong browser
    Ferro Level 2 Level 2 (455 points)

    Hi Silby102 when I open Automator (2.1.1) I don't see Service but Services  than what about run Shell Script, sorry but never tried such things before so I want to make sure I am not messing up soemthing.

     

    Thanks

  • 14. Re: links open in wrong browser
    bozo_z_clown Level 1 Level 1 (0 points)

    Resetting the default browser to Chrome in Safari (even though that is what it showed it was already set to) fixed the issue for me (the Pandora app was opening links in an old copy of Firefox).

     

    1. Open Safari
    2. Open "Preferences..."
    3. On the "General" tab set the "Default Web Browser" to "Safari"
    4. Close Safari
    5. Open Safari
    6. Open "Preferences..."
    7. On the "General" tab set the "Default Web Browser" to "Chrome" (or your choice)
    8. Close Safari
    9. Try your link again
1 2 Previous Next