13 Replies Latest reply: Apr 8, 2013 5:41 PM by robert scottfromaurora
IH8UM Level 1 (35 points)
Anyone know if you can put Hitachi 3TB drives in an Xserve? I even tried using external firewire and I can't get it to read more than 801.57 GB. I have read people are putting them in Macs, but I can't figure out how to format it to 3TB.


Xserve, Mac OS X (10.6.5)
  • ClassicII Level 3 (835 points)
    Richard, xserves are very specific on which drives it likes. They like to work on apple ADM's only. People have been able to get other drives working though with out a problem. I have not heard from any one who has gotten a drive over 2tb to work yet though.
  • jmyres Level 1 (80 points)
    The 3TB Hitachi drives we have been working with default to 6Gb SATAIII. If you find the drive doesn't present at 3TB or not at all, use the Hitachi Feature Tool to back it down to 3Gb SATAII, and there is a good chance that will correct your problem.

    We have yet to try 3TB drives in an Xserve, but have had to do this to get the drives to present correctly in 3Gb enclosures.


  • Ed Adams2 Level 2 (475 points)

    I have managed to get the 3TB drive to work in a Mac Pro, the latest model.

    I only have access to an 1st gen Intel Xserve, drive shows up as 2TB there, winding the speed to 3GB did not help.

    Will test on the last version of Xserve soon

  • NitricjerkSud Level 1 (5 points)
    I've managed to get a Western Digital 3TB drive working as an internal drive on my Mac Pro (2006) system. It did NOT work with an external case, as others have described, since it only appears to see 800-and-something GB available. Once installed as an internal drive, it was properly recognized, and I was able to format it as a full 3TB volume.

    I tried moving the drive from my Mac Pro to a 2006 Intel Xserve, and the drive was NOT recognized at all. (Strange, given that both machines were manufactured around the same time.)

    I'm working to resolve the issue, and will provide an update as I get more information.
  • ClassicII Level 3 (835 points)
    Good info.

    The xserve has two different drive sleds. Can you tell me what the serial ata cable looks like? Is it a ribbon or a wire type? I think ribbon one works with the SAS drives but will also accept all kinds of sata drives compared to the black wire sleds.
  • NitricjerkSud Level 1 (5 points)
    I'm not exactly sure what you're talking about -- but here's what a SATA cable looks like.

    http://www.google.com/images?oe=utf-8&rls=org.mozilla:en-US:official&client=fire fox-a&q=sata+cable

    I'm unfortunately under a bit of a deadline, so I'll likely be scavenging a 2TB drive from a local RAID array, re-copying the data onto it, and trying that out in the datacenter. It doesn't look like there's a straightforward answer though.
  • xb37835dd237610f1 Level 1 (0 points)

    Do you know if this limitation on which drives the XServe supports has to do with software or hardware limitations? Initially I am interested in putting 3TB drives into the newest XServe and will be running another UNIX operating system which wouldn't have the software limitation of 2TB or less. I have three drive bays and would like to swap the custom drives in place with the factory shipped drives. I haven't purchased an external controller card so my question refers to the native SATA controller that is part of the latest XServe that was offered. I'm hoping that the hardware does not limit the accessible space.

    I'm also wondering if the choice of drive matters. Another post suggests that a Hitachi drive might need to be placed into a particular mode before it may work--and even then that wasn't on an XServe.
  • NitricjerkSud Level 1 (5 points)
    All I can say for sure is that the 3TB Western Digital Green Drive DOES NOT work in the 2006 version of the XServe. When I used a jumper on pins 5 & 6 to slow the drive to 1.5Gbps, the Xserve was able to detect and format the drive, but ONLY to a maximum of 2TB -- and the existing partition (and the data within it) was not recognized. My time at the datacenter was limited, so I didn't try to create a 2TB partition and a further 1TB partition, which would have been an acceptable compromise.

    I opted instead to replace the 3TB drive with a spare 1TB WD Green drive I had, and it worked without issue.

    I may replace that 1TB drive with a 2TB drive in the future.

    If anyone else has any insight into this issue, please let us know.
  • tecsol Level 1 (0 points)

    For the record:

    I just installed x2 Seagate XT 3TB HDDs in a 2006 Xserve, mirrored Apple software RAID, OS X 10.6.8.


    No matter what I tried, only 2TB is available to use on a 3TB drive in these Xserves. No, you cannot create a 2TB and 1TB partition. 2TB max. Works great with a 80GB SSD Boot drive in drive 1 though



  • NitricjerkSud Level 1 (5 points)

    Thanks for the update.  I guess we're running into a 48-bit limit on drive sizes (around 2.2TB), which is likely hardware related.  Does anyone know if a dedicated RAID Card would resolve this issue?


    I fear that with the impending end of the XServe line (I say impending because there are still some for sale on Apple.com) that this is an issue that may not be resolved anytime soon.


    It might be time to put my old Mac Pro into the datacenter.

  • beatle20359 Level 2 (290 points)

    I don't know that the RAID card will make any difference but i'll certainly give it a go in the next few weeks.


    I've had a bit of success with the Caviar Black 500gb and Hitatchi 500/1TB drives recently in the 2006/2008 xserve with and without RAID card. If anyone wants the model numbers mail me and i'll send them to you. Without any support from Apple I wouldn't recommend doing this on a production machine.


    It would be great if Apple were to release an update to allow greater drive support in the Xserve and allow us to do so at our own risk.


    Once i've received the 3tb drive i'll let you know how it goes with the RAID Card.


    All the best

  • danceswithxserves Level 1 (0 points)
  • robert scottfromaurora Level 1 (0 points)

    Does anyone know the part number of the drive sled with the ribboon?