4 Replies Latest reply: Feb 9, 2011 6:55 PM by JackyYeh
JackyYeh Level 1 (0 points)
I have a MAC OS NB. When I link its ethernet to the LAN of my router modem, it will send MDNS to cause my another NB on the same LAN of the router modem not to access internet because another NB can't get its DNS response packets. My question is why MAC OS NB doesn't send pure DNS packets and send MDNS. Because it causes my NB can't access internet, I need to know how to disable MDNS. This is my mail address, **@**.com. You can also send the solution to me. Thanks in advanced.

Message was edited by: JackyYeh

<Edited by Host>

MAC NB, Mac OS X (10.6), MAC NB
  • J D McIninch Level 5 (4,060 points)
    mDNS doesn't affect regular DNS, so that's not the problem.

    OS X does send DNS requests and replies like any other OS. For that matter, most modern OS's also have mDNS services. Bonjour (Apple's implementation) is available for OS X and Windows, and there's Avahi for Linux and NetBSD systems. Windows CE has a similar function.

    When a machine in a network needs to resolve a host name, it sends a DNS request to the list of DNS servers manually configured or provided by DHCP from the local network's DHCP service. If a machine wants to perform local service discovery on the LAN, it instead sends out a multicast DNS request and a system on the LAN replies. Fundamentally, the requests are handled differently and don't interfere with one another. mDNS doesn't respond to regular DNS requests (which your switch or router shouldn't even make visible to the other systems on the LAN), and systems with mDNS do not use it to replace standard DNS requests.

    On Windows systems, you can disable mDNS by disabling the Bonjour (if present) and ZeroConf services in the services administration panel. In Linux, you disable it by logging in as root and typing

    $ service avahi-daemon stop
    $ service avahi-dnsconfd stop

    In OS X, you can disable it by opening terminal and typing the following:

    launchctl unload /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
    launchctl unload /System/Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist

    ... this is unlikely to resolve your problem as mDNS is not likely the cause. Disabling mDNS will disable service discovery on your local network, so file shares, printer shares, photo and music sharing, screen sharing, etc. can all be affected.
  • k.panic Level 3 (605 points)
    What's more likely is that your router is not running NAT or DHCP is not working as it should be.
  • J D McIninch Level 5 (4,060 points)
    Most likely DHCP is not working properly. For some routers, they proxy DNS requests through the router, so when you receive your DHCP lease from the router, it gives you the router's IP as your DNS server and all DNS requests go to it. However, if the router's DNS proxy has a problem, then DNS breaks.

    A good solution is to configure your computers to use a known external DNS provider like opendns.org in addition to whatever DHCP assigned. This will usually fix any DNS issues that arise from your router or gateway.
  • JackyYeh Level 1 (0 points)
    Thank you for your answer. I already solve now.

    Jacky Yeh