Previous 1 2 Next 15 Replies Latest reply: Feb 22, 2013 10:48 PM by nowsthetime
Milesat Level 1 Level 1

I was wondering if someone could help me out. I have recently reinstalled my Leopard software in an attempt to speed my Mac up. All went well and I backed up with time machine, however, now when tryin to open any iWork applications they quit at initial launch. All other applications seem to be fine it is just all three iWork applications. I have tried everything from restoring previous versions through time machine to reinstalling with disk and nothing helps!! I am desperate as now anything I have done in iWork is useless.

Any ideas on what to do?

iMac, Mac OS X (10.5.8)
Solved by power mac on Feb 10, 2011 6:48 AM Solved
SORRY ABUT MY LAST POST , This should be move all the .plist files from Your User Library and Move a iWork Folder Located in Statup disk --> Library ---> Application supportThen simply move iWork folder from Applications Then try to reinstall it backLH
  • power mac Level 2 Level 2
    Try this ,

    01. Just open Pages app. just app. not pages document. and see if the pages application is stable ?

    *. Try to Download Latest iWok Update from Apple software update or apple's web site and install it .

  • Milesat Level 1 Level 1
    Have tried this and downloaded software update and nothing works. Seems to affect all iWork apps when trying to open them from iether the dock or the applications folder in finder, all quit immediately asking to relaunch which doesnt work. I have also tried draggin file tonopen in applications folder onto app as suggested in another discussion but this also does not work.
  • BGreg Level 6 Level 6
    Welcome to the Apple discussions.

    Are you using an older version of iWorks, like iWorks '05, for example? I don't know that an older version would have a 10.5 compatibility problem, however, perhaps that's a possibility.

    Have you tried downloading the free iWorks '09 trial from to see if that works or if you still have that issue?
  • Milesat Level 1 Level 1
    I am using iWork 09 and was having no problems with it until I did the reinstallation of leopard. All other applications work without a problem including third party applications like Office, it is only iWork that is unresponsive.
  • BGreg Level 6 Level 6
    Have you reinstalled iwork after the Leopard upgrade? Have you used Disk Utility to repair permissions?
  • power mac Level 2 Level 2
    01 Quit your iWork Apps

    02. Go to Your user / Library / Preference

    03. Locate following file names. move those files in to different location such as desktop (don't delete it) ()

    # - sign will have some code any way its not important

    04. restart Pages or Keynote or Numbers see if its solve the problem

    if yes, now you can delete those files you moved to desktop
  • Milesat Level 1 Level 1
    tried this but still no help. am not even able to open the apps in the first place, they quit immediately saying "The application Pages quit unexpectedly. Mac OS X an other applications are not affected. Click Relaunch to launch the application again. Click Report to see more details or send a report to Apple." then i try again and the same message comes up. When sending the report the following message comes up

    Process: Pages [884]
    Path: /Applications/iWork '09/
    Version: ??? (???)
    Build Info: Pages-8520000~2
    Code Type: X86 (Native)
    Parent Process: launchd [126]

    Interval Since Last Report: 26283 sec
    Crashes Since Last Report: 13
    Per-App Interval Since Last Report: 0 sec
    Per-App Crashes Since Last Report: 12

    Date/Time: 2011-02-09 17:42:16.828 +0000
    OS Version: Mac OS X 10.5.8 (9L31a)
    Report Version: 6
    Anonymous UUID: A7C0C998-A44A-4B46-AFBF-9476F406246A

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: @rpath/Inventor.framework/Versions/C/Inventor
    Referenced from: /Applications/iWork '09/
    Reason: image not found
  • Milesat Level 1 Level 1
    i have tried to reinstall iwork, both from disk as well as from time machine restore but to no avail. have also performed a disk permission repair with no effect.
  • Milesat Level 1 Level 1
    Can anyone help out with this issue. I am afraid I am going to have to call Apple support and pay for advice unless someone out there can help me out. Been trying to sort this out for the last three days and can't do any work so am desperate!!
  • power mac Level 2 Level 2
    Hi Try this

    Move following list of files to different location (you did this before but check again and move it )

    02. Go to Startup disk --> Library ----> application Support ---> i Work 09

    03. Move that Folder Away

    04. remove iWork 09 apps folder from Applications

    05. try to reinstall iWork 09 again

  • power mac Level 2 Level 2

    This should be
    move all the .plist files from Your User Library and Move a iWork Folder Located in Statup disk --> Library ---> Application support

    Then simply move iWork folder from Applications

    Then try to reinstall it back

  • Milesat Level 1 Level 1
    This did it! Thanks for all the help!!
  • power mac Level 2 Level 2
  • valcabigao Level 1 Level 1

    thanks a lot powermac, i had the same problem (iworks quit unexpectedly) and been trying to figure out for answers for days, then i search the net and thank God he led me to this discussion, i just simply follow the instructions you posted and now, im enjoying my iworks. thanks again.

Previous 1 2 Next