6 Replies Latest reply: Jan 12, 2015 6:56 AM by jsthoreson
myzhou Level 1 Level 1 (0 points)
My iphone 3gs won't turn off for a long time. It seems that the on/off button does not work. Also when I press both the home button and on/off button for 10 secs to reset the iphone, it goes into voice control but not reset. These days the only thing I can do is to recharge it when the battery is almost off to keep it work. All the other functions seem ok but the on/off button. Anyone has faced this problem or can tell me how to solve this problem?

HP, Windows XP Pro
  • JimHdk Level 7 Level 7 (28,240 points)
    If your phone is in a case then remove it from the case and try the On/Off button. If not then:

    What level iOS are you using? Have you tried to restore/update the OS software?
  • myzhou Level 1 Level 1 (0 points)
    My iOS is 4.2.1, the latest, I have tried the restore/update the OS software, but the problem is still the same.
  • EFrench Level 1 Level 1 (0 points)
    Did you guys ever get a response to this? My 3GS just turned off this morning and won't turn back on. I took it to the ATT store and of course they didn't know. I have an appt with the apple store tonight but it's out of warranty so i'm not sure what they'll do for me. If I get anything helpful I'll let you know.
  • natalgoo Level 1 Level 1 (0 points)

    Ever since I updated to iOS5 I have had the same problems.  "Power" button does nothing or locks the screen.  Holding power button and home button at the same time just gives me voice control.  Warranty is unlimited on manufacturing faults in Australia so I can't see how this wouldn't be covered.

  • jsthoreson Level 1 Level 1 (0 points)

    Same problem occurred after trying to erase all the data and settings on the phone. 

     

    I held down the power and home buttons and that forced it off momentarily.  Then I plugged the phone back in to my computer while holding down the home button.  iTunes recognized it was in recovery mode, but when I go to restore it says the device isn't eligible for the requested build.  Then the phone goes back to the boot screen.

     

    Before this problem occurred, the update to the iTunes was ready to install to iOS6.  I was on 4.2.1, I think.  The phone was jailbroken.

     

    The ultimate goal is to unlock the phone.  My request with ATT was accepted, but everything hit a snag when I pressed "Restore".  Not the end of the world.  This is an older phone and was going to be a backup.  Might be out of luck. 

  • jsthoreson Level 1 Level 1 (0 points)

    Update:  I let the phone run it's battery out overnight, then held down the home button, and plugged it into a another computer I have running iTunes 12.0.1.26 (the latest that my MacBook Pro will on OS 10.8.5) on a whim.  The day before, I was trying to restore the phone on iTunes 10.6.1 (the idea being that this version of iTunes was the last one I used with this phone before retiring it to backup duty).  iTunes 12.0.1.26 recognized the phone was in recovery mode, asked if I wanted to restore, clicked "yes", and it updated to iOS 6.1.6 and everything is working now. 

     

    So, if your phone is still stuck, try the latest version of iTunes that you can get your hands on and plug in your phone holding down the home button.  Then, good luck