Skip navigation

Seagate FreeAgent GoFlex Desk frustration

81635 Views 184 Replies Latest reply: Dec 7, 2013 7:28 PM by hwmd RSS
1 2 3 ... 13 Previous Next
Bill Fant1 Calculating status...
Currently Being Moderated
Feb 9, 2011 8:54 AM
Hi all,

I recently purchased a 2TB Seagate FreeAgent GoFlex Desk external hard drive. Unfortunately, there seems to be a conflict with either my hardware or software. The drive seems to go to sleep after a period on non-use and consequently crashes the Finder and various apps when trying to gain access. I can see the icon for the drive... even navigate down some recently used directories, but then I'll go too far, get the beach ball and have to force restart the entire machine. The same will happen if I'm using an app trying to access files on the drive. I can force quit the app and/or Finder, but they will not be available for use until I force quit the entire machine. I've been trying to solve this problem for a couple weeks now without success, so I thought I'd turn to the Mac community here.

* The drive has been reformatted Mac OS Extended (Journaled).
* I have used Seagate Diagnostics and the drive passes all tests.
* I have disabled drive sleep under Energy Saver.
* I have tested the drive on a MacBook running the same OS as my iMac (10.6.6) without a problem.
* I have disabled Time Machine backup to a TimeCapsule to see if that helps. Does not.
* I have disconnected other drives to see if that helps. Does not.
* I have disabled virus scans, media servers and other apps (that I know of) that sometime run in BG.
* I have tried different USB ports and different wall plugs.

I'm beginning to think there is some sort of compatibility issue with my hardware, but it could still be some sort of software that is conflicting. I simply cannot find the pattern.

I spoke with Seagate support and we got as far as the recommendation to test on another machine. The drive seemed to work fine there, so I'll have to continue troubleshooting with them from that point, but I thought someone here might have some ideas as well.
27" iMac - 3.06 GHz Intel Core 2 Duo, Mac OS X (10.6.6), 4GB Ram / ATI Radeon HD 4850
  • babowa Level 7 Level 7 (22,095 points)
    Currently Being Moderated
    Feb 9, 2011 9:30 AM (in response to Bill Fant1)
    Looks as though you've already done some extensive troubleshooting; my first reaction after seeing this:

    +I have tried different USB ports and different wall plugs.+

    was that this may be the cause? I would not recommend any external for daily medium to heavy duty use - I'd only use Firewire (at least FW 400, if possible FW 800).

    Also, have you tried a different USB cable?

    And, FWIW, this caused an alarm to go off:

    +I have disabled virus scans, media servers and other apps (that I know of) that sometime run in BG.+

    What kind of antivirus software do you have installed? Unless you are running Windows, you do not need it and most of it causes more harm than good; you might want to read this:

    http://www.reedcorner.net/guides/macvirus/
    27" 3.2 GHz iMac i3, 12 GB RAM, 13" white early '09 MB,, Mac OS X (10.6.6), LaCie d2 DVDRW, 2 LaCie d2 Quadra ext HD , Wacom tablet, Epson Artisan 810
  • babowa Level 7 Level 7 (22,095 points)
    Currently Being Moderated
    Feb 9, 2011 11:46 AM (in response to Bill Fant1)
    I just took the time to look at the specifications of your drive - if I found the correct model, it does not appear to include its' own power supply? At least it is not mentioned in the "what's in the box" stats. If that is the case, I'd suspect that to be your main problem - so please post back if yours has a power supply or not.
    27" 3.2 GHz iMac i3, 12 GB RAM, 13" white early '09 MB,, Mac OS X (10.6.6), LaCie d2 DVDRW, 2 LaCie d2 Quadra ext HD , Wacom tablet, Epson Artisan 810
  • babowa Level 7 Level 7 (22,095 points)
    Currently Being Moderated
    Feb 9, 2011 1:39 PM (in response to Bill Fant1)
    So I did at least find the right model; odd it doesn't say it includes a power supply...

    In any case, it's really difficult to help since you're already done all the troubleshooting most people would come up with.

    +Seagate tech support recommended I try reformatting for Windows... disable any HD sleep via their diagnostic software... reformat for Mac and... try again. That's quite a process and I kinda doubt it would work. It seems like reformatting the drive for Mac would disable such features.+

    I'd agree with you on that one - but, maybe Seagate knows something we don't.

    +I'm gonna try disabling MobileMe synching to see if that helps+

    You might have a point there - I've seen some posts where syncing seemed to have caused a few "side effects".

    Have you tried resetting the PRAM and SMC (although I don't necessarily think that'll help, but it won't hurt):

    http://support.apple.com/kb/HT1379

    http://support.apple.com/kb/HT3964

    And, sometimes a simple restart will fix minor issues.
    27" 3.2 GHz iMac i3, 12 GB RAM, 13" white early '09 MB,, Mac OS X (10.6.6), LaCie d2 DVDRW, 2 LaCie d2 Quadra ext HD , Wacom tablet, Epson Artisan 810
  • jgsullivan2 Calculating status...
    Currently Being Moderated
    Mar 21, 2011 1:44 AM (in response to Bill Fant1)
    I am experiencing the exact same problem. You said it worked fine when you connected it to your Mac Book...Well that is the machine I am having trouble with while connected to the external drive. Has this issue been resolved?
    MacBook Pro, Mac OS X (10.6.6), n/a
  • Jubilee Video Calculating status...
    Currently Being Moderated
    Mar 21, 2011 11:49 AM (in response to Bill Fant1)
    Hi, I'm new to this forum like you, and also have purchased the same unit as you.
    I do use my iMac for editing and found that this HD as sold out of the box is only sold as a back up. You have to use the special adapter to gain the advertised 10X speed they are stating.

    I have had this unit shut down and not power up again.
    There is no power button and so you have to disconnect power source each time this happens.
    I am ready to take it back since the unit freezes up, most likely because it is under rated for the job I need.

    I also have had lock ups with the computer, unplug the unit and the computer unlocks. Strange, but very frustrating experience.

    If you are going to do any serious editing the unit is not up to speed. Even the RPM's are low, around 5400 or 5800, they don't advertise that fact either.
    Your better drives are 7200rpm.
    iMac7, 27", 4GB Ram,ATI 5750 graphic,2.92Gh Quad Core i7, 10.6.5
  • vinniefromflatbush Calculating status...
    Currently Being Moderated
    Aug 1, 2011 11:06 PM (in response to Jubilee Video)

    After visiting the Seagate support forums and finding out hoe folks dealt with this issue, I purchased a Seagate Firewire 800/USB 2.0 Desktop Adapter to replace the usb 3.0 version that comes with the drive.  It cost me about an extra $27 bucks but the drive stays mounted and the finder doesn't freeze.  Moral of thre story - that drive is NOT mac compatible in the USB 3.0 version despite everything Seagate claims

  • Smudge Level 1 Level 1 (115 points)

    I have the 3TB version and the Firewire 800 adapter but have the same issues.  I've disabled "Put the hard disks to sleep when possible" option in Energy Saver but it still sleeps.  The only difference of my config is that it is daisy-chained from another external drive, also using the FW800 connection.  That drive does not sleep but the Seagate drive still sleeps when idle.

     

    By chance has anyone come across a new fix or suggestion?

  • danco34 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2011 8:42 AM (in response to Smudge)

    I ran into this problem on a different Seagate drive, and found a solution (and also, I think, the cause of the problem).

     

    Try a little program called "Keep Drive Spinning", available on MacUpdate. It's very simple and in fact is no more than a wrapper to a shell script and launch daemon that accesses the drive regularly. The only trouble with it is that it does keep the drive spinning, rather than letting the drive sleep and then wake up. For my use that was not an issue.

     

    The problem with Seagate is that their drive sets its own sleep time, and won't wake up once it has slept, and seems to freeze the Finder. I did find on the Seagate site a while ago a little program that claimed to solve this, but from looking at the elements of the package I was convinced that it did not work.

     

    I did not feel like experimenting, though, but someone else might be more adventurous. I used something called "Suspicious Package" which lets you look at the contents of a package installer by Quick Look. It seemed to me that what the Seagate program did was to temporarily install its own driver, use that to reset the sleep time, then remove that temporary driver. But I reckoned that the sleep time need to be set to 0 to ensure that Energy Saver controlled sleep but in fact was set to a non-zero figure.

  • Smudge Level 1 Level 1 (115 points)
    Currently Being Moderated
    Aug 9, 2011 12:25 PM (in response to danco34)

    Wow.  I hadn't even thought about a simple script to access the drive as I was concentrating on how to fix the problem instead of patching it.  I've just written my own instead but the Keep Drive Spinning utility is perfect for those that are not comfortable making their own scripts.  (One down side to the Keep Drive Spinning utility is that it installs as a user script and not a system script so it will only run when that user is logged in.)

     

    Obviously it would be best to fix/control the drive sleep instead of using this hack, but it will have to work until (haha!) Seagate fixes it.

     

    Thanks danco.

  • gogogut Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 18, 2011 7:36 PM (in response to Bill Fant1)

    I have been having precisely the same problem with the GoFlex Desk 2tb USB 3.0 on my MacBook. Almost every time I try to transfer files, the drive hangs and forces me to do a hard restart. I purchased the drive in August of 2011.

    I contacted support and they told me to run mac diagnostics, which it passed. The support person didn't understand why this is happening and recommended I return the drive while I can.

    I will try again tomorrow using a FireWire adapter, but I was hoping there was a real fix for this. What is the point of patching temporarily if there might be problems the next time I connect to a different computer? And having the drive constantly spin seems like harsh treatment for something the drive should do easily. I have 6 other external hard drives and none of them exhibit this type of behavior. They transfer files by drag and drop with no problems. Yet my Seagate is super problematic and I don't what to tip toe around it.

    I am willing to throw in the towel soon, but I really want a solution. At $90 for 2tb and $20 for a FireWire adapter, I hope I can turn to go flex for more drives in the future. Who knows, maybe some day I will buy a new mac and upgrade to a thunderbolt adapter. Otherwise, I am looking at non-upgradable USB 2.0 drives like the WD Elements.

    I hope someone can speak to this problem and provide some sunshine.

    Thanks,

    RJ

  • danco34 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 19, 2011 12:24 AM (in response to gogogut)

    The O.P. reported using Seagate Diagnostics unsuccessfully, but I wondered if anyone had used the

    GoFlex for Mac software.

     

    Below is Seagate's description. You can see that it specifically says that it includes drivers to disable the built-in sleep timer (which I think is the cause of the problem(. Somewhere in the Seagate discussion forums I think I saw that you don't have to set anything, just installing the relevant drivers is enough.

     

    As I mentioned previously, it is possible to look at the scripts in the installation package, but I found them too complicated to understand.

     

    I agree with gogogut that having the drive spin constantly is not a good solution for most people. I only used that drive for video programs and processing them, so I unmounted and turned the drive off except when I needed it to be active.

     

    File Version: 1.1.2
    File Name: Seagate GoFlex Software.mpkg.zip
    File Size: 5MB
    Supported Operating Systems: MacOS 10.5.11+, MacOS 10.6

     

    Summary

     

     

    Seagate Drive Settings application for MacOS is included on the GoFlex series of drives. Simply double click it to install the software. If the software was deleted, it can be downloaded using the link below.

    This software package includes Diagnostic software for testing the drive, drivers to disable the built-in sleep timer on the drive, and drivers to enable the capacity gauge for GoFlex Desk models. It has now been updated to support 64-bit and 32-bit version of MacOS.

     


  • gogogut Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 19, 2011 6:36 AM (in response to danco34)

    I just downloaded the GoFlex for Mac software and installed it on the drive. I will now try a fresh data transfer and see if anything has changed. I will report back soon.

    I had not downloaded this particular software before because it said on the website that it was specific to the GoFlex for Mac drives. Seeing as how I reformatted, I hope it is okay that I put it on my drive.

    Ha! Haven't even started yet and the drive is already hung, so this is not looking good.

    RJ

1 2 3 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.