2 Replies Latest reply: Feb 11, 2011 11:25 AM by ethan795
ethan795 Level 1 Level 1 (0 points)
A friend of mine gave me their iPod touch 2G, hoping I could fix it for them...but I'm having several problems.

Firstly, I also own an iPod Touch 2G which is fully functioning - I've messed around with it a lot and had to restore it several times. I'm not great with 'em but I got the basic knowledge.

The broken iPod isn't on, it's literally a paper weight I've tried everything but it just doesn't react to anything.

So there's two things wrong with this iPod - the power button is jammed. Yeah, it's a pain in the ***...I've tried poking it with a screwdriver to see if I can unjam it. What's the best plan of action in regards to this? I've considered opening it, I'm sure there's a good guide out there, but I was wondering if anyone knew specifically with jammed power buttons if this helps.

Of course this power button issue means I can't get into DFU mode (afaik) but then again this isn't the main problem...

The main problem is the fact that it isn't recognized by any computer. I don't mean it pops up saying "Windows can not recognize this USB device." I mean literally no reaction to a computer. I tried using Device Manager to see if Windows (XP) recognizes it at all, but it doesn't.

I've looked around for some advice on this but there's far too many people posting in a panic and getting flamed...any help's much appreciated.

Oh and it hasn't functioned for months now so it is on a very outdated iOS.

iPod Touch 2G, iPhone OS 2.x
  • lllaass Level 10 Level 10 (165,005 points)
    Here is where you can get instructions for disassembling the iPod. I would try to get the switch "fixed" before going further since the stuck switch may be preventing recognition.
    http://www.ifixit.com/
  • ethan795 Level 1 Level 1 (0 points)
    Thanks for the speedy response, I'm looking on that website now at a guide for replacing the power button.

    I'm trying to avoid replacing anything if the iPod is totally frazzled (I'd have to purchase the required tools and ship them to the UK), so do you know of any cases where a stuck power button actually prevents it from being recognized by a computer?

    Also, is there any way of checking if it has any charge to the battery without it being on?

    Message was edited by: ethan795