8 Replies Latest reply: Feb 12, 2011 4:42 PM by crochammer
crochammer Level 1 Level 1 (0 points)
I have been trying all week to connect to AppleTV trying all forms of networked connections. I also tried connecting cat6 ethernet direct to the ATV and 2 computers I have. Both computers have Gigabit ethernet ports so I expected that a connection would be plug and play. 1 PC has 2 Yukon Marvell gigabit ports, both lit up when connected but the Apple TV will not show up in devices in itunes off either port. I returned the ATV to factory defaults and connected to the newly re-formatted PC with clean install of XPPro and iTunes 9.0.2. No go on the Intel Pro1000 gigabit adapter port either.

The ATV connects fine to the internet so I know the ATV ethernet port is OK.
A few say I need a crossover cable but both PCs are new and haved adapters rated to handle the connection without it.

Everyone I talk to says it should be just plug and play but that is just not happening. Is there something I need to do at the PC or ATV end to have this connection work?

Windows XP Pro
  • vazandrew Level 6 Level 6 (15,360 points)
    ATV2 won't show up in devices. You simply turn on home-sharing in iTunes and on ATV (make sure they are both using the same apple id and on same network).

    Computer must be on and running iTunes (version 10.1 or later) and then you can stream your library. You can also use an ios device (iPhone, ipod touch, iPad) to airplay content directly. This all uses the local network.

    Other features (such as iTunes rentals, netflix etc) use the internet.

    Message was edited by: vazandrew
  • crochammer Level 1 Level 1 (0 points)
    Thanks.

    I have Apple TV 1. I don't think there is a a home-sharing option in ATV 1 and I am trying to by-pass the local network because I can't get ATV to be recognized in devices at all. So I am trying to connect direct to the PC ethernet port and the ATV ethernet port to do that.

    Home sharing on my network is not working because the PC does not see an ATV to stream to. That all started when the latest itunes update screwed that up.
    I have read where you should be able to link to the ATV without a network with a direct link.

    I am trying find a direct link to the ATV so that all network issues are gone and I can get content back on to the ATV.
  • vazandrew Level 6 Level 6 (15,360 points)
    You posted in the ATV2 section, you will get a better response then by posting over in the 1G forum.
  • Alley_Cat Level 6 Level 6 (17,910 points)
    crochammer wrote:
    I have Apple TV 1. I don't think there is a a home-sharing option in ATV 1


    No there isn't

    and I am trying to by-pass the local network because I can't get ATV to be recognized in devices at all. So I am trying to connect direct to the PC ethernet port and the ATV ethernet port to do that.


    Have you not tried to pair the AppleTV with iTunes?

    Home sharing on my network is not working because the PC does not see an ATV to stream to. That all started when the latest itunes update screwed that up.


    Have you tried setting up under Settings>Computers

    NOTE CHANGING SYNC COMPUTER DELETES CONTENT ALREADY SYNCED TO APPLETV

    For sync/stream connection you need to set up the top entry in computers

    Select any existing top entry and then add a new computer to replace it - you need to enter a 5 digit code in iTunes when prompted to pair the devices.

    Same would apply for a shared streaming only connection - the computers listed below

    You can have 5 streaming computers but only 1 sync and stream computer

    I have read where you should be able to link to the ATV without a network with a direct link.


    Yes, but unless you've paired using the numerical code it won't work.
  • Alley_Cat Level 6 Level 6 (17,910 points)
    Have you paired AppleTv with the computer tomsync or stream?

    Resetting factory defaults will have caused Appletv to lose it's connection settings with the itunes library

    Equally a new computer install will be a different iTunes library to before and the connection needs to be set uo again under Settings>Computers
  • crochammer Level 1 Level 1 (0 points)
    Yes to all the last posts. I am aware of how the unit pairs with a computer. I restored factory defaults so that I could connect the ATV as if it was new out of the box. Yes when I select computers and click on the Infinite or Pair? symbol it gives me the code to use. The code number is useless unless the computer sees the ATV so you can enter the code.

    To eliminate any possible network issues, I was trying to connect direct to the PC and ATV to see if the PC would see the ATV. So far, no go, so I was hoping for some ideas on how that is done, or even if it can be done.
  • Alley_Cat Level 6 Level 6 (17,910 points)
    crochammer wrote:
    Yes to all the last posts. I am aware of how the unit pairs with a computer.


    Good, but you never mentioned this and kept talking about Home Sharing.

    You've established AppleTv can see the internet.

    I cannot believe your network card/chip has any bearing on things if
    the computer can also connet to the internet.

    This could be an iTunes problem but unlikely if you've installed an older version on a fresh OS install.

    More likely to be a network issue or security software/hardware firewall blocking communication but odd unless you've changed hardware or added new security software.

    Connect the AppleTv to your normal local network again - note the IP address in Settings>About, open a command line window Start>Run>cmd.exe

    Try to use ping command to see if you can reach AppleTv at it's IP address.
  • crochammer Level 1 Level 1 (0 points)
    Yes Alley Cat, I actually tried all that. My router pings both PCs and ATV fine and both PCs ping each other and the ATV and router fine.

    I would have thought the iTunes 9.02 would have picked up just fine but no such luck. The ATV tested out fine at the Mac store so I know that's not it. It may have something to do with the router firewall but I can'y see how.

    Time to try another router to be sure of that, unless any other ideas surface.