Previous 1 2 Next 18 Replies Latest reply: Mar 7, 2015 7:09 PM by GrNivek
kitler Level 1 (0 points)
Hi there,
I have a strange problem with my app store. Since app store has opened I could be able to download/buy applications for some time. But approx 3 weeks ago something got broken and every time im trying to download an application I get error "The application could not be downloaded. The server gave an error during download: 403 Forbidden"

I can not install ANY application because of this error. What it could be? I checked logs and there is no any errors from app store application beside this message:


12/02/2011 01:37:21 App Store[491] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary.
12/02/2011 01:37:21 App Store[491] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary.

mac, Mac OS X (10.6.6)
  • Carolyn Samit Level 10 (103,365 points)
    Hi and welcome.....

    Quit the Mac App Store if it's open.

    Open iTunes. From the iTunes menu bar click iTunes / Preferences then select the Advanced tab.

    Click: *Reset warnings* and *Reset cache*

    Go back to the iTunes menu bar, click Store / View My Account / Sign Out.

    Restart your Mac and try the MAS again.











    Carolyn

    Message was edited by: Carolyn Samit
  • kitler Level 1 (0 points)
    Hey Carolyn,
    I've tried it a couple of times and it does not work
  • Carolyn Samit Level 10 (103,365 points)
    Hi,

    Open a Finder window and select your home folder in the Sidebar on the left. Open the Library folder then the Preferences folder.

    Move the com.apple.appstore.plist file from the Preferences folder to the Trash.

    Try the MAS again. If that didn't help, there are other .plist files mentioned at this link you could try deleting.

    http://discussions.info.apple.com/message.jspa?messageID=12899910










    Message was edited by: Carolyn Samit
  • kitler Level 1 (0 points)
    Thanks a lot,
    I had to delete all the files in

    ~/Library/Caches/com.apple.appstore
    ~/Library/Caches/com.apple.storeagent
    ~/Library/Preferences/com.apple.appstore.plist
    ~/Library/Preferences/com.apple.storeagent.plist
    ~/Library/Cookies/com.apple.appstore.plist
  • Carolyn Samit Level 10 (103,365 points)
    Welcome. Thank you for the star
  • Bicontinental Level 1 (0 points)

    I had the same problem. Tried fixing permissions, deleting plist, etc. Turns out the problem was the cookie function in my Anti-Virus software. I use Intego. Once I permitted cookies it installed without a problem. We Mac people often do not think about anti-virus, firewall, etc. programs. Virtually all the problems I ran into with my Mac were caused by incompatible firewall settings, cookie settings, anti-virus, etc. etc. This should be one of the first places to look at and experiment with. I wish these programs had a setting that lets you temporarily disable these features.

  • EGTE_RPF Level 1 (0 points)

    Same for me.

     

    VirusBarrier's cookie filter was preventing AppStore somehow.

     

    Turned it off and the problem was solved.

  • antiseven Level 1 (0 points)

    I had this problem. Turned out the internet I was using was set up on OpenDNS. Changed to google DNS servers (8.8.8.8 and 8.8.4.4) and success.

  • erniefromcornell Level 1 (0 points)

    I've tried both of these fixes; deleted all 5 files listed, and reset warnings etc. Neither worked. Not running anti-virus. App store support took a week to get back to me last time and had no fix to offer. Are there any other known fixes? Thanks.

  • Scott Rose Level 3 (895 points)

    It's a shame that Apple doesn't understand what their own 403 error means, and that the 403 error doesn't provide any more information.

     

    What this error means is that you have exceeded the "download cap" that your Internet Service Provider has set for you. You have gone over your allowed download usage. Some ISP's will limit you to a certain MB size per download.

     

    This is an ISP problem, not an Apple problem. Talk to your ISP.

  • erniefromcornell Level 1 (0 points)

    Thanks Scott. I think this is the case. I just remembered I had this problem with my ISP a year ago, i totally forgot. However, along with what you point out: this was in regard to another download service, and when I ran into the problem, their error message told me EXACTLY what the problem was and I was able to deal with my ISP immediately. I've had this problem with the mac app store now for three months and they've had me chasing my own tail.

  • antiseven Level 1 (0 points)

    Go find a public wifi and try it there.

  • dogspace Level 1 (10 points)

    Thanks, Bi - that was my problem. VirusBarrier cookie filter.  Phewww; glad to be rid of that!

  • Philippmac.com Level 1 (0 points)

    Thanks for solving my Intego problem!!!

Previous 1 2 Next