6 Replies Latest reply: Nov 11, 2013 1:51 PM by nathanmc0075
TiGPS Level 1 Level 1
So here I am, doing my own thing as usual, editing, getting ready to slap on a lower third. So I decide to design it a different way this time. What if it looks like a curvy sheet of paper coming from the bottom of the screen, so that it's not just a regular suspended lower third that flashes on and off.

All good until I export the thing. It took me 2 hours to understand why FCP 7 is ignoring png transparency. Apparently, it's not how you export it, it's not the content (weird layers modes), and it's not even the DPI setting. It is the design itself. For some reason, FCP thinks you should never attempt to bring in a lower third that starts at the bottom of the screen, filling it completely. So there ya go. If you want PNG transparency, DO NOT FILL THE BOTTOM PART OF THE IMAGE. Leave some transparent space. Talk about putting your creativity on a leash.

To better illustrate this odd behavior which I would classify as a bug, I wasted 5 minutes recreating my "problem" for the world to see.

Have fun!

http://vimeo.com/19856624

Mac Pro, Mac OS X (10.5.8)
Solved by mishmumken on Feb 12, 2011 12:36 AM Solved
Hello TiGPS,

I'm not really sure how the design could possibly affect how FCP sees the file ... weirdest thing.

I do know, however, that PNG files do not support alpha channel. I noticed in your video that you went through the "Save for web" option in Photoshop ... if you simply choose "Save as", then PNG from the dropdown menu, you'll notice that that you can't check "Alpha Channel" in the save dialog - it's greyed out.

IMHO it would be much better to use a TIFF or, if you need to animate layers, a PSD file.

hope this helps

mish
Reply by Nick Holmes on Feb 12, 2011 2:07 PM Helpful
You must be doing something wrong.
I just watched your Vimeo movie and recreated it according to your description on my own computer.
The deliberately oversized, lower third fill composited instantly. Transparency was recognized.
Not a bug.

All replies

  • mishmumken Level 5 Level 5
    Hello TiGPS,

    I'm not really sure how the design could possibly affect how FCP sees the file ... weirdest thing.

    I do know, however, that PNG files do not support alpha channel. I noticed in your video that you went through the "Save for web" option in Photoshop ... if you simply choose "Save as", then PNG from the dropdown menu, you'll notice that that you can't check "Alpha Channel" in the save dialog - it's greyed out.

    IMHO it would be much better to use a TIFF or, if you need to animate layers, a PSD file.

    hope this helps

    mish
  • Nick Holmes Level 7 Level 7
    You must be doing something wrong.
    I just watched your Vimeo movie and recreated it according to your description on my own computer.
    The deliberately oversized, lower third fill composited instantly. Transparency was recognized.
    Not a bug.
  • TiGPS Level 1 Level 1
    Hello,

    Thank you for your advice. I have no experience using TIFF or even alpha channels when exporting an image. I understand how they work though, so I'll try that.

    I have fiddled with that regular save as well, and it seemed to make a difference but then again it would still not be recognized as a transparent PNG either way. It may be a bug in my setup, I don't know.

    Usually, if I want to animate something I use motion and that seems to take care of alpha channels on export. But of course, it would be a lot faster to do it right there in FCP, so thank you for again, I'll try using TIFF exports.
  • TiGPS Level 1 Level 1
    Hello Nick,

    I tend to agree with you, I must be doing something wrong or something must be wrong with my particular setup as it is right now because I've never bumped into this kind of issue before and I've been using PNGs for lower thirds for a long time.

    Will finally upgrade to Snow Leopard one of these days (got the disc but not the time) and check if after a clean install it will do the same.

    Thank you
  • Nick Holmes Level 7 Level 7
    Something else to try: I always use .TIFF files on a transparent backplate. If you get the chance, do it.
  • nathanmc0075 Level 1 Level 1

    Hi TiGPS

     

    It's a simple solution if you would like to use PNG's as they DO carry an alpha channel.  Find your PNG over in your FCP Project bin.  Right click > Item Properties.  Most likely your Alpha Channel is set to Ignore/None.  Control Click on it to change it to Straight.  Drag your PNG back to the timeline and you should have your Alpha Channel.

     

    Cheers