3 Replies Latest reply: Mar 19, 2011 5:15 PM by fosterm
fosterm Level 1 Level 1 (0 points)
I've published my website using iweb and published it on me.com. I did the other steps for the CNAME etc.

I'm trying to set up my website so I don't have to type www before domain name. It works fine with it but without it, the page appears which says in effect that it's under construction probably from the domain registrar I'm guessing.

I feel stupid asking this but I tried dragging the index.html file to the sites folder and only a copy appeared. It didn't work when I checked url.

Also, if I create the index.html which redirects to the homepage, where do I find the code to change it? Can someone give me directions? Thanks for your help.

Message was edited by: fosterm

imac g4 15 inch flat panel, imac intel, Mac OS X (10.6.5), mac os 10.4
  • fosterm Level 1 Level 1 (0 points)
    I just created the index.html which redirects to the homepage using this, I changed the "webfolder" to my site's homepage. and saved it in web/sites folder of idisk.

    <HTML><HEAD><meta http-equiv="refresh" content="0;url=webfolder/index.html"></HEAD><BODY></BODY></HTML>


    and it didn't work as well without the www. With the www, the code showed up instead.

    my website is www.mylenefoster.com
    Thanks for your help.
  • Ethmoid Level 6 Level 6 (10,380 points)
    This has nothing to do with index files and you don't need to do anything with it - you are making all more complex than it actually is or needs to be.

    Whether you get to your site using the www or not is purely a CNAME forwarding issue and you domain name registrar is where you need to fix this.

    Go to the DNS settings at your registrar, where I assume you went when first setting up forwarding? All registrars are different, but with some you need to delete the A records that are there already and set up CNAME. What you would need to do is set up 2 CNAME's, one for the www and one for @.

    @ represents your domain name on its own, so http://domain.com. Set this up as @, CNAME web.me.com.

    www represents your sub-domain, so http://www.domain.com. Set this up as www, CNAME web.me.com and then people should then be able to get to your url by using either domain.com or www.domain.com.

    There is no need to set up any kind of forwarding or fiddle around with your index file. Simply change your CNAME forwarding and it should work.
  • fosterm Level 1 Level 1 (0 points)
    Thanks for your help. I guess I got mixed up because I did a search in the forums and got very confused with all the postings that seemed related to my issue. After a lot of attempts, I was able to make it work per your recommendation.