1 2 Previous Next 20 Replies Latest reply: Jun 3, 2014 10:25 AM by Eric Root
jthedwalker Level 1 Level 1 (0 points)
Hello Everyone,



I was trying to change the permissions on my 24" iMac so that main hard drive would not be visible to everyone that could access my network. Unfortunately, I did not know that changing it would effectively lock out the computer all together. Ok, on to what I've done so far.



First, I booted with the Snow Leopard CD and repaired permissions and repaired the drive as well. Both came back with good reports. Tried to reboot and nothing. Just the gray screen of death with the perpetual wheel.



Second, I restored from a Time Machine backup from the same day I changed the permissions,but from an earlier time. It didn't work and still gave me the gray screen, but I may have been mistaken on what time I actually made the changes. I was going to try a second time, but I don't know if permissions are effected with a Time Machine restore.



Third, I tried running some commands in single user mode. /sbin/mount -uw /, /bin/chmod -R o=r,+X /, /usr/sbin/chown root:admin /, /bin/chmod 1775 /, /bin/chmod -N / I've separated them by comma's here but entered them one at a time in the command prompt. The command /bin/chmod -R o=r,+X / kicked out a bunch of errors in trying to change the permissions on the application Windows Media Player, then gave these two errors. /dev/fd/3: Not a directory, /dev/fd/4: Bad file descriptor. Then it gave a few more permissions errors on some songs. After that, I ran the rest of the commands listed above and rebooted. Again, nothing. Just the same gray screen and wheel.



I've also tried starting into safe mode. The bar comes up on the bottom of the screen but goes away, the OS just hangs at the gray screen. I've even tried running a couple sudo commands; however, I have seemed to have locked myself out of those as well.



I have many more Time Machine backup's to try but I am hesitant as I do not know if the previous permissions are attached to the backup itself, or if the changes I've made to the permissions will remain no matter what backup I restore to. I've scoured the internet in an effort to solve the problem; however, I have been unsuccessful in my attempts. It's a pretty 24" paperweight, and a nice nightlight. I liked it better as a computer though, your help would be much appreciated.

24" iMac, Mac OS X (10.6.6)
  • 1. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Barney-15E Level 8 Level 8 (35,275 points)
    I don't know if a Time Machine restore will fix the permissions. I can envision it either way, and I haven't tried it to see. But, the way I see it, you have two choices, reinstall snow leopard or restore from Time Machine.
    Reinstalling will just replace the system, but since you gave everyone read and execute permissions on all files/folders on the hard drive, all of your home folders are buggered up now as they shouldn't have those permissions. There is a way to [restore home folder permissions|http://reviews.cnet.com/8301-13727_7-10329971-263.html] using the Install Disk. Just use the Snow Leopard installer instead of the Leopard installer as the article states.

    Just because everyone had read and execute permissions on the Hard drive didn't give them access over the network. Everyone (others) are others that can log into the system. If people log into the computer with an account that is on that computer, then they have access to whatever that account had access to if physically logged into that computer. If you want to share certain folders, then create a sharing only user and give them specific access to the folders you want to share.
  • 2. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    jthedwalker Level 1 Level 1 (0 points)
    Hello Barney,

    Thank you for your reply. I'm still working toward fixing this problem. I have tried the commands from the as the article stated; however, sudo commands are not being recognized. I tried running the commands without sudo and it gives me access errors, as expected. I may just run an earlier Time Machine back up from the day before I messed up the permissions if no one can think of anything else. I'm skeptical that it would even work. Thank you for the help.
  • 3. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Pondini Level 8 Level 8 (38,720 points)
    jthedwalker wrote:
    . . .
    I may just run an earlier Time Machine back up from the day before I messed up the permissions if no one can think of anything else. I'm skeptical that it would even work. Thank you for the help.


    Yes, that should work, as long as you do a +Restore System From Backups+ from your Install disc. That will erase your internal HD entirely, and restore everything, including the permissions, from the backup you select.

    Note that the dates and times of your backups on the selection window may not be shown in your local time zone; they may be in +Pacific Time.+ See #14 in [Time Machine - Frequently Asked Questions|http://web.me.com/pondini/Time_Machine/FAQ.html] (or use the link in *User Tips* at the top of this forum) for details.
  • 4. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    jthedwalker Level 1 Level 1 (0 points)
    Hello Pondini,

    Thank you for your reply. Unfortunately attempting a second Time Machine restore didn't work. I used a backup from the day prior to my permissions fiasco. As it did not work, I would have to assume that permissions are not part of the backup when it is made. Good to know for the future. Aside from any other ideas, I think the only solution is a full reinstall with a subsequent restore from one of my Time Machine backups. I'm still hoping someone can think of an alternative solution. Thank you all for your help.
  • 5. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Barney-15E Level 8 Level 8 (35,275 points)
    Not sure what you mean by a full install, but just running the installer over the top of what's there should fix the problem. If that doesn't work, then you'll have to erase the drive, install, and restore from TM.
  • 6. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    jthedwalker Level 1 Level 1 (0 points)
    Hello Everyone,

    Just in case someone has the same problem I did. This is what FINALLY worked for me. I opened Terminal and entered these two commands.

    sudo chflags 0 /volumes/*

    sudo chmod a+rx /volumes/*

    After that I was up and running again. So, for the record, don't set "no access" on the permissions of a hard drive! That's not good. lol
  • 7. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Bramar Level 1 Level 1 (0 points)

    An alternative solution would be to acces the computer in Target mode and reset the permission on the drive. You can also startup from an external drive and reset the permissions.

  • 8. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Ayad_Eddy Level 1 Level 1 (0 points)

    Dear jthedwalker

     

    I hope you can read this message.

     

    I just had the same problem! My computer is locked out. I changed everyone permission of the main hard drive on my MacPro computer  to "no access". Could you please take me through excatly what you did to unlock your computer?

     

    Many thanks,

  • 9. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Bramar Level 1 Level 1 (0 points)

    Boot your computer in target mode from an other computer using a firewire cable and change the EVERYONE permissions back to WRITE ONLY(DROPBOX). You can also boot from an other drive but you might encounter access problems.

     

    Good Luck.

  • 10. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Ayad_Eddy Level 1 Level 1 (0 points)

    Dear Bramar,

     

    Your advice was very useful. I used the "magic" firewire 800 cable to connect the locked computer to my laptop and followed your advice. It worked. My computer is now up and running. Many thanks for your help.

     

    Cheers.

  • 11. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    cathy fasano Level 2 Level 2 (340 points)

    Also, a rant about the whole Get Info interface...

     

    Unix filesystem permissions have a HUGE number of permutations -- read, write, execute, for user, group, other, and every single file can have it's own permissions set differently from any other file.  Some unix applications do not run with permissions that are too liberal -- if one of these thinks the permission should be no access to "other" and you do a read-write-execute for everything, then the software will refuse to run.  I always *cringe* when I see that "propagate permissions down the directory hierarchy" button -- because if you run it on a big tree, there is no way to return 10s of millions of files to their previous unique permissions, at least not in your lifetime!  Also, when people are doing the "give everybody read/write permission" dance, it's often because they need to fix file OWNERSHIP not permissions at all.  And the stupid Get Info screen won't let you change the ownership of a file, you have to use Terminal.

  • 12. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    autochthon Level 1 Level 1 (115 points)

    Agree 100%!  There seems to be no helpful instructions on how to manage Sharing & Permissions using the GetInfo panel. I'd like to ensure that my user files are only readable by myself. If I log in with my Admin name and password on Partition #1 and open my home folder, I find that Myself, Staff and Everyone has Read/Write privileges, by default. Is that stupid, or what?

     

    I think so, because if I reboot as admin from Partition #2 that has its own, separate Snow Leopard system, I find to my dismay that I can still see virtually all of the contents of Partition #1, including all of my Partition #1 Admin home folder files!

     

    Again rebooting from Partition 1, when I getinfo on my admin home folder, I could set myself to Read & Write, and set 'Staff' and 'Everyone' to "No Access".

     

    But in the English language, "everyone" means EVERYONE, (which also includes MYSELF, right???) So, if I set Everyone to "No Access", will it remove MY read & write access?  Or, If "everyone" REALLY means "everyone else", why didn't they simply call it "everyone else" in the first place?

     

    Next question: Who is "Staff"?  Does that include Everyone, or some sub-set of Everyone?  Am I, as Admin, part of "Staff"? But it gets even worse: Who is "Unknown User"?  I see this appear, sometimes. Really, this is enough to drive a person to consume multiple Margaritas...!!!

  • 13. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    WZZZ Level 6 Level 6 (12,220 points)

    Do a search for "OSX Permissions" and start reading, instead of this useless rant. The best way to approach (Unix) Permissions is from the command line (Terminal), not from Get Info Sharing & Permissions, which is oversimplified and can lead to misunderstandings.

     

    It is an extremely complicated subject, but that is no reason to complain that it shouldn't be.

  • 14. Re: Changed permissions for "everyone" - "no access" on Macintosh HD, no boot.
    Jele826 Level 1 Level 1 (0 points)

    Rebooting computer in Target mode (via firewire with a host mac) allowed me to change back Sharing & Permissions for "everyone" settings back to "Read only" on my start up HD. Computer restarted fine afterwards!!!

1 2 Previous Next