Previous 1 2 Next 18 Replies Latest reply: Nov 27, 2013 7:31 AM by SShailja
Giulioangelo Level 1 (0 points)
I noticed that contacts that I text frequently are showing up in my spotlight searches with text messages that have been deleted. Sometimes as "Top Hit"
I know that I can exclude messages from the search, but I'd rather just not have deleted messages show up. Is there anyway to permanently delete SMS messages from my phone.
AT&T iPhone 4 iOS 4.2.1
I've googled this subject to no avail.

PC, Windows 7
  • Giulioangelo Level 1 (0 points)
    I'm now also noticing that if you go into the messages app and start typing in the search box at the top, it pulls up deleted texts. It will show the message but not who it was to. If you touch it, it turns blue then nothing. I'm seeing this on my iPhone and a friend's phone also. Resetting the phone doesn't help. Is anyone else seeing this?
  • tedcwynar Level 1 (0 points)
    Giulioangelo,

    I'm having the same issue with deleted emails. Have you found a solution to your problem?
  • M2TH3P Level 1 (0 points)
    I'm having this exact same problem. How can this be happening with no possible solution?
  • daveyboyuk Level 1 (0 points)
    I'm also experiencing exactly the same issue with deleted SMS messages showing up in the Spotlight search.

    I've reported this in the Apple store 1st week in April so hopefully someone will be working on it.

    The only way I have been able to clear the history is to wipe the entire phone, back to factory settings. Much quicker way right enough is to turn off Messages within Spotlight Search. This can be done by going to Settings - General - Spotlight Search - then untick Messages.

    A few of my friends have exactly the same issue, all using exactly the same phone - iPhone 4 - 16Gb. However, some other friends using the iPhone 4 32Gb haven't encountered this problem at all, so it might be limited to the 16Gb model.

    It would be useful to know what model everyone else has?

    Here's a discussion I have found elsewhere - which goes into detail on how to backup and erase your phone.

    http://forums.macrumors.com/showthread.php?t=1047576

    Lets hope Apple fix this bug sooner rather than later
  • digitalqualms Level 1 (0 points)

    It's not fixed in 4.3.3. I've reported it to the feedback page every time an update has been released that doesn't fix it.

  • GregTB Level 2 (215 points)

    This is a very interesting problem that I have no heard of. I am currently using a Black 16GB iPhone 4 running iOS 4.3.1, and I'm not having this issue. I will update to the most current version and let all of you know if the problem starts to happen following the update.

     

    - Greg

  • blassiz Level 1 (0 points)

    1. Download iPhoneBrowser (Windows)

         http://iphonebrowser.googlecode.com/files/SetupiPhoneBrowser.1.93.exe

     

    2. Connect iPhone via USB

     

    3. Start iPhoneBrowser & Delete all files in following 2 folders:

     

        /private/var/mobile/Library/Spotlight/com.apple.MobileSMS/

     

        /private/var/mobile/Library/Spotlight/com.apple.SpotlightTopHits/

     

    4. Restart ur iPhone

  • Lily from townsville Level 1 (5 points)

    Hi I have an i phone 4 32GB and I accidently deleted SMS text messages and I WANT TO RECOVER THEM (not delete them). Can anybody help me? I did not back up the iphone to my computer. I am not very computer savy but if someone could give me assistance I would be sooo grateful - PLEASE

  • jenfrombelmont Level 1 (0 points)

    Does anyone know if ios 5 fixed this problem? 

    A friend of mine, who has an iphone 4 and hasn't upgraded, mentioned this issue to me today, but I've got an iphone 4s and am on ios5 and don't have the problem.  Just wondered if upgrading will fix it so that deleted messages don't come up in the spotlight search

  • Pandaflop Level 1 (0 points)

    i had this problem and after searching the net i found 3 solutions, first an explanation of the problem, certain items, sms messages/ emails dont get deleted from the phones memory when u hit delete, they are marked for deletion. now short term to prevent them showing up in the spotlight search you can change your spotlight search settings by selecting setting>general>spotlight search, here you can edit what gets searched, next you can erase all data and media in settings>general>reset, this is a bit extreme especially considering the easiest method i found which worked for me, sync your iphone with your computer via usb, this will delete all items marked for deletion in your phones memory, do a full sync and it will work

  • Trumania Level 4 (1,160 points)

    I believe the items will be removed from spotlight after some time. Try turning your phone off and back on and see if the issue remains.

  • iDeviant Level 1 (0 points)

    this blows! i have same problem on my iphone 5, you would think they would have fix this already.

     

    why dont they feature this problem on the tv commericals.

  • tejeshwar95 Level 1 (0 points)

    My advice, people let's all make sure apple notices this bug, cause only they can fix it. So, lets all report this and hopefully it will get fixed soon, cause I am also experiencing the same problem.

  • sjohnson90 Level 1 (0 points)

    go to settings: General: spot light search: then pick what you want to see

     

    hope this helps

Previous 1 2 Next