Previous 1 2 3 4 5 6 Next 211 Replies Latest reply: Aug 30, 2013 7:41 AM by ellenfrommn Go to original post
  • jp717 Level 1 (0 points)

    Hi there, I have removed and reinstalled iTunes five times already with the latest version.  The results are still the same: a blank space where the iTunes Store display is supposed to be available.  My other computer has it up and working; this one has Windows Vista and Norton Securities 2011 recently installed.

  • Angel8586 Level 1 (0 points)

    I had just updated my nortons too but i unistalled and deleted it a few time and it still didnt work..Does anyone know how to fix it??

  • Lucky482 Level 1 (0 points)

    My iTunes store starting doing this about a week ago too.  I'm running Windows 7 64-bit edition and the most recent version of iTunes.  I haven't been able to access the store at all - all I get is a white screen.  When it does attempt to load on the few times that it does, I might get a window that looks like Java is messed up to the point where I see no graphics just some blue text.  I've tried the iTunes U disable the store/enable iTunes U thing, that doesn't work.  The diagnostics all pass correctly without any failures.  I'm trying a complete uninstall of it and a reinstall.  This started for me with the most recent update to QuickTime but I doubt that's related with the store.

  • Nonnie Level 1 (15 points)

    Same problem for about a week.  Re-installed itunes with no changes.  Why is there no solution from apple yet?

  • Nonnie Level 1 (15 points)

    Just saw upgrades suggestions on pages 2 and 3.  I checked all the parental controls items, downloaded itunes 10.4, latest upgrade, which I already had, nothing!  Still a blank screen when I go to the itunes store.  How can you purchase anything if you can't get into the store?

  • Hchlee Level 1 (0 points)

    I once encountered exactly the same issue. I was using ISA(Internet Security and Acceleration) by then. When I disable it. the problem disappeared. If you're using isa or other internet accelerate tool when accessing itunes store,  you can try disable it for a while and try.

  • Angel8586 Level 1 (0 points)

    what do you mean accelerate tool?? All i have is nortons    

  • Lucky482 Level 1 (0 points)

    Hi Everyone!  I finally got my itunes store working again.  Apparently something with the update corrupts one of the components of itunes so unless you remove all the components and reinstall, it's not going to fix it.  Here's what worked for me:

     

    Follow the uninstallation instructions at http://support.apple.com/kb/ht1925 removing each component in the order that is indicated.

    Make sure that after you delete the folders in step 2 that you restart your computer.

     

    The link for Windows Vista and Windows 7 is

    http://support.apple.com/kb/HT1923

     

    For the most part, it is very similar but this link also has the 64-bit locations of the folders that need to be deleted.

     

    Good luck!

     

    After the restart, download the newest version of itunes from the webpage and let it install.  This fixed my problem and my store works just fine now.  Hope that it helps your issues.

  • Lucky482 Level 1 (0 points)

    Originally had a duplicate post here because I didn't know I can edit the previous one.  Can't delete this one so typed over it.

     

    Good luck and hope the solution works for you.

     

    Message was edited by: Lucky482

  • Angel8586 Level 1 (0 points)

    yes!!! it worked you are a life savor

  • jedizim Level 1 (0 points)

    Worked for me too!  Thank you, thank you, thank you!! 

  • TheInvisibleMachine Level 1 (0 points)

    ******************************************************************************** ***************************************************************

    Hold on a minute ........ a much much easier fix can be found at https://discussions.apple.com/message/13124170#13124170

    ******************************************************************************** ***************************************************************

     

    You don't have to uninstall/install and all that nonsense .........

     

    Copied text below ::

     

    Here's the fix! Go under Edit - Preferences - Parental Control -Where it say's disable, check ITunes Store and then check Allow access to Itunes U. That did the trick for me, although checking the box in the disable section doesn't makes sense

  • Denise Woodcock Level 2 (375 points)

    disabling the itunes store and then ticking allow access to iTunes U just crashes my itunes.  The only part of itunes store I cannot access is the App store.  Rest is okay.

     

    And I don't have the quick time update.

  • davidfromeast norriton Level 1 (0 points)

    I actually think QuickTime is the culprit.  I did the uninstall and reinstall and all was fine, I could get into iTunes store and backup iTunes.  Then along came a QuickTime update that I made a mistake of installing and back to square one, can't backup or get into the store.  In the process of doing the install once again.

  • khalidfromcairo Level 1 (15 points)

    Check this out bro , the solution is there : )

     

    https://discussions.apple.com/thread/3275295?tstart=0

     

    Best wishes : )

Previous 1 2 3 4 5 6 Next