5 Replies Latest reply: Feb 2, 2015 7:19 PM by gseb
Brian Guam Engineer Level 1 Level 1 (25 points)
I moved an Intel Mini from an Airport network to an ethernet connection on the same network. Safari now has issues loading SOME but not all web pages. One page with a problem is www.macrumors.com - the content on the page loads but Safari stalls, apparently trying to load all the ads.

The stall makes it impossible to use Safari, and needs to be "force quit".

Other ethernet-connected Macs have no issues.

I've done the usual troubleshooting; DNS, disabling DNS prefetching, etc. but nothing seems to resolve the issue.

Intel iMacs, Mac Mini's, Macbook Pro, iPhone 3G, Mac OS X (10.6)
  • Carolyn Samit Level 10 Level 10 (95,975 points)
    Hi Brian,

    From your Safari menu bar click Safari / Reset Safari. Select the top 7 buttons, click Reset.

    Quit Safari, then relaunch Safari.








    Carolyn
  • Brian Guam Engineer Level 1 Level 1 (25 points)
    Sorry Carolyn, I should have mentioned I've tried this already as well.

    No difference.

    It's also odd that the Safari listing in the "Force Quit" window says "not responding" very quickly after the web page starts to load - within 15 seconds.
  • Carolyn Samit Level 10 Level 10 (95,975 points)
    I came across this link and thought it might shed some light on the issue for you.

    http://support.apple.com/kb/TS2296

    As for "force quit"... are you referring to the Activity Monitor where you can force quit an app?

    If you have any Safari Extensions installed, that could certainly be a factor. Safari / Prefereneces - Exeensions.

    Or, third party Safari add ons.

    http://support.apple.com/kb/TS3230?viewlocale=en_US

    If you have an "adblocker" installed, that could be preventing pages from loading 100%.










    Carolyn

    Message was edited by: Carolyn Samit
  • odhinnsrunes Level 1 Level 1 (0 points)
    I had a similar problem. Safari would stall with the spinning beach ball of death on any page with Flash regularly every couple of minutes for up to a minute.

    The answer after I looked at the console was that there were problems with files. I booted to the Mac OS install disk and ran Disk utility to repair the main hard drive.

    After that everything worked fine. I think there was a file that the system was trying to access that was corrupted. While this was happening, it would block certain calls that Flash was trying to make.
  • gseb Level 1 Level 1 (0 points)

    I have tried all of these solutions and find that at times nothing resolves the problem with Safari stalling except for switching from wi-fi to another connection method.   This is happening on different networks(routers) and is resolved if I disable wi-fi and connect via another means.    My 6 year old  OS-X on a 11 yr. MacBook pro never has any issues and is ALWAYS 3 times faster than the new Safari runs on a much more powerful machine running on the same wi-fi network.   Wish I could switch back to the older Safari.

     

     

    Here is my story:

     

    When Yosemite came out I installed it (and have applied all available patches) on my MacBook Pro,MacBook Air and 2 IPhones and now having problem with Safari stalling at 25% load progress point in webpage download at a fairly high frequency.    YOSEMITE REALLY *****  -- need to now figure out how to the MAVERICKS installed.

     

    Meanwhile,  I have another MacBook Pro -  11 Yr. old and 6 yr. old Safari and it is rock solid reliable and on average it's 3 times faster in loading (when compared to YOSEMITE when it's working that is).      As a result,   I had to download anothe r browser and as you would expect,  I am not having these problems with anothe r browser.

     

    Avoid YOSEMITE is you care an ounce about have a reliable Safari browser.

     

    Thanks for wasting my time Apple -- now I got the hours/hours of trying to reload 4 devices with MAVERICKS.

     

    I believe the issue has to do with using Safari via a Wi-Fi connection as when I turn on Wi-Fi on the Iphone's the problem seems to be resolved.     Unfortunately it's not an easy option to disable Wi-Fi on the MacBook Pro's/Air as it wouldn't be much fun to connect up with an ethernet cable.    It's not the Wi-Fi connection itself as it happens on all Routers in multiple locations and the 11 yr. old MB running 6 yr old Safari doesn't have the same problem.