0 Replies Latest reply: Feb 16, 2011 11:20 PM by SiliconLunch
SiliconLunch Level 1 (0 points)
I attempted to backup and restore a 2TB external raid storage device using the recommended Disk Utility procedure for 10.6.6. One of the HDDs in the raid enclosure had started to fail.

First step was to create a new image from the 2TB device. I accepted the defaults of compressed image format and no encryption. The image took about 15 hours to create, and when complete, I was left with 2 files:

OWC2TB.dmg (1.1TB)
OWC2TB.002.dmgpart (486GB).

To check the DMG I ran the Disk Utility "Verify Disk" on the DMG, and got the message "The volume OWC2TB appears to be OK". The DMG is described in DU as:

Description: Apple UDIF read-only compressed (zlib)
Connection Bus: Disk Image
Total Capacity: 2 TB
Disk Write Status: Read Only
Partition Map Scheme: No partition map

I then replaced the failing HDD in the enclosure, recreated a new 2TB filesystem on the device, and attempted to restore from the DMG image.

The first attempt was to use Disk Utility "Restore" function. I specified the DMG as the source and the new device as the destination, and chose "Erase Destination". This failed immediately with the error "Restore failure. Could not find any scan information. The source images needs to be imagescanned before it can be restored".

After researching this error I tried to correct it by selecting the DMG in Disk Utility and running Images => Scan Image for Restore. This failed immediately, complaining there was insufficient disk space. More research revealed it needed the same amount of spare space on the same disk to do an imagescan. So I had to free up an EXTRA 1.5TB of space in addition to the space the DMG consumed. Not very user friendly.

The next attempt to imagescan the DMG got further than the "insufficient space" error. It displayed "Scanning image OWC2TB.dmg, Block Checksum Partition #1". This ran for about 10 hours. At the end, it displayed a new error message "Unable to scan OWC2TB.dmg (internal error)".

Next I tried to mount the DMG and copy the files manually. My first attempt at this resulted in a "Verifying..." phase which looked like it will take about 10 hours, so I clicked "Skip". Soon after I got an error message "Unable to attach OWC2TB.dmg (no mountable file systems).". Now I am trying a mount with the Verify option...

Can anyone suggest what I can try next to restore the DMG?

I think the problem might be the fact the DMG is split in two parts, but the imagescan/restore software does not know how to read the second part? Is there a way to join these into a single DMG?

Mac OS X (10.6.6)