Previous 1 2 3 Next 71 Replies Latest reply: Jan 8, 2015 7:15 PM by bnorgeot
iLukeKendall Level 1 (35 points)
Hey guys,

Was just wondering if anyone could shine some light on the problem I'm experiencing at the moment.

For some unknown reason, my MBP (current model, with latest firmware) keeps 'forgetting' the trackpad settings I choose every time I restart/turn it off and on.

The issue lies with the settings for enabling 'One Finger' settings, specifically 'Tap to Click', 'Dragging', and 'Secondary Click - Bottom Right Corner'. I'll tick the settings, but after a reboot the boxes are unchecked again.

This is pretty annoying as I'm having to change the settings every time I turn my computer on.

Does anyone have a solution to my issue?

Many thanks,

MacBook Pro (Current), Mac OS X (10.6.6)
  • Linc Davis Level 10 (192,436 points)
    Those settings are stored in the file Library/Preferences/.GlobalPreferences.plist in your home folder. The file may be corrupt. I suggest you move or rename it, log out, and log back in. Then set up your trackpad again and see whether the settings stick across sessions. You'll need to set quite a few other preferences as well.

    Note that the file is invisible in the Finder by default, so you'll either have to show invisible items or use the shell to get to it.
  • iLukeKendall Level 1 (35 points)
    Thanks for you help...

    I followed your instructions yesterday, and it seemed to work after a restart.

    Today however, I've turned my MacBook on again, and the same problem has occurred - it's only the 'One Finger' settings that seem to be doing this :/

    Any further advice?
  • Linc Davis Level 10 (192,436 points)
    The next question is whether the problem lies in your user files or in the operating system. Log in to the guest account (enabling it if necessary in the Accounts preference pane) and see whether you can reproduce the problem there. If you can't, then something is wrong with your account. If you can, then something is wrong with the system, the hardware, or third-party software that you installed.
  • iLukeKendall Level 1 (35 points)
    I just performed another restart after enabling the guest account, but signed into my main account to test if the problem was persisting first.

    It seems it's happening randomly on some boots, but not others... annoying :/

    I've been having a few issues since I began using Time Machine - I performed my first backup, however the following day my AirPort began to have issues in that it was slow to acquire an IP address. I restarted the router as was recommended by another user of this forum, however after that, my MacBook wouldn't connect at all.

    I ended up restoring to the backup I had made previously, which fixed the AirPort problems, however my MacBook now seems to be running much slower than before, and also this issue with the trackpad settings has occurred. It's strange.

    I'm contemplating a fresh install of OS X, but obviously it's hassle and will take a while to re-install all my software.
  • Linc Davis Level 10 (192,436 points)
    An intermittent problem might be hardware-related. If you're close to the end of your warranty, consider taking the machine to an authorized shop to be checked out.
  • Peter Honeyman Level 1 (5 points)

    I have been having the same forgetful trackpad settings problem reported by OP for several months now ... it's annoying, but somewhat easier to fix on the occasion than to try to understand what's going on.  But it happened again this morning, so I googled macbook forgets trackpad settings and that took me here.  No answers, but I agree with the overall hypothesis that it's time for a fresh OS install.


    Fact is, my (i7 8GB) MBP has been panicking on a regular basis for a while, always


    panic(cpu 2 caller 0x226b57): "thread_invoke: preemption_level -1, possible cause: unlocking an unlocked mutex or spinlock"@/SourceCache/xnu/xnu-1504.9.37/osfmk/kern/sched_prim.c:1471


    with the locationd process implicated.  This bug has persisted across several Snow Leopard major updates, more or less on a monthly basis.  (I have taken to writing "I hate you" in my the love note section of the (anonymous!) report to Apple.)  I am guessing that my network stack, infiltrated by both Cisco VPN and VMware, has been become a battleground for control by a bunch of witless giants.


    But I have strayed from the trackpad problem ... I just wanted to s.o. that I have symptoms just like iLukeKendall.  I guess I'll reset PRAM.  (Old school shout out!)

  • iLukeKendall Level 1 (35 points)

    Just to bump/update this post really...


    I've now been experiencing this problem ever since I first reported it back in February.


    Since then, I have reset the PRAM, and even done a completely clean install of the OS, but am still experiencing the same issues. Whilst a very simple problem, it is extremely annoying having to re-enable settings every time I boot my laptop.


    Any other advice anyone could offer me would be greatly appreciated. Many thanks.

  • jwestover Level 1 (0 points)

    I have just started experiencing a similar issue. I have done a PRAM reset and an SMC reset which has been no help.

  • bigheadjer Level 1 (10 points)

    I've been experiencing this as well since about the same timeframe as the OP.  Just upgraded to 10.6.8 and the same problem still occurs.  I have done a find/grep on all plists in ~/Library/Preferences and /Library/Preferences and the only plist that contains trackpad and mouse settings are in .GlobaPreferences.plist and those contain the right values.   BTW I ran into some other users having this problem which is related to them having installed and tried out MagicPrefs at some point.  I did, but I followed all instructions for removing MagicPrefs but to no avail.


    Did any of you also try MagicPrefs at some point?

  • iLukeKendall Level 1 (35 points)

    I have used MagicPrefs ever since purchasing my MacBook, so sounds as if you could be onto something there. I'm tempted to send an email/bug report to the developer of MagicPrefs, as it is an extremely annoying issue.


    Although, if you've uninstalled it and still had problems, then maybe it's not MagicPrefs :/

  • bigheadjer Level 1 (10 points)

    Yeah the thing is I wasn't the only one with problems post-uninstalling MagicPrefs.  I might send a separate email to the developer of MagicPrefs as well to ask.  It seems like .GlobalPreferences.plist seems to keep getting overwritten, and MagicPrefs seems to be the common link for this issue.

  • BarbarellaTV Level 1 (0 points)

    I've never used MagicPrefs, but i've been experiencing this problem since I upgraded to 10.6.8..can be an upgrade problem?

  • Brad Bishop Level 1 (10 points)

    Something I just did that worked for me:


    Go to: Utilities -> Disk Utility

    Select your Mac's drive.

    Select the "First Aid" panel

    Click on "Repair Disk Permissions"

    (it'll churn for a while)


    Then reboot.


    Then make your settings changes.


    Then reboot and verify.


    Seemed to work for me.


    Good luck!

  • Brad Bishop Level 1 (10 points)

    Never mind... A reboot later and it was back to the way it was.


    This is very frustrating.

Previous 1 2 3 Next