Previous 1 2 Next 15 Replies Latest reply: Jul 9, 2013 2:58 PM by SatanMAT
Marc Monaro Level 1 Level 1
Before I do what I think I am supposed to do... I wanted to run this by you guys first to make sure incase someone found a way. I wish i didn't have to do this but...

I have a Mac on our domain running 10.6.6. It had a seizure of some kind and i was forced to cold boot it. We got it back up and running and to the login screen, but when we tried logging in to it, the login in screen just shook. No matter what AD account i tried logging in with, SHAKE! SHAKE! SHAKE The next thing i decided to do was unbind and rebind the Mac thinking maybe it had something to do with that. NO GOOD. Not only did I get an error that the Mac could not unbind from our domain, but now, no matter what account i use to try and rebind the mac, I get the dreaded: invalid username and password combination error. WHEN I KNOW THAT'S NOT THE CASE!

Anyone know how to fix this OTHER THAN downgrading to a version of 10.6.x that CAN bind? If that's even a option???


Mac Pro, Mac OS X (10.6.6), Active Directory on the Mac *****!!! It always has...
  • Marc Monaro Level 1 Level 1
    COME ON! You've got to be kidding me?

    Here, I'll rephrase it...

    How do you fix the dreaded, 'INVALID USERNAME AND PASSWORD COMBINATION' when trying to bind a 10.6.6 Mac to Active Directory when you know the username and password are correct?

  • Kappy Level 10 Level 10
    See Special Report- Active Directory Issues with Mac OS X Leopard. Also do a Google search where I found quite a number of links to discussions some of which offered possible solutions.
  • baltwo Level 9 Level 9
    Ultimately, sounds like something for MS to resolve.
  • NoMacs Level 1 Level 1
    Why is that always any Apple support person or Mac users answer? It's a Microsoft problem. How can it be, I have 20 macs connected to the same network. The mac having the problem has been successfully working for 3 months. It started shaking when the user came in and in the troubleshooting process we removed it and are trying to rejoin it backl on to a domain it has been working on for months and 19 other machines are still working on. How is this a microsoft problem? Please enlightne me? If it sounds like I am frustrated, I apologize, but I AM!
  • NoMacs Level 1 Level 1
    By the way, if you come across this problem, run the following commands at a console prompt (terminal).

    sudo rm -rdfv /Library/Preferences/DirectoryService
    sudo rm -rdfv /var/db/dslocal/nodes/Default/config
    sudo killall DirectoryService

    Then try to Rebind client.
    This fixed it for me and I didn't have to do anything to my AD Microsoft server.
  • Marc Monaro Level 1 Level 1
    NoMacs, I didn't get a chance to try this.
    In the end, I had to reinstall the system from disc.
    From 10.6.6 back down to 10.6.4. Once I did that, i was able to bind.
    Upgraded back to 10.6.6 and now 10.6.7, and so far so good.
    If and when this happens again, I'll definitely try your little fix.
    Thanks a bunch!
  • cookied Level 1 Level 1
    Thanks NoMacs, resolved my issue.
  • Level 1 Level 1

    This worked for me many thanks for the tip... I look after 400 + students and staff this has just started happening on some of our 10.6.7 clients.





    Univeirsity of Gloucestershire

  • bcforrest Level 1 Level 1

    Just as an aside, if this crops up again, boot into Single User Mode and type in the date command to make sure the date and time are within five minutes of server time. If the time drift is outside five minutes, active directory won't authenticate. You can enter date hhmm in 24 hour format (3:14 pm would be 1514) to reset it.

  • receng Level 1 Level 1

    Thanks NoMacs!!! Solved my issue too.

  • F4st3ddy Level 1 Level 1

    The problem has been solved by running the commands on a 10.6.7 client.


  • Erickson23 Level 1 Level 1

    NoMacs, thank you so much, this worked perfect.  We are a school and have over 600 client machines about 50 of them Macs.  We use a Windows 2008 Active Directory environment.   Never had this problem before until today.  A teacher brought me a macbook that would not login.  All that I read online was that it was a MS issue, I knew that it had to be the machine because everything else including the other mac machines where fine.


    Thank you for clearing this up.

  • vargsa Level 1 Level 1

    NoMacs, this worked like a charm. Sat for several hours pulling my hair out trying to fix this and your terminal commands did the job. Thanks so much!

  • fesheila Level 1 Level 1

    Thanks NoMacs! Worked like a charm!


Previous 1 2 Next