Previous 1 2 3 Next 41 Replies Latest reply: Mar 1, 2014 9:20 AM by BDAqua
DunhamR Level 1 Level 1
It appears that 10.5.8 will not support a 3TB external drive as a single unit? Hitachi has a patch for windows but they indicate that Mac Os X should support the 3TB drive. Do I have to upgrade to 10.6 ? The Drive is recognized as 768GB drive and the limitation seems to be 2.2Gb . Is there a workaround?

MacBook Pro 5.1, Mac OS X (10.5.8)
  • Klaus1 Level 8 Level 8
    Have you formatted the drive as Mac OS Extended (Journaled)?
  • macrapn Level 1 Level 1
    it doesn't work with a format mac os (journaled)
    it only sees 801GB instead of 3TB (Hitachi 3TB)
    any ideas?
  • torana355 Level 1 Level 1

    I have the same issue. I have a Stardom external enclosure that supports 3tb with a Hitachi 3tb drive installed. I am running Lion and it only sees 2.2tb, not the full 3 tb. I have a feeling its a Lion issue??? Any ideas?

  • BDAqua Level 10 Level 10

    2.2 TB is the limit of AFP Partition scheme, try GUID Partition scheme.

  • v8media Level 1 Level 1

    I just got myself a 3tb drive and I'm having the same issue. I have four different SATA enclosures and I have the same problem in all of them (and only a Mac Mini and laptops, so no way to try internally). I'm betting all four of those are not capable of running 3TB drives. I just ordered a cheap enclosure that's listed as supporting 3TB in windows, but I'm not finding much about Mac OS X support, either for the enclosure that I ordered or in general.


    I also tried reformatting the drive in each enclosure, but all would only allow 800GB.


    Can anyone confirm any external enlosures that they own support 3TB?

  • jhellstrom Level 1 Level 1

    Make sure you partition the drive, don't just erase it, you need to partition the drive as GUID partition.

    It works fine here with a 3TB disk on 10.5.5.

  • v8media Level 1 Level 1

    What brand of enclosure are you using? As I said, I've tried this with four different ones, all of them partition out to 800GB. Still waiting on the one I ordered, and I'll let people know the brand and if it works or not.


    Thanks, Ian

  • Tony10am Level 1 Level 1

    I am having the same problem.  Hitachi 3TB drive, I just erased and went to partition and it says size 801.23 GB. The Partition Map Scheme is listed at GUID Partition table.


    Any ideas how to access the full volume of the drive?



  • p51flyer Level 1 Level 1

    I have encountered the same problems using 3TB drives with most external drives connected via either USB 2.0 or through Firewire 400 / 800.  However, the drives that also have eSata capability DO work properly and allow use of the full external 3TB drive connected to a MacBook Pro with an external eSata PCMIA card.  Thus the problem appears to be with the USB or Firewire connection in my experience, because using those connectinos the iMac or MacBook Pro can only see 800GB of a 3TB drive, but using eSata connection it can see the entire 3TB.  Anyne with technical thoughts on WHY that might be?


    FYI, the Macally external drive enclosure (about $67 from Amazon - see works just fine with the HItachi 3TB drives (successful with both the "green" variable speed and the continuous speed 7200 RPM Hitachi 3TB drives) connected via Firewire 800 to our 27" iMac (late 2009 model) and 17" MacBook Pro.  Good luck!  WES

  • p51flyer Level 1 Level 1

    Forgot to add that both machines are running 10.6.8, just FYI. 

  • BDAqua Level 10 Level 10

    Great post/tip, thanks!

  • p51flyer Level 1 Level 1

    Some additional observations:  I installed one of the HItachi 3TB (Green, variable speed) drives (yes, using GUID partition at initialization) in an older G5 Mac running 10.5, and it recognized the drive and would format it in Mac OS Extended (Journaled).  However, the size was only 2.7TB, and when I tried using the G5 as an external drive in target disk mode with the 27" iMac (running 10.6), it would recognize the 150GB system HDD, but insisted on initializing the Hitachi 3TB drive as an 801.57GB drive in Mac OS Extended (Journaled).


    I also tried the tarket disk mode using a 13" MacBook Pro running Lion (10.7) and it did the exact same thing.


    Note, it shows the S.M.A.R.T. status as "Unknown" when erroneously depicting the drive as 801.57GB, whereas it is "verified" when connecting with eSata cables where it shows the proper 3TB size and will format properly all day long?  Again, eSata works great, but no easy way to have an eSata connection in the iMacs or smaller MacBook Pros.


    Note I also installed one of these Hitachi 3TB drives in a 27" iMac (late 2009) and it ran so HOT (fans going wild, WAY too noisy) that I took it out an reinstalled the original factory 2TB drive.  YES, I installeld the thermal sensor correctly, and YES I used the same manufacturer for the HDD, and YES I tried the various fan speed software, but the fans were running and it was noisy just because the drive runs HOT from what I can tell, even in an external enclosure.


    This is going to be a real problem as the need for larger 3TB (and more) storage exists, so I hope someone figures out why

  • BDAqua Level 10 Level 10

    Thanks again,

    it shows the S.M.A.R.T. status as "Unknown"

    USB & Firewire do not support S.M.A.R.T. status last I knew.

  • v8media Level 1 Level 1

    Just wanted to follow up that the enclosure I got works perfectly over USB (it's just a backup drive, I don't need speed). Disk Utility was happy with this enclosure and had no problems seeing, partitioning, and formatting the full 3TB. I've been cloning my previous backup drive over for the last many hours, but tested out some file copying and reading beforehand. Works well.


    Cheapo Rosewill RX358 v2 ($35 from newegg) with a Hitachi Desktar 0S03208. Works fine in both 10.6.8, and 10.7.1. Haven't tried anything but USB.


    Thanks for the other helpful posts.

Previous 1 2 3 Next